Question

Arc and Google Assistant


Hi, having just set up the Arc and a Gen 3 Sub, I thought I would add Google Assistant.

Unfortunately, when I get to the point, where it asks you to login to my Sonos account, it just say that my email address or password is incorrect!

I checked and double checked my Sonos account details, and I am inputting the correct details.

I have also uninstalled and reinstalled Google Assistant, but it still says my account details are incorrect.

Now what?

TIA


14 replies

Badge +1

reset the password and try again.

Have done that, and still doesn't work!

Also cannot connect Arc with Google Assistant. Arc updated with latest software, verified same WiFi network, newly-installed Google Assistant app, but every attempt results in failure to recognize the Arc.

Userlevel 3
Badge +4

are you sure it is asking for your Sonos account credentials and not for a Google account?  you’ll need a to provide a Google account for the Google Assistant.

i was never asked for account credentials (either sonos or google) but was asked to allow the Sonos device access to my Google account for the Assistant service to work (and agree to the service terms, etc).  i am using an Android phone logged into the same account as i use for the Google Assistant). if you’re using an iOS device this process may work a little differently.

Badge

So I also can’t add google assistant/get the arc’s mic to work  

 

I can add the Sonos as a service to my google home but assistant won’t appear as service on the s2 app and the arc won’t respond to ‘hey google’

 

Pic shows how the room looks on my home app

 

any ideas welcome

 

 

I followed the details from Sonos as shown below.

So you are asked to sign into your Sonos account. But like I said, it says my account details are not correct, when I know they are. Go figure.

 

 

Userlevel 3
Badge +4

@Cielo Alto - hmm, as i noted i was never asked to sign into my Sonos account or my Google account.  in the Sonos app, i am already logged in and i already have Google Assistant configured on the same android phone with a Google account. when i start to add the voice service it just launched the Google Assistant setup and asked me for permission to allow the Sonos service to access my Assistant account.  i just now removed it and re-added it to make sure the steps were as i remembered.

from the screen shot it looks like you have a recent android device as well.  do you already have google assistant setup and configured on that phone?  if not, it might be worth doing first before launching the Sonos setup portion. also, make sure you’re logged into your account in the sonos app before trying to add the voice service.

if none of that works this might be a situation needing a call to support.

Userlevel 3
Badge +4

@PSmart86, that “Sonos TV Control (room name)” in the Google Home app doesn’t appear to actually do anything. it appeared there before i setup the voice service and did nothing but confuse the voice assistant about my other room devices. after setting up the voice service it is also there and still doesn’t appear to do anything and (as in the pic below) google home says it isn’t responding and flips from “Connecting…” to “Not responding.” google assistant voice commands to and via the Arc do work though and after setting up the voice service the google assistant stopped being confused about that room’s devices.

 

Badge

Yes but I can’t get beyond this pint to set up the voice assistant with the S2 app. How’d you manage it. 
 

ive followed the steps multiple times. All apps most recent version and same google account. No improvement with deleting everything and reattempting. 
 

doing something wrong but can’t work out what. 

Userlevel 3
Badge +4

@PSmart86, the display screen pic you showed is from the Google Home app, not the Google Assistant app.

also, it looks from the notification bar like you are using an Apple iPhone so my setup experience may be different than yours. you might check to make sure you have the Google Assistant app installed before adding the voice service in the Sonos app.

Badge

So I had installed the assistant app prior to adding voice. Was just showing that I get some indication of the arc being added but no voice assistant. 
 

everytime I get the s2 to try and add google assistant it keeps bringing me to the App Store page for the assistant app; regardless of the fact I’ve already got it installed. 
 

I think this link within the s2 app has got to be broken and might be why the process isn’t completing. 
 

anyone else have similar problems with being forced to the App Store?

Userlevel 3
Badge +4

So I had installed the assistant app prior to adding voice. Was just showing that I get some indication of the arc being added but no voice assistant. 

 

ok, just checking. :-)

 

 

everytime I get the s2 to try and add google assistant it keeps bringing me to the App Store page for the assistant app; regardless of the fact I’ve already got it installed. 
 

I think this link within the s2 app has got to be broken and might be why the process isn’t completing. 
 

 

any chance the Assistant app isn’t up to date? as i noted, i’m not an iOS user so can’t test myself. this does look to be an issue that would warrant a support call.

Badge

It’s Version 1.8.9604 of the google assistant iOS app, being the update that was released last week. 
 

Well, it looks like a call to Sonos, as although I have google assistant setup on my phone, its still a no go. I have no trouble with using Alexa though, instead of.

Reply