Question

Why does my entire system show as WM:0?

  • 25 November 2020
  • 1 reply
  • 1100 views

Userlevel 5
Badge +6

Hello.  Thanks in large part to the support from these forums my system has been working just fine since I installed it and worked out the kinks.  That’s about 1.7 years.  

Today one of my sub-woofers just randomly started dropping out.   I’ve long ago assigned IP addresses to everything in the network so it’s not that.  I decided to look at the “about my system.”

In my set-up, I have around 19 speakers with many (not all) of the devices connected by ethernet.  Some speakers are paired as part of a left/right stereo speaker and some are paired with a sub-woofer.

 

Every speaker in my system shows as WM:0.  I don’t have any WM:1 or WM:2.   I don’t understand that?  If one of the speakers is not connected by ethernet, should that be WM:1?  Or do I misunderstand how that works?

In my case, the Kitchen Amp may be connected by ethernet but the sub-woofer is not, so I’m not sure if that’s WM1, 2 or 3. 

 

I’ve attached my Network Matrix just in case anyone needs to see that.

 

I’d like to make sure there is not something here that is causing the sub-woofer to drop out for some reason. Would like to make sure I understand the WM issue as I’m confused by what I’ve read versus my system.  Thank you!

 

 

One edit after I posted:  I found another thread here that says WM:0 can also mean it is connected to an ethernet-connected unit using SonosNet, so maybe that’s why some of my devices show as WM:0 though not connected by ethernet.  But shouldn’t some still be WM:3?  Or does that mean not using SonosNet?  I don’t think any of mine are using  the house Wifi, so all ethernet or SonosNet, if I understand all this correctly.  Thank you!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @TheRamblinMan, thank you for reaching out to us. We appreciate you for letting us know about your concern and for providing your network matrix to see your system.

​The WM codes indicate how your Sonos product was set up and work in your system.

  • WM:0 - Sonos is functioning in SonosNet
  • WM:1 - Sonos players, that are not satellites/surrounds, are functioning in station mode (wireless connection).
  • WM:2 - Satellite players (surrounds/Sub) that are connecting to a home theater player in station mode (wireless connection).

Please submit a diagnostic report of your Sonos system for us to check why your Sub is dropping off your Sonos system. Just include the confirmation number in your response. If you have any questions about this, please let us know. We’ll wait for your reply.