Answered

USB flash drive Archer router--can't add Music Library

  • 29 December 2019
  • 25 replies
  • 1555 views

Badge

I’m in the same boat as the poster in a previous thread here (unfortunately never received an answer).

I’ve checked all the USB settings on the router side and everything looks normal, showing that USB is being shared.

I’ve tried two different USB devices and the result is the same.

How can I determine the correct path to enter into the Sonos app to get this set up as my Music Library?

Thanks-

icon

Best answer by pwt 30 December 2019, 11:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

25 replies

Maybe there are some clues at link below? I would not want to be trying to do this using the mobile app.

https://www.tp-link.com/us/support/faq/1527/

 

Badge

Thanks for your reply John.  My router’s manual has a version of what is collected in the link you’ve shared.  I’m not sure what else I can do on the router side to ‘discover’ the ‘path’ I need for Sonos.  My USB device is showing properly; I’m seeing the same thing as the poster in the thread I linked to (device is showing as Media Device in Network).  But I have no idea where to go from there.  I can’t select anything in “Network” when I “browse” within the Sonos desktop program (I’m not using the app actually); it just hangs and shows nothing.

Userlevel 7
Badge +18

What OS system do you have (win, Linux or ?)?

Check under network in your file manager where the router should be listed - for example, mine is shown as ‘TP-SHARE - drill down and the file share area should be listed, mine is sda1.  This translates to //192.168.0.1/sda1  for the share location to use in Sonos.

Depending on how you set up the share - user password or anonymous - these are the details you need.

No idea how to check all this in android or iOS.  

 

Userlevel 7
Badge +16

Don't know if this is related but my NAS (WD MyCloud) has to be in SMB1, most hardware is SMB2 now due to security issues.

Sonos can't use SMB2 protocol.

I use an Archer, although not with a USB stick attached. 

I can see the Archer in media devices, but also under Computer in Network  - which may be what you need. If I try and add a library on the Sonos, then I can browse to the Archer - and I assume onto the USB stick, if one was fitted.

Badge

What OS system do you have (win, Linux or ?)?

Check under network in your file manager where the router should be listed - for example, mine is shown as ‘TP-SHARE - drill down and the file share area should be listed, mine is sda1.  This translates to //192.168.0.1/sda1  for the share location to use in Sonos.

[snip]

 

I’m running Windows 10.  I do see a ‘TP-Share’ under ‘Media Devices’ in Network.  If I double click on that I get taken to a web page ‘MiniDLNA Status’ with a little table that lists the 2 ‘audio files’ I have on the USB flash (just put these 2 on to experiment with).  The address of this page is ‘192.168.1.1:8200’  I don’t see/can’t get to any file share area like you’re describing… ?

I should also mention that I can locate TP-Share under This PC using the ‘Browse’ option in the Sonos software (‘Add music from your networked share’).  But no matter what I select under TP-Share, the ‘OK’ button to actually add anything remains greyed out...

What OS system do you have (win, Linux or ?)?

Check under network in your file manager where the router should be listed - for example, mine is shown as ‘TP-SHARE - drill down and the file share area should be listed, mine is sda1.  This translates to //192.168.0.1/sda1  for the share location to use in Sonos.

[snip]

 

I’m running Windows 10.  I do see a ‘TP-Share’ under ‘Media Devices’ in Network.  If I double click on that I get taken to a web page ‘MiniDLNA Status’ with a little table that lists the 2 ‘audio files’ I have on the USB flash (just put these 2 on to experiment with).  The address of this page is ‘192.168.1.1:8200’  I don’t see/can’t get to any file share area like you’re describing… ?

I should also mention that I can locate TP-Share under This PC using the ‘Browse’ option in the Sonos software (‘Add music from your networked share’).  But no matter what I select under TP-Share, the ‘OK’ button to actually add anything remains greyed out...

Do you see it at all under the ‘Computer’ option, though?

Userlevel 7
Badge +18

Have you set up the sharing options for the usb on the router config page?

Badge

Do you mean do I see it within the Sonos desktop controller software or the Windows File Explorer?

Badge

Yep, I’ve set the router sharing options to ‘share all.’

Just so it’s clear what I’m doing/seeing:

In the Sonos desktop controller app I’m choosing ‘Music Library Settings’ then ‘Add’ then ‘Networked device (ex. NAS drive)’ then ‘Browse.’  Under ‘This PC’ I can find the USB device = ‘TP-Share,’ and then folders within that ‘Browse Folders’ and ‘Music’ and ‘Pictures’ and ‘Video.’  I can see my individual folders with the audio files in them, but no matter which folder I choose (or even the ‘TP-Share’ folder itself), the ‘OK’ button remains greyed out, so I can’t add anything.

Userlevel 7
Badge +18

On router:

Advanced - USB settings - Sharing Access - Use default account - Save

Sharing Settings - accept Network Server name (or change) - Enable network neighbourhood

The link should show smb://TP-Share - Save

Probably worth rebooting router

You should be able to now access in the Sonos setup

Badge

OK, below is a screenshot of my router’s USB settings.  I don’t see any ‘enable network neighborhood’ option unless I misunderstood what you were saying.

Not sure what you mean when you say ‘the link should show...’  Where exactly would I be seeing this?

I rebooted router and went into Sonos setup but I’m seeing the same thing I described before: ‘TP-Share’ and all its folders/contents are visible, but selecting any of them won’t change the ‘OK’ button from being greyed out so I can move to the next step…

Thanks for your continued patience/help troubleshooting this!

 

 

Userlevel 7
Badge +18

You are in Basic (top of image).  What do you see under Advanced?  (also select Sharing Access on left menu)

Userlevel 7
Badge +18

my settings

 

 

Badge

Yep, that’s what I’m seeing also.

 

Badge

Hmmm...just noticed our links are different:

Mine: \\TP-Share

Yours: smb://TP-Share

Userlevel 7
Badge +18

Hmm?  No idea!  Need to think about that … or maybe somebody else can step in here.

Userlevel 7
Badge +18

How about trying to access the usb in the Sonos setup by smb://192.168.1.1/sdb1

(Which router is it?)

Badge

The router is Archer C1200 (manual).

I tried that path (smb://192.168.1.1/sdb1) in the setup, but the ‘Next’ button remains greyed out...no way to continue...

Userlevel 7
Badge +18

This is a possible solution (clutching at straws) - involves enabling smb in win10 (which is disabled by default)

https://www.asus.com/support/FAQ/1037477/

Hopefully this will enable the Sonos setup to see the smb shares to select the usb drive

Userlevel 7
Badge +20

In the Sonos controller app, try adding the network share as \\TP-SHARE\sdb1

Badge

In the Sonos controller app, try adding the network share as \\TP-SHARE\sdb1

 

Looks like we have a winner—thank you Prodigy!  And thanks castalla for all your replies/help in trying to get this to work for me.  By the way I added \\TP-SHARE\sdb1 via the desktop controller and not the app…probably works either way.

I’ll provide a little background on my situation for future reference of others who may be searching these threads.  Previously I’ve had the Music Library set up to pull music from folders on the hard drive of an always-on Windows 10 computer.  Frequently the music would stop and I’d get that message ‘unable to play music because server cannot be found’ message.  Assuming it was my overloaded WIFI environment, I plugged this always-on computer in to the router with an ethernet cable, but the same problem persisted.  I also considered buying the BOOST to solve this problem, but the ethernet cable experiment suggested the issue wasn’t due to the connection.  This always-on computer runs Blue Iris camera software, which sometimes pushes the computer up to near 100% CPU.  I’m guessing that when this happens, it interrupted the Sonos somehow leading to my stopped/interrupted music.  So the solution seemed to be moving the Sonos Music Library off that always-on computer.  When I discovered that my router had a USB port and that others had used this as a Music Library location, that seemed the way to go.

So knock on wood this seems to have solved my problem…several hours now with no music stoppage.  If others are in a similar boat this might not be a bad route to go, even if it means replacing your router (if your current one doesn’t have USB capability); the router I’m using is currently selling for just over $50, compared to several hundred for the NAS devices I had eyeballed.

Userlevel 7
Badge +18

Good news!  

I’ve used the usb method for ages & the fact it’s always there is really useful.  But if you can’t see the ‘drive’ in Win10 (File Explorer) then how can you copy new files over to it?  Can you use the \\TP-SHARE\sdb1 notation  to see the drive in Win10?  (I use Linux myself).

 

(I do wonder why your settings never showed the smb prefix?)

Badge

Good news!  

I’ve used the usb method for ages & the fact it’s always there is really useful.  But if you can’t see the ‘drive’ in Win10 (File Explorer) then how can you copy new files over to it?  Can you use the \\TP-SHARE\sdb1 notation  to see the drive in Win10?  (I use Linux myself).

 

(I do wonder why your settings never showed the smb prefix?)


Well I’ll have to leave it to more knowledgeable folks to answer that second question.  As far as the first, I guess I was just planning on physically unplugging the flash drive and using it on a computer when I needed to update the music/files on it and then plug it back in.  This wouldn’t happen a lot, so not real inconvenient :)

Userlevel 7
Badge +18

I just tried it on win10.  Using the File manager you can enter \\192.168.1.1\sdb1 & you should be able to access the shares.  Could be useful to copy over new files, etc.