Unicode characters showing up as garbage

  • 29 February 2024
  • 3 replies
  • 37 views

Userlevel 1
Badge +1

I have a music library I’ve been nursing along for 20 years. In those 20 years it has lived on a Windows machine, but 11 years ago I migrated to Mac, where it has been since. 

When the library is reindexed, there are some artists that show up with garbage names. Björk, in particular, but also artists like Ali Farka Touré, whose last name shows up as both “Touré” and “TouĀ(C)” (copyright symbol)

Using mp3tag, I’ve examined files from Björk and “BjĀ(p)k” (paragraph symbol) side by side, and they all look fine there. The characters are also rendered correctly in VLC. ffprobe doesn’t show anything either. 

But the Sonos desktop app has split the album “Gling Gló” into two albums, one rendered correctly and the other looking like a squashed bug. 

So this is some kind of unicode / UTF-8 issue, either in the tags or in Sonos. Any ideas? 

Note - the files are not on a NAS but on a local APFS disk. Also, to be clear, the filenames themselves are ASCII-compatible, it’s only the ID3 tag metadata that is causing this.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

It probably is a unicode / UTF-8 issue - but you would need to discuss the issue with Sonos Support and perhaps provide them with examples and screenshots to maybe get it resolved - or you come up with your own tag entries names for the artists, like Bjork (just as an example).

Anyhow here is the link to contact Sonos Support: 

https://support.sonos.com/s/contact

Userlevel 7
Badge +22

I ended up replacing a lot of characters Sonos didn’t like in my music library. A good tag editor with a global search/replace tool is the easiest option for that.

Userlevel 1
Badge +1

Thanks Ken and Stanley. Sadly, it’s coming to simply giving in and removing all of the accented and foreign characters. Everything else in my music universe handles the characters correctly, and I’ve gone to considerable lengths getting them right. I suppose I can live with Sonos displaying them incorrectly, but it’s not a very attractive feature. Even more frustrating is why it works in some cases and not in others. 

 

Thanks again for your replies.