Answered

unable to see Sonos devices when using Airplay

  • 1 January 2024
  • 1 reply
  • 462 views

When playing a song or playlist on Spotify (listening on headphones) I am unable to transfer to Sonos. Devices not visible on Airplay option. 
if I use Sonos app, it will not continue playing current item. 
appreciate any help or suggestions 

I also use Alexa on my Sonos One

icon

Best answer by Ken_Griffiths 1 January 2024, 11:27

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Here’s some things suggested by Apple/Sonos users to maybe try next time your Speaker(s) do not show (or play) as available in the AirPlay connection list, please try the following:

  1. Open the Sonos app
  2. Go to Settings » System » About my System
  3. Find the IP address of your Sonos device
  4. Open a browser on a device connected to your local network
  5. In the address bar, type http://[IP address of Sonos device]:1400/tools.htm (the whole thing should look something like “http://192.168.0.125:1400/tools.htm”, but the four numbers will/may vary). You may want to bookmark this page
  6. Click the “mDNS Announce” button at the bottom of the page.
  7. You should see a simple page with nothing but “Success”. You can now close the browser
  8. You should now see the Sonos device appear in the AirPlay list of devices to connect to

If the issues persist then go onto perhaps try these things…

  • Restart all devices including the router and try to AirPlay again
  • Remove and reinstall the App that is being used for Airplay on the sending device
  • Toggle off Bluetooth, or if already off, try turning it ‘on’ on the sending device
  • Turn off Cellular Data and use a WiFi only connection
  • Disconnect from any other Bluetooth devices (like speakers etc.)
  • Connect the sending device to the same WiFi network access point as the speaker
  • Reset your network settings on your iDevice in Settings > General > Reset > Reset Network Settings
  • Disable ‘Private Address’ MAC Spoofing in the iOS Network connection 
  • Disable WiFi calling on the mobile device
  • Update iOS, and speaker firmware/software
  • Move your devices away from other electronics and closer to the main router
  • Renew your devices DHCP lease via the router configuration pages or better still, reboot the router as mentioned above
  • Switch off any Security/VPN software installed on the sending (mobile) device

Hope the above assists to resolve your Airplay issue.