Sonos S1 update problem

  • 13 February 2024
  • 5 replies
  • 96 views

My Sonos S1 app on IOS is asking me to update, but when I click the update button I am taken to the S2 app update on the App Store. If I search for the S1 app on the App Store, no update is available. I have a Gen 1 Sonos Connect so can’t use the S2 app. Any help with this would be greatly appreciated.


5 replies

It sounds rather like you, or someone else in the Household, ’may’ have perhaps upgraded your Sonos One to use the S2 App and now it’s looking to move that over to a separate S2 system. To maybe confirm this, just see what happens when you power off that speaker and just have the ‘Connect’ only connected to the WLAN. If it has been upgraded by accident, then to downgrade it back to S1, see these instructions…

https://support.sonos.com/en-us/article/downgrade-a-sonos-product-from-s2-to-s1

Thanks for your reply. My Sonos One does use the S2 app but it is In a different physical location and on a different LAN to my Sonos Connect. It had not occurred to me that there would be any conflict due to this separation but I will try your suggestion. 

Thanks for your reply. My Sonos One does use the S2 app but it is In a different physical location and on a different LAN to my Sonos Connect. It had not occurred to me that there would be any conflict due to this separation but I will try your suggestion. 

Is the Sonos One using a different Sonos Household/System, did it start its life as part of the same system? There’s no way your Connect can upgrade to S2 unless it’s a gen 2 product anyway (manufactured on/after March 2015 IIRC🤔?) - If it’s the newer model, then obviously it can be upgraded to S2 anyway.

I have a Gen 1 Connect in one property. It can only use the S1 app.  I have a Sonos One in another property and this is set up with the S2 app. The devices are not on the same WiFi network, but they are both on my account. I use the S2 app to control the One, but use Amazon Alexa voice control for the Connect. I recently lost connection to a streaming service I use on the Connect and when I tried to re-link it via the S1 app, I was met with the update message. I had assumed that I could use the 2 apps, one for each product as they are not being asked to work together e.g for multi room audio. The S1 app only controls the Connect. The S2 app only controls the One and the One has never been set up on the S1 app.

I have a Gen 1 Connect in one property. It can only use the S1 app.  I have a Sonos One in another property and this is set up with the S2 app. The devices are not on the same WiFi network, but they are both on my account. I use the S2 app to control the One, but use Amazon Alexa voice control for the Connect. I recently lost connection to a streaming service I use on the Connect and when I tried to re-link it via the S1 app, I was met with the update message. I had assumed that I could use the 2 apps, one for each product as they are not being asked to work together e.g for multi room audio. The S1 app only controls the Connect. The S2 app only controls the One and the One has never been set up on the S1 app.

What version/build  is the S1 App and what software version is the Connect showing in the ‘About my System’ area in the S1 App settings?

Reply