Answered

Sonos no longer able to access music library on NAS after router change

  • 20 November 2022
  • 11 replies
  • 85 views

Badge +1

I use S1, have about 10 zones, have a ‘connect’ hard-wired to the router, and an apple time capsule connected to that ‘connect’. The time capsule produces its own network which I use throughout the house, using apple repeaters connected via the ethernet port. This all works very well (for many years). We have just changed our Internet Provider, so have a new pre-configured router. The router works, we have Internet and, like the previous one, another wi-fi network that reaches only part of the house. The Sonos system can access Internet services and all the zones are as they should be, but I can no longer access music vis Sonos on the external hard drive. I can still access it and play the music from my laptop! When I try to make a second music library (at the same existing location) within S1, the error message is: the computer [] refused to let the Sonos product connect to it. I have tried rebooting all the zones - no effect. I cannot see anything meaningful to change in any menu. Why is the hard disk no longer allowing access from Sonos just because I changed the router (but not the wi-fi)?

icon

Best answer by Corry P 25 November 2022, 13:47

View original

11 replies

After replacing a router, everything on the network should be rebooted and WiFi credentials must be updated, as appropriate.

Badge +1

Did the reboot this afternoon. In fact, there was no need, because the situation was exactly the same before and after the sequential reboot, but I saw your advise on this, Buzz, so gave it a try (and see it worked for others in similar bit not identical situations). As far as Sonos is concerned, the wi-fi has not changed; only the largely unused wi-fi from the router, the main house wi-fi stays the same and comes from the NAS. When I changed the router before (2 years ago) this was seamless for Sonos, as I expected it to be. But not this time, even though the operation was exactly the same...

Userlevel 7
Badge +18

Hi @TimMeese 

Thanks for your post!

I took a quick look at your system details and your Sonos system is on the subnet of 50 (192.168.50.x). Please ensure your NAS is on the same subnet. If not, it may be receiving an IP address from a different DHCP server than that of your Sonos system, which would not be good. If the first two parts of the IP address aren’t 192.168, that’s not good either. Unless you really know what you’re doing, there should only be one device on your network acting as a DHCP server, and this would ideally be the first device on the network - the one that’s connected to the internet ingress point in your home.

I think you probably have to disable the DHCP server on the Time Capsule, then reboot everything that’s on the network.

I hope this helps.

Badge +1

Thanks Corry P - I’ve posted below what I see for my NAS (Airport Time Capsule). So- the IPv4 address (whatever that is) is consistent with what you say about subnet. But the subnet mask (whatever that is) is different. I don’t know what these mean or how I would change them (they are not editable from that window, and no obvious edit window to open.), but I’m guessing this is correct as it is.

I run my NAS in bridge mode (always have done) which means, as I understand it, it does not operate as a DHCP server. Indeed, they are the other options I have (DHCP only, or: DHCP and NAT)  but ‘Router Mode: Off (Bridge mode)’ is selected instead. It is only the new router that acts as the DHCP server (now, and also for the previous two routers, which worked fine), but both the router and the NAS provide independent wireless networks. My Sonos works with the wireless network off the NAS. (If I change it to the router wireless network, then I lose the ethernet extension of the wireless on the back of Sonos through the house.) So I think these components are as they should be. (The router connects to the fibre ingress, my Sonos ‘connect’ connects to the router, and my NAS connects to the Sonos ‘connect’.)

 

 

 

Userlevel 7
Badge +18

Hi @TimMeese 

That all looks and sounds correct, which means I was on the wrong path. Subnet masks are kind of difficult to explain, but that is what it should be.

Is your Sonos system connecting to your router, or to the Time Capsule? And which is the NAS connecting to? If you can get them both to connect to the same part of the network, you may have more success.

Otherwise, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Badge +1

Sorry - I’ve been using the terms NAS and Time Capsule interchangeably. My NAS is a Time Capsule. (That was my understanding of the terminology.) So, Sonos connects to Router. NAS (aka Time Capsule) connects to Sonos. (I tried connecting the NAS directly to the Router a while back, but that didn’t work - I forget the symptoms.)

I’ll try the tech support link when I get a moment…

Thanks

tim.

Badge +1

Wait - your last comment got me thinking … one more thing to try … I tried plugging the router into the NAS *instead* of the Sonos. So: Fibre → Router → NAS(aka Time Capsule)→Sonos. And bingo - everything works as it should. Odd tough, this is a different wiring scheme from my previous two routers, and nothing else has changed…

Thanks for your help, Corry P.

Userlevel 7
Badge +18

Hi @TimMeese 

Sorry - I’ve been using the terms NAS and Time Capsule interchangeably. My NAS is a Time Capsule. (That was my understanding of the terminology.)

No - that was my mistake. I momentarily forgot that Apple inexplicably added router functionality to what is basically a NAS.

Wait - your last comment got me thinking … one more thing to try … I tried plugging the router into the NAS *instead* of the Sonos. So: Fibre → Router → NAS(aka Time Capsule)→Sonos. And bingo - everything works as it should. Odd tough, this is a different wiring scheme from my previous two routers, and nothing else has changed…

Ok, I see two possibilities:

  1. The router and the Time Capsule are both configured as DHCP servers and are both configured to dish out IPs matching 192.168.50.X. If this is true, I wouldn’t have spotted it earlier.
  2. The Time Capsule is blocking certain data packet types from crossing between the TC and the router

I think the first is more likely, but only because it would be less repeatable/reproducible. When client device connects to the network (or refreshes it’s connection) it sends out a request to hear back from a DHCP server. If there are two on the network, both will reply, but the client will ignore the second. As there might only be a millisecond difference in when each arrives, it could be either. The device might get 20 replies in a row from the same DHCP server, then the next time from the other. If two clients get IPs from two different DHCP servers, they will not be able to communicate with each other, though both will be online.

I think the answer might be in the Network section of the settings screenshot you posted above. Could you let me see what’s there, please? Although things are working for you now, it’s best to not have two networks on one setup.

Thanks for your help, Corry P.

You are very welcome!

Badge +1

Sure - but there’s not much to see there as the NAS is operating in bridge mode (as I noted above). So that makes me think your second suggestion is more likely, but why would that look different from this router compared to before?

For completeness: clicking ‘timed access control’ (below) reveals that wireless access time is every day, all day. And network options (below) has enable IGMP snooping selected (whatever that is!).

 

 

Userlevel 7
Badge +18

Hi @TimMeese 

Thanks. Again, that all looks good.

IGMP snooping is good to have - it prevents multicast packets from going where they’re not wanted and reduces traffic.

How you proceed is up to you - you are now able to play your music that’s on the NAS, so if you’re happy, I’m happy. I would make sure that things work regardless of which WiFi your phone is connected to, but I suspect everything will be fine.

As to why it wasn’t working before, I’d need to see diagnostics to take another guess, and that would mean you having to rewire things again, so it’s really up to you. I suppose it’s technically possible Apple decided to block NAS access to devices that aren’t below the TC in network hierarchy, but it looks like the last TC update was in April ‘22.

It does looks like your network is healthy enough though - that was my main concern for you.

Badge +1

Yes - thanks for doing your checks. I guess I’ll just live with the mystery.

cheers

tim.

Reply