Sonos constantly dropping or skipping songs with NAS

  • 21 January 2023
  • 1 reply
  • 23 views

I have a QNAP 4 bay NAS with 3 x Samsung EVO SSD, one of the drives is dedicated to MP3.

Setup is a combination of Play 3’s (Wireless and Hardwired), Playbar (Hardwired) IKEA Sonos (Wireless and Hardwired) I was having constant problems with any speaker either hardwired or wireless dropping out, songs skipping and just general unreliability.

 

Sometimes it would play a song for 20 seconds then skip to the next, it would do this every day some days it went on for hours, a lot of times the app would come up cannot play ?? as file couldn’t be found.

 

I thought it might have had something to do with my house Double Brick and concrete slabs on both levels,  once I worked out  it was doing it on the hardwired devices that ruled out a wireless problem.

I suspected the NAS was causing the problem as there wasn’t any other devices in the loop, thing is, it all worked perfectly fine before I moved into this house.

 

The only change I made when moving here, was replace the hard drives in the NAS with SSD, it appears the SSD is the problem, I think it’s going into some aggressive power save mode and doesn't wake-up in time then the Sonos loses it’s connection which is why I think the error messages were coming up as it was not able to find the files, strange thing is it would do this half way through a playlist.

 

After much frustration for the past few months and trying everything from different wireless routers, to many other things, I ended up adding a hard drive back into the spare NAS slot, I did this as the “couldn't find files” error made me think the SSD was going offline and it was the only change I made to the NAS.

 

I copied all the data from the SSD to the HDD, shared it, reconnected the library to this share.

It appears to have fixed the problem, up until yesterday it was dropping, after swapping to the HDD in the morning every device streamed music all day either wireless or wired connection.

 

Today, it has also streamed all day and hasn’t dropped a single song.

 

I checked the NAS for power down options and these only apply to HDD, there are no setting for SSD, so I don’t know if the issue is the SSD or the NAS ?

Something to keep an eye on if you have a similar setup.

 

 


1 reply

Userlevel 7
Badge +18

Hi @Spakoo 

Welcome to the Sonos Community!

Thanks for sharing your findings! That is entirely the opposite of what I’d expect - if anything, the SSD should be more responsive, rather than less. In theory, at least. I recommend reporting this to QNAP - if you haven’t already - and keeping an eye out for software updates for your NAS device.

Reply