Answered

Sonos App suddenly stopped connecting to Tidal

  • 21 April 2024
  • 5 replies
  • 372 views

I have a Sonos Connect and control it using the Sonos app on Android. Last week I stopped being able to access my Tidal service from the app. I tried re-authorizing, and got the message that it had worked, but when I returned to the Sonos app it said “”There was a problem adding the Tidal account. Connection could not be made.” I have uninstalled and reinstalled the Sonos app, have rebooted everything, have checked my Tidal account to make sure that it is functioning normally, but I still get the same result. Any ideas?

icon

Best answer by Corry P 22 April 2024, 13:30

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +18

Hi @Perizoso 

Welcome to the Sonos Community!

I’m sorry to hear of the issue you’ve had trying to play from Tidal, and in trying to resolve it. To give things the best chance of going smoothly, please turn your router off for at least 30 seconds. While you are waiting, please also reboot your phone/tablet. Once WiFi returns, please wait another minute or two before trying again.

If that hasn't helped, and if you have the option, please try adding the Tidal service using a different phone/tablet.

And if you’re still struggling at this point, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Thanks. I was able to use my previous phone (had to update the sonos app first). For whatever reason, I was able to add Tidal back on that phone, and the service is now working properly.

Userlevel 7
Badge +18

Hi @Perizoso 

Glad to hear it! Thanks for updating the thread!

Userlevel 1

Hi all! Unfortunately I have the same problem: I cannot add my Tidal premium account on the new Sonos app.

Log in correctly on the Tidal web page but when I go back to the Sonos app it tells me there was an error. I've been trying for days with different devices but nothing. I contacted customer service today but they tell me they don't know what to do. Absurd! the new app is always worse but unfortunately they removed the possibility of adding a new streaming service in the old version and so the downgrade didn't work either.

Can anyone help me?

I'm paying for a service that I can't use because of Sonos!

Userlevel 7
Badge +18

Hi @DaNny_S 

Sorry to hear of the issues you’ve had in trying to add the Tidal service to your Sonos system!

Please try resetting the Sonos app (User icon » App Preferences » Reset App » Reset). Re-open the app once done, connect to the existing system and sign in to your account. Try adding Tidal once done.

And transferring the system ownership to yourself may also help: Settings (Gear Icon) » Manage » Transfer system ownership. Transfer to your existing Sonos account. Try adding Tidal once done. This one is, admittedly, a long-shot.

Any one of these may help, so feel free to do them in the easiest order (at first), but doing them all in one go and in this order may significantly improve your chances:

  • Turn off your Sonos speakers.
  • Turn off your router.
  • Reboot your phone/tablet. Or, try with another.
  • Turn on your router once it has been off for at least 30 seconds.
  • Turn on any ethernet-wired speakers and wait for the flashing white light to stop
  • Turn on any Home Theatre primaries (soundbars or Amp). Wait for the flashing white light to stop.
  • Turn on all other Sonos speakers.

If none of these steps help, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.