Sonos 2 app messed up languages

  • 21 October 2023
  • 17 replies
  • 227 views

I am using latest Sonos2 app on my iOS devices. While I have system language set to russian sonos app is showing me some chineese (probably). Switching system language to english is working ok.

Is there any way to get it working properly? Or its software bug?

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

Userlevel 7
Badge +16

Hi @sg_frost, welcome to the Sonos Community!

This definitely isn’t normal behaviour of the app. I would suggest you following the steps outlined in our support article for Resetting the Sonos app. If that doesn’t resolve the issue, please delete the Sonos app and redownload it. We have a support page with a link to all the app download pages.

I would also recommend that you make sure you phone is fully-up to date. While I doubt that it’s the cause, it would be worth checking.

I hope this helps!

Userlevel 7
Badge +23

This is an issue with Apple Music: their string table contains no Russian translation, and so the Sonos app defaults to the first language, Chinese. You can see the file here:

https://cf.ws.sonos.com/p/s/898f9431-e65a-4b1b-a78b-b3a2c218bfcd

It is supposed to say “Library” in that first screenshot I think.

In fact Russian is not in the list of languages that Sonos support on music services anyway, but defaulting to Chinese seems wrong.

I tried my Windows app and I default to English for non-supported languages, the official Sonos app should do the same IMHO.

This is an issue with Apple Music: their string table contains no Russian translation, and so the Sonos app defaults to the first language, Chinese. You can see the file here:

https://cf.ws.sonos.com/p/s/898f9431-e65a-4b1b-a78b-b3a2c218bfcd

It is supposed to say “Library” in that first screenshot I think.

In fact Russian is not in the list of languages that Sonos support on music services anyway, but defaulting to Chinese seems wrong.

Well that seems strange as it was working previously all correct. Probably they changed something recently. And definitely defaulting to Chinese is S2 application issue. 

In this case how do I file a bug report to Sonos as I looked everywhere and could not find a way to do it?

Userlevel 7
Badge +23

Well that seems strange as it was working previously all correct. Probably they changed something recently. And definitely defaulting to Chinese is S2 application issue. 

In this case how do I file a bug report to Sonos as I looked everywhere and could not find a way to do it?

Hopefully @Jamie A will open a tracking bug for this issue in the Sonos app.

Userlevel 7
Badge +16

Hi @sg_frost,

I’ll forward this thread to our Engineers and get back to you when I have more information.

Also thanks for checking @controlav. I’m not sure what the default language should be, but English would make the most sense to me.

Hi @sg_frost,

I’ll forward this thread to our Engineers and get back to you when I have more information.

Also thanks for checking @controlav. I’m not sure what the default language should be, but English would make the most sense to me.

@Jamie A thanks for forwarding this to devs.

I did some additional testing with other languages and for example Arabic which seems also not supported by Apple is defaulting to English. Actually with Arabic the whole S2 app is in English which make me think the issue is that S2 app does has Russian language support but Apple Music does not.

Userlevel 7
Badge +23

Hi @sg_frost,

I’ll forward this thread to our Engineers and get back to you when I have more information.

Also thanks for checking @controlav. I’m not sure what the default language should be, but English would make the most sense to me.

@Jamie A thanks for forwarding this to devs.

I did some additional testing with other languages and for example Arabic which seems also not supported by Apple is defaulting to English. Actually with Arabic the whole S2 app is in English which make me think the issue is that S2 app does has Russian language support but Apple Music does not.

There are two localization points in the app, one used for the app itself, and one passed onto the music services so they can return the correct strings. Sounds like the app does the right thing, but forgets to handle the music services correctly. I don’t think Apple are doing anything wrong, except possibly by listing Chinese first in the string table which I am guessing is why it is chosen in your case.

Userlevel 7
Badge +16

Hi @sg_frost,

Thank you again for reporting this and @controlav for looking further into this.

I’ve heard back after reporting to our engineers, who explained that we do not officially support the Russian language on the Sonos app nor is this country a part of the Sonos Service Region, so any bugs that arise from using it will not be addressed by our engineering team.

In this case, I would recommend that you use the Sonos app in a supported language.

 

Edit:

After further investigation with our team, a ticket was opened regarding this issue as the default language (if something is not supported in the native language) should be English. This has also happened with a few other languages, so while Russia isn’t part of our service region, fixing this will resolve the issue you are having.

I apologise for the confusion that the original message may have caused and I hope this new information helps!

 

 

 

 

Hi @sg_frost,

Thank you again for reporting this and @controlav for looking further into this.

I’ve heard back after reporting to our engineers, who explained that we do not officially support the Russian language on the Sonos app nor is this country a part of the Sonos Service Region, so any bugs that arise from using it will not be addressed by our engineering team.

In this case, I would recommend that you use the Sonos app in a supported language.

 

@Jamie A that’s very confusing. I can’t find any way to change s2 app language. I am not asking for country support, but rather language support. I am living in Latvia and my regional settings are set accordingly. My phone language is set to Russian. So engineers are asking me to stop using my phone in the language that is comfortable for me? S2 app is localised and whole app is in Russian, if it is not supported how do I get all parts of app in Russian? I am totally confused now.

@Jamie A ok I found how to change language settings, it was not in the app, but rather in settings. All is set up and working. Although Russian language was normally supported previously. Still confused, but not surprised.

@Jamie A @controlav Thank you for your assistance.

I think sonos “engineers” might get their development straight. It’s bit messy. 

 

Userlevel 7
Badge +16

Hi @sg_frost,

You are absolutely correct, I raised it again with the team and a ticket has been opened as the default language (if something is not supported in the native language) should be English.

I apologize for any confusion this might have caused and have added the correct information in my original message.

Thanks for reporting this!

I am using latest Sonos2 app on my iOS devices. While I have system language set to russian sonos app is showing me some chineese (probably). Switching system language to english is working ok.

Is there any way to get it working properly? Or its software bug?

I have similar problem with Finnish iOS app: The language in my app should be Finnish but half of the menu options are in Korean. I have the lates updates installed both for iOS and for the Sonos app.

This has continued for 3-4 months.

I am using an android phone and having the same error as the poster. I am using hungarian language. Normally it is fine in the app, but not so much when I try to pair with music apps.

Userlevel 7
Badge +23

I am using an android phone and having the same error as the poster. I am using hungarian language. Normally it is fine in the app, but not so much when I try to pair with music apps.

The bug is that when the app runs in a language not specifically supported by a music service, the app picks the “first” language from that music service, which is not always English. After that every message from that music service will be in the wrong language.

Table of supported languages is listed  https://docs.sonos.com/docs/localization but not all services support all those languages.

How come the app supperted Finnish previously? This is a resent problem. 
I’m using Deezer as my streaming service and that supports Finnish quite well. It’s the Sonos app that is mixing languages.