Answered

Sonos 14.18.1 - iOS no localization function & problem with the local library

  • 1 November 2022
  • 8 replies
  • 117 views

Userlevel 1
Badge +3

Hello Everyone,

I need your help, since the 14.18.1 update, the localization function in the Sonos app on iOS is missing.

Since this last update, I have a lot of problem with my local library on my WD My Cloud EX2 Ultra.

Sometimes this library disappears and I must to update manually the library in the Sonos app. I have no modified the initial configuration but the problems are there.

Thank you forward for your time and kind regards.

icon

Best answer by Airgetlam 1 November 2022, 21:52

View original

8 replies

Can you expand on what you mean by ‘localization function’, please?

Often, troubles that occur after updates have to do with issues around the router handing out duplicate IP addresses when the Sonos restarts. I’d certainly recommend a refresh, by unplugging all Sonos devices from power, then rebooting your router.once the router comes up, go ahead and plug in your Sonos devices.

If this does work, which I think it should, you may want to consider reserved IP addresses in your router. Check the router’s manual for instructions. Any router that has gotten in to a state where it’s passing improper IP addresses can do so again, and Sonos tends to expose that more readily, since every update comes with a reboot. 

Userlevel 1
Badge +3

Hello Bruce,

Thank you for your quick answer.

On the following picture, at the top in red, normally the localization function is present. Since the last update, this function is missing :

I have no make a restart of all my systems, I go to try this, thank you for this tip.

My speakers have a private IP address, I have configured this on my router.

Kind regards,

Laurent.

 

I’ll have to expect that Sonos will respond to the localization function issue, I’m not at all familiar with that, as it’s not something I’ve ever used. 

Even with reserved IP addresses, there may be some value in a network refresh….and it certainly wouldn’t hurt anything.

However, if that doesn’t actually resolve the issue, you may want to submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network. 

One thing I’d double check, although it’s a long shot, for the local library issue, is the version of SMB that your WD device is using. 

From what I can see, you’re using the iOS 14.18.1 S2 client, which works well with SMB version 3. I know in the past, I’ve had issues with Western Digital messing with my versions of SMB in use by my MyCloud device, without notifying me. You may want to double check to see that the NAS is indeed using SMB v3. But I’m grasping at straws a bit, here. Your best bet is to run a diagnostic as indicated in my previous post, immediately after a failure.

And now, since you’re obviously a speaker of the french tongue, a Google Translate of this. Hmmm. I’ll do both posts, just for completeness. 

 

  1. Je dois m'attendre à ce que Sonos réponde au problème de la fonction de localisation, je ne suis pas du tout familier avec cela, car ce n'est pas quelque chose que j'ai jamais utilisé.

    Même avec des adresses IP réservées, une actualisation du réseau peut avoir une certaine valeur... et cela ne ferait certainement aucun mal.

    Toutefois, si cela ne résout pas réellement le problème, vous pouvez soumettre un diagnostic système dans les 10 minutes suivant l'apparition de ce problème et appeler l'assistance Sonos pour en discuter.

    Certaines informations incluses dans le diagnostic aideront Sonos à identifier le problème et vous aideront à trouver une solution.

    Lorsque vous parlez directement aux gens du téléphone, ils ont à leur disposition des outils qui leur permettront de vous donner des conseils spécifiques à votre système et réseau Sonos.

 

  1. Une chose que je vérifierais, bien que ce soit long, pour le problème de la bibliothèque locale, est la version de SMB utilisée par votre appareil WD.

    D'après ce que je peux voir, vous utilisez le client iOS 14.18.1 S2, qui fonctionne bien avec la version 3 de SMB. Je sais que dans le passé, j'ai eu des problèmes avec Western Digital avec mes versions de SMB utilisées par mon appareil MyCloud, sans me prévenir. Vous voudrez peut-être revérifier pour voir que le NAS utilise bien SMB v3. Mais je m'accroche un peu aux pailles, ici. Votre meilleur pari est d'exécuter un diagnostic comme indiqué dans mon message précédent, immédiatement après une panne.

    Et maintenant, puisque vous êtes évidemment un locuteur de la langue française, un Google Translate de cela. Hmmm. Je ferai les deux messages, juste pour être complet.

The location settings are likely missing if you have switched it off in the iOS main Settings under ‘Privacy & Security’. Its showing okay on my iOS device. See screenshot attached.

Userlevel 1
Badge +3

Thank you Bruce and Ken for your informations 👍🏼

@Ken_Griffiths I have checked in “Privacy & Security” and the Sonos App is not present, please see photo below :
 

The iPhone is on the 16.1 Version.

Kind regards,

Laurent.

It’s definitely showing in my Location Services list in the iOS 16.1 settings, so my thoughts are to perhaps try an App reset (in the Sonos App Settings/App Preferences) and see if that fixes the issue. After reset, ensure you choose to connect the App back to the existing Sonos System. See if that fixes your issue.

Userlevel 1
Badge +3

@Ken_Griffiths

I have make a reset of the app and the problem is always present > no possibility to put on the localization. The localization option is always missing :

 

Since this issue and as is mentioned in my first post, I’ve problems with my local music library (this library is in SMB 3 configuration), often this one is missing and I must to manually update the library (I don’t know if the localization problem is linked at this library issue ?) :

I go to reach the support this morning with a diagnostic resume.

Kind regards and thank you.

Reply