Answered

Something went wrong


Userlevel 3

I have just updated Sonos and it won’t play on my mobile or Mac - with the app or the online web page.

I get a message saying ‘Something went wrong’.

I have a party tomorrow!!!

what can I do?

icon

Best answer by Richardicain 12 May 2024, 16:40

View original

45 replies

I had a Chat yesterday and they told me to reboot each individual Sonos item and my internet. I suggested them to have a reboot option within the app. Itself that we could simply control.
They did not offer a reboot for me. I was skeptical to reboot each item From reading all the previous posts. I was afraid I would loose all functions.

it only rebooted my router & modem. once I rebooted my internet the functions are much better. Still not perfect but it works. I will wait for the fix of the app. 
here is something else I found posted on Community page.

Every update we have a few posters who blame an update, even though when an actual bug happened to a single Sonos device, the thread hit 100 pages in a day. It's not the update, it's your network, specifically IP conflicts. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem

Router

Switches or hubs

Wired Sonos units

Wireless Sonos units

Computers/printers

Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.

 

This worked for me too.  Hopefully, it’s not something I have to do everytime the power blinks…

That being said, the new app is still clunky...

If you do that last paragraph, you don’t need to do the process every time the power blinks, and causes an issue. And it may not cause an issue every time the power blinks, but that is up to your router, and not a Sonos problem. 

Userlevel 1

There have been several software ‘updates’ since the May 24 debacle that stopped my system working. Still no corrections for me.

  1. Sonos app takes 2 minutes plus to start
  2. Cannot play radio stations- get ‘something went wrong’ message, or simply nothing happens
  3. Cannot control Sonos device other than through Alexa commands

When can we get a correction or revert to previous version of the app please ?

Next step is to send the device back to the vendor with a full explanation as to why.

As previous posters have pointed out, why should we be wasting our time on this - we did actually pay a significant amount for this nonsense.

Had Sonos for years and spent a few k.It will not play my main Napster playlist anymore (something went wrong) and the new update has turned my devices into expensive bricks. You must be mad to buy anything from Sonos again....having bought all mine on a credit card I may start a section 75 against Sonos for breach of contract in England you have 6 years. If we all did this Sonos might pull it's finger out and sort it. 

Same problems, no fixes for a month.  Zero testing of this failed app!

I can stream to every Sonos device individually and in groups using Roon (with its built-in Sonos integration).  So the issue is not with my network.  The problem is in this faulty new Sonos App, that has turned every Sonos speaker into paper weights!

The latest Sonos App is very buggy. I keep getting ‘Something went wrong’. It doesn’t play half my Amazon music. I never had this issue with the previous version of the App. Sonos, how much longer must we suffer with this buggy App on Andriod!

I cant sync speakers,or add speakers,anyone else have this issue?I deleted new app,installed old one,to add speakers I get message to update app,so I go back to square one.

Same issue as everyone else. Can't play anything "Something went wrong". I've reset the router, factory reset every device, used the workaround from Sonos support (connect via Windows app first). Nothing works. 

Time to fix this or issue refunds. 

Hi Everyone!

Just setup my username for my new Sonos purchase… 

Seems to be all I ever see. 

Userlevel 2
Badge +1

Sonos likes to blame everything but its own equipment…bottom line is Sonos releases updates and new apps that are not thoroughly tested and then won’t support their own products or software. This has been a long standing problem and is obviously ingrained in their management culture. 

Have resisted updating.

Updated today. 

Now, “Something went wrong, Something went wrong, Something went wrong, Something went wrong, Something went wrong, Something went wrong, “

Can't use speakers in any sense.  Neither voice command nor through app. 

Have spent this afternoon trying to get them to work, resets and all. 

Now have several rooms full of expensive bricks and no music. 

Bunch of a****.

Moderator Note: Modified in accordance with the Community Code of Conduct.

Userlevel 2
Badge +1

Have resisted updating.

Updated today. 

Now, “Something went wrong, Something went wrong, Something went wrong, Something went wrong, Something went wrong, Something went wrong, “

Can't use speakers in any sense.  Neither voice command nor through app. 

Have spent this afternoon trying to get them to work, resets and all. 

Now have several rooms full of expensive bricks and no music. 

Bunch of a****.

Welcome to the club! Bet you can’t even contact Sonos support to get help…of course not it’s the weekend! 

Userlevel 2
Badge +1

The latest Sonos App is very buggy. I keep getting ‘Something went wrong’. It doesn’t play half my Amazon music. I never had this issue with the previous version of the App. Sonos, how much longer must we suffer with this buggy App on Andriod!

Same on iOS… it’s their lousy software/app development and non-existent pre release testing. At least most tech companies do beta testing.

Userlevel 2
Badge +1

I had a Chat yesterday and they told me to reboot each individual Sonos item and my internet. I suggested them to have a reboot option within the app. Itself that we could simply control.
They did not offer a reboot for me. I was skeptical to reboot each item From reading all the previous posts. I was afraid I would loose all functions.

it only rebooted my router & modem. once I rebooted my internet the functions are much better. Still not perfect but it works. I will wait for the fix of the app. 
here is something else I found posted on Community page.

Every update we have a few posters who blame an update, even though when an actual bug happened to a single Sonos device, the thread hit 100 pages in a day. It's not the update, it's your network, specifically IP conflicts. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem

Router

Switches or hubs

Wired Sonos units

Wireless Sonos units

Computers/printers

Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.

 

This worked for me too.  Hopefully, it’s not something I have to do everytime the power blinks…

That being said, the new app is still clunky...

Pretty unbelievable that it’s only Sonos that has these issues. No other devices or technology I have ever requires this crap. Not Blink, Roku, Android TV, LG, Apple, Canon etc. etc. ONLY Sonos!!

Same here, just transferred over to Amazon Unlimited for the family from Spotify. I'm unable to play direct from Amazon app, unable to add more than one Amazon account to the system. 

 

Reset and rebooted, killed apps and reinstalled... Nothing appears to help? I did have a chat with support a few days ago... Unfortunately the support ticket was not sent back to me so I could follow up on the phone... Looks like I'll have to go through it all again! 

 

But reading the messages here it would appear the issue is software related and is affecting many users. Pretty shoddy tech and development testing, when you're paying this price one expects this stuff to actually work, if I wanted a £50 system unable to stream and configure is of gone to Temu

Userlevel 2
Badge +1

Not impressed that Sonos monitors this community yet does nothing to address the concerns. It would be nice to know IF they are even addressing the many issues that are affecting the ecosystem and clients. 

In short, display specific error messages!

Quite annoying getting the catch-all, there is something wrong, and see all the unresponsive services. 

As a developer I would think there are many checkpoints where you could have identified a more specific error code.

I think not all 'theres something wrong' is due to same error, no, it's rather mark of the lazy developer. -> error, well then display 'something went wrong'. 

Either fix it, or report what is actually the issue, seriously.

If you want more specific feedback of the issues we experience, then why not provide more specific error codes?

Userlevel 2

Sonos… it’s getting a bit stupid. Get playlist functionality back and sort out the slowness and the frequent  «something went wrong» messages. 

In my case it seem like my daughters log in works, but mine doesn´t. I keep getting somethings wrong all the time. It never works… 

Reply