Solution for update error 1101

  • 14 July 2021
  • 1 reply

Userlevel 7
Badge +23

I acquired a Play1:Gen1 and wanted to add it to my S1 system, so I factory reset it and then tried to add it using the S1 app. Adding it to my household was fine, but it needed an update, and that failed with the infamous error 1101. I looked at the support page for this error, and as a result I powered down some of my funkier Sonos devices that were not a part of my S1 system, but it made no difference. I tried updating from the PC app and the iOS one, but both immediately gave error 1101.

I broke out Network Monitor and traced all the SOAP calls during this failed update, and I could see that my PC was returning UPnP Error 800 to a call. Weird I thought.

A while ago I had enabled the Windows Media Server, and as I don’t use it I disabled it, rebooted my PC, and now the update went through just fine.

For some reason the Sonos app is finding the Windows Media Server and getting confused when it returns an error.

Hope this solution helps the next person who gets error 1101 when trying to take a Sonos update with a PC on the network.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Badge +17

Thanks for sharing! I’ve passed this thread on to our engineers for investigation, and I’ll reach out to you directly if we have any further questions. :slight_smile: