Question

New Sonos App


Hi all, on the new Sonos app, if I look for a band and choose a song, Sonos now only plays that one song, instead of playing the next song on the album, did it always do this or is this a new app thing? Also seems to find it difficult to connect to my Sonos speakers and control them properly, issues when I’ve selected a song it doesn’t play, or trying to forward a song to next it doesn’t do it 


5 replies

Userlevel 7
Badge +18

Hi @VonConway 

Welcome to the Sonos Community! And, apologies for the delay.

Sorry to hear of the issue you’ve been having in trying to play your music.

I’d like to look into this for you. What source of music are you using?

Hi Corey, I’m using Amazon music as my main source.

 

thanks

Userlevel 7
Badge +18

Hi @VonConway 

Thanks. I think sounds like expected behaviour, but it largely depends upon what you are searching for. If you search for one track and find it, selecting it will result in that one track playing. If you search for an album, however, then selecting a track from it will result in the album playing from that track, and continuing to the end. The last app had the same behaviour, I think.

If this is not the behaviour you see, please let me know.

Also seems to find it difficult to connect to my Sonos speakers and control them properly, issues when I’ve selected a song it doesn’t play, or trying to forward a song to next it doesn’t do it 

This could be due to a few things - there are still some teething issues with the new app, but it’s possible things could improve after a simple reboot of your speakers and/or network. I recommend unplugging your speakers and router. Once the router has been off for at least 30 seconds, turn it back on and wait for WiFi to return before turning on your speakers.

I hope this helps.

 

Thanks for the response, I will do a reboot as suggested, and let you know, I probably wasn’t clear enough above, but for example, searching for the Foo fighters, greatest hits for example, playing the first song off the album, it stops after the first one instead of continuing with the whole album.  But also takes ages to connect and play the song, often saying has an error connecting, when eventually it does connect, if I try to change what is playing or stop it playing, it’s not responsive to that. 

Userlevel 7
Badge +18

Hi @VonConway 

Even with that exact example (Foo Fighters), we were unable to recreate your issue as you describe it - the album just moved on to the second track without issue.

Just to be doubly sure, what tier of account do you have with Amazon? We were testing with an Unlimited account.

Hopefully, the reboot will help with matters.

Reply