Answered

New problem with Tunein, streaming station & Sonos. Need HELP!

  • 18 February 2022
  • 18 replies
  • 503 views

Badge

Been listening to a streaming station KPIG (Santa Cruz) for a year, without incident. Now Sonos will not connect to it, from desktop, iPhone or iPad. Will connect to local Public Radio station. Music library works fine. Deleted station and re-added it, multiple time. No problem at the station. My business tech guy is coming next week because I am so fed up, but would love to solve this on my own, and without an added expense. Anyone??

icon

Best answer by Ken_Griffiths 18 February 2022, 23:35

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

Badge

Should have added that this is a subscription station and subscription is up to date.  Would give URL but since it is subscription specific … thinking maybe I shouldn’t?

TuneIn doesn’t handle subscription stations...to my knowledge they have no method for you to enter in your account information in their client, which of course extends to Sonos. 

Did KPIG recently add the subscription model? When I look at the station, they don’t even stream through TuneIn directly, they open up what appears to be a flash or java client (not having peered too deeply into it).

Badge

Thank you for responding so quickly. KPIG has had the subscription model for years, and I used it successfully for about a year through Sonos Tunein. Never used Tunein directly. The account info I entered was through Sonos. I’ve spent way too many hours trying to troubleshoot this, so any help you, or others, may have will be greatly appreciated. Thanks.

I’m not sure how you can enter account information in through the Sonos interface, which is essentially just a “front” for the TuneIn one. Unless KPIG wasn’t checking for account information until recently, and you used the “add an internet stream”, which still doesn’t use the “account/password” paradigm…

Given that an account and password is required, by looking at KPIG’s website, I don’t know of any way to either use TuneIn or Sonos to access their stream. I think your best bet, unless anyone else has an idea, is talk to the engineers at KPIG, since they’ve set up their account/website system. 

Badge

This is what I used to enter URL for station.

 

Badge

And this

 

Badge

? Not showing on previous.

***

 

*** Moderator note: Image removed at poster’s request

Badge

KPIG Engineer said, “There is no "KPIG Engineering problem. I am the engineer for the station.Ask them the version of OS on your Sonos device that is the information needed. And then ask them how to
upgrade your device to 14.0.” He is saying this because in our correspondence he suggested my Sonos software needed updating. Explained it is done automatically. I use Sonos 1 Controller (Currently Software 11.3), as I have accumulated 7 Sonos devices over the past 10 years and am not about to ditch them to put out $$$ for all new ones … but that’s a different problem :)  I did not have any problems to date EXCEPT for this one Tunein KPIG issue. And everything else still works. Why won’t this?

Userlevel 7
Badge +22

so when you paste your personalized links into the Sonos app to add the station manually - what happens (when your adding it manually like this your not really using TuneIn but creating a direct link the station URL).   There wouldn’t be any type of login so I’m assuming the links they gave you have your account already setup in (probably then shouldn’t post them publically).

 

I perhaps would not have posted your ‘exclusive’ URL’s in an open forum that are unique to your KPIG subscription. I suggest that last image be removed.

Just to say, for testing purposes only, I cannot get those URL’s to work in the S1 App, but the secure https:// URL in your list does work in the Sonos S2 App. So there does appear to be an issue with S1 software …and so I suggest you submit a system diagnostic report and then contact Sonos Support direct and explain the issue.

Just to also say I have removed the URL from my own system after the testing here was completed.

Userlevel 7
Badge +22

I went in copied your personal URL (the second one on your screen) and added as radio station (in the screen you previously showed in the desktop app.    copied the url to the first line that says streaming URL and then put description as KPIG Account as the name.

Went in to TuneIn in sonos app and went to My Radio Stations section at the top and picked KPIG Account and came up just fine.  Listening to it right now.

Userlevel 7
Badge +22

 

Userlevel 7
Badge +22

oh wow - they actually are Pig themed!

 

Userlevel 7
Badge +22

Ah I see Ken sees problem with S1 software - I am on S2 software on my system at home.

I went in copied your personal URL (the second one on your screen) and added as radio station (in the screen you previously showed in the desktop app.    copied the url to the first line that says streaming URL and then put description as KPIG Account as the name.

Went in to TuneIn in sonos app and went to My Radio Stations section at the top and picked KPIG Account and came up just fine.  Listening to it right now.

Yes me too @Chris  - but I could only get it to work using the S2 App. I could not get it to work with the S1 App. Do you have an S1 system you could perhaps try it in that App too, that’s if you were using S2 during your test here?

Userlevel 7
Badge +22

My S1 system is at my other house so I can’t check it.

 

Ah I see Ken sees problem with S1 software - I am on S2 software on my system at home.

ha ha😀 - I see our posts crossed @Chris  - no worries. Yes, the station URL definitely works with the S2 App. So its possible there might be an issue with S1

The S1 App still lets me add the same URL, but for some strange reason it just will not play.

I think it’s perhaps a case for the OP to contact Sonos Support direct to see what they can discover from a diagnostic report.

Badge

Thanks to all who have responded. Yes, I guess I shouldn’t have included those, but then you couldn’t have done such good work! (And I hope those that did, enjoyed what music they heard. Really the greatest station.) All, please forgive my tech frailties, but I don’t see how to remove that photo with URL’s. Edit is not an option.Oly LINK TO URL and FLAG. And I'm probably not posting this correctly, but  hey, I just want Sonos to work like it was, and not learn more technology (Sorry guys).