Answered

NASDrive won’t connect

  • 7 October 2021
  • 5 replies
  • 291 views

For several years my Sonos has played my albums on my WD My book live. I am now receiving a message that my book live does not exist. The drive is connected directly to the bridge with a cable.

I have tried disconnecting everything and rebooting. I have uninstalled and reinstalled the NAS drive . I am not tech savvy and have looked through other posts but to no avail. Any ideas?

icon

Best answer by Airgetlam 8 October 2021, 01:17

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Has the NAS received a recent firmware update? If so It could have disabled SMB v1, which Sonos requires. 

Thank you for the answer. Unfortunately I don’t understand what that means. I am not a computer expert just a user. How will I find out if I have received a firmware update and what do I need to do if I have?

Thank you for the answer. Unfortunately I don’t understand what that means. I am not a computer expert just a user. How will I find out if I have received a firmware update and what do I need to do if I have?

You may want to head over to the WD community forum, or perhaos speak with the WD support desk to find out how to change the sharing protocol back to SMB v1- it’s ‘perhaps’ a case that the NAS Drive is using a newer version SMB v2 or higher and Sonos are yet to make that switch with their software - There is inference/mention the Sonos update may happen before the end of the year, but it’s probably just a setting you need to change on your NAS in the meantime, until the update is released.

Hope that assists you to get access again to to the NAS.

Consider the possibility that the drive has failed. Is the drive visible to your computer?

Somewhere around, there is a thread in which I detailed how to change the settings on version 5 of the WD MyCloud software. No need to be a “computer expert”, just need to be able to log in to the settings on your NAS. Aha, here it is.

There is an extensive discussion about how to set up SMB v1 in this thread.