Music Library - “No selections are available’

  • 28 May 2021
  • 2 replies

Userlevel 1
Badge +1

My system is a pair of Sonos 1’s with S2 controller. Mac OS Big Sur. After upgrading from S1 to S2 I lost acess to my Mac OS library. It resides on another drive attached to my desktop. I have tried every possible suggestion on this website and still can’t manage to get it to recognize the library. I think it has something to do with the path. When I browse for the folder on the desktop, I identify it without problem, but in the iOS Sonos app it lists a different folder. If I try to force add the folder by typing in the path, it won’t recognize it. Any ideas?


Best answer by jjodod 30 May 2021, 22:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 1
Badge +1

Figured it out on my own. I’m posting here for somebody who has the same issue. On Big Sur you need to have BOTH the Sonos app and Sonos library selected in the Privacy settings for disc access.

Thanks for the tip.  Specifically, both

Sonos and


need to have Settings/Security and Privacy/Full Disk Access


Sonos, why do we have to dig so deep to figure it out on our own?  Your instructions state ‘follow the prompts’ - it does not work like that.

PS Still no ‘Imported Playlists’… maybe it needs more time