Answered

keep losing connection with devices

  • 24 November 2023
  • 2 replies
  • 105 views

I recently upgraded my router with spectrum to their smart router 6e.Since the router change i keep losing connection to my speakers it will not show up in my app when i click on system.Seems like i have to reboot my router unplug all my speakers to get them all back. But i dont want to keep doing this.I have read some forums that people are having trouble with the new spectrum router and the sonos system.If this is true can you recommend a router that works best with Sonos

 

icon

Best answer by ratty 24 November 2023, 22:16

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

Hi

Can’t recommend a router but be sure you follow the instructions in the link below:
 

https://support.sonos.com/en-us/article/connect-sonos-to-a-new-router-or-wi-fi-network

Note: If you decide to connect a router of your choice to the Spectrum box (modem portion) be sure to turn off the WiFi signal and/or place the Spectrum unit in “bridge” mode.

Make sure the Spectrum router isn’t in the Hall of Shame, though this list isn’t exhaustive.

If speakers go missing then it’s usually an IP address conflict. Rebooting the router and Sonos units isn’t sufficient. You’d need to reboot/reconnect everything on the network. Alternatively wait 24 hours and it should all sort itself out.

To avoid this kind of issue, reserve fixed IP address in the router for Sonos devices and your mobiles. Consult manufacturer documentation.