Issue linking YouTube to Sonos app

  • 26 September 2022
  • 4 replies
  • 141 views

Hi, sorry for the noob question... totally new to Sonos (yesterday) and trying to get everything sorted in the app.

I have a lot of tracks in playlists in my YT library that I now want to stream on Sonos. I've set up all my other streaming services successfully...but not YT.

I've linked and authorized through Sonos app and YT, but when I access YT in the Sonos app I get the message 'Unable to browse music'.

I've deleted and started again...no difference.

I've re-authorized...no difference.

Any suggestions for a fix before I ditch the Sonos app (on day 2 😂!) and buy a Bluetooth receiver.

Many thanks

Rob​

 

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

It looks like the Google account credentials have not been authorised with the Google servers. The re-authorisation in the Sonos App will generate an 8 character code similar to something like CWKG-CYGN - copy the unique code generated in your App and select to ‘authorise’. It will take you to the Google servers to paste the code into a box and log you into your account. Then just follow instructions to get the account authorised.

Note it might just be the case their severs are temporarily unavailable, although I’ve just tried it here and it is working for me (I’m based in UK).

Thanks Ken, I'd already done all that (twice), but I did it again...just for luck...no difference.

Got the authorisation successful screen from Google, back to Sonos and instead of 'Unable to browse music' I now get 'No selections are available '.

Its annoying these things don't work normally first time. One app clearly doesn't fit all...spoiled initial experience of Sonos.

Had another suggestion of rebuilding all my playlists in another streaming service 😭.

Rob

 

I’m not a ‘paid’ user, (I opted to use Amazon Music & Deezer), but have YTM as a ‘free’ service and uploaded some tracks and can see those, but I can’t see much else. 

As I understand it, I would need to subscribe. I have just posted some images as a collage so you can just see, what I see via the service.

Another thing you could perhaps try, is a different DNS perhaps🤔, but you won’t see much/anything if just using the ‘free’ YTM service, unless you upload your own music to their cloud.