Question

How to solve the Error 913 (Music Library) on a Mac


Userlevel 4
Badge

There is a reported bug fix coming mid-June 2024. If you can’t wait until then…

(I did this running Sonoma 14.4.1) And thanks to folks in a separate thread on the details - just tried to put them all in one place.

I made a video of the process if you prefer that way: https://youtu.be/kjhKhDuvgDY


Part 1 - Set up the share (System Settings/Preferences)

  1. Open System Settings (in earlier MacOS it’s called System Preferences).
    • Click on the apple in top left of your screen to find that option.
  2. Choose General
  3. Select **Sharing**.
  4. Enable **File Sharing**
  5. Click the "i" symbol
  6. Click the "+" symbol.
  7. Add a shared folder by choosing the folder where your music is stored and selecting Open
    • The name of the folder here will be the ShareName that you’ll use in Part 3.
  8. Under ‘users’, confirm that the list includes an ‘everyone’ option, and that you set ‘everyone’ to *Read Only* at a minimum (or “Read & Write”)
  9. Ensure the customer's account is set to **Read & Write**
    • I’m not 100% sure ‘customer’s account’, but I took it to mean the account I login with on the computer.
  10. Click the Options button
  11. Ensure that both SMB and the customer's account below are checked and choose Done. 

Part 2 - Find your computer’s name

  1. At the bottom (or sometimes top in earlier versions of macOS) of the Sharing page, you’ll see Local hostname. Everything before the .local is the hostname. Copy that down - that will be your MacName that you’ll need in Part 3.

 

Part 3 - Add the share to Sonos

  1. Open the Sonos app on your mac.
  2. Choose Manage > Music Library Settings
  3. Choose the + for your music folders.
  4. Instead of ‘another folder or drive’, choose Networked Device
  5. Type the network path name when prompted, and press Next. The format will be \\MacName\ShareName
    • Remember the ShareName and MacName you captured earlier? This is where you’ll use them. Make sure the \ are the right ones (not /, but \).
  6. Enter the Mac username and password. The password is the same as when you login opening your laptop.
    • If you’re not sure about the username, you can find it this way:
      • Open an app called ‘Terminal’ on your macbook. (Go into Launchpad and type ‘term’ and it’ll show up)
      • Type whoami and press enter. 
      • The result that shows is your username. (e.g. Perhaps my computer shows my login name as Salami Slices but my username technically is different (salamislices)). Copy and paste that into the username that Sonos is asking for.
  1. If that doesn’t work, someone had mentioned trying the following:
    • From System Settings, on left side, choose ‘users and groups’
    • Click on the ‘i’ next to Guest User
    • Enable “Allow guest users to connect to shared folders” and choose OK.
    • Now, from Sonos app, when get prompted for username and password, leave them blank and just choose enter.
      • The idea is it would treat it as a guest and since gave access to guests, will work.

 


108 replies

There is a reported bug fix coming mid-June 2024. If you can’t wait until then…

(I did this running Sonoma 14.4.1) And thanks to folks in a separate thread on the details - just tried to put them all in one place.

I made a video of the process if you prefer that way: https://youtu.be/kjhKhDuvgDY


Part 1 - Set up the share (System Settings/Preferences)

  1. Open System Settings (in earlier MacOS it’s called System Preferences).
    • Click on the apple in top left of your screen to find that option.
  2. Choose General
  3. Select **Sharing**.
  4. Enable **File Sharing**
  5. Click the "i" symbol
  6. Click the "+" symbol.
  7. Add a shared folder by choosing the folder where your music is stored and selecting Open
    • The name of the folder here will be the ShareName that you’ll use in Part 3.
  8. Under ‘users’, confirm that the list includes an ‘everyone’ option, and that you set ‘everyone’ to *Read Only* at a minimum (or “Read & Write”)
  9. Ensure the customer's account is set to **Read & Write**
    • I’m not 100% sure ‘customer’s account’, but I took it to mean the account I login with on the computer.
  10. Click the Options button
  11. Ensure that both SMB and the customer's account below are checked and choose Done. 

Part 2 - Find your computer’s name

  1. At the bottom (or sometimes top in earlier versions of macOS) of the Sharing page, you’ll see Local hostname. Everything before the .local is the hostname. Copy that down - that will be your MacName that you’ll need in Part 3.

 

Part 3 - Add the share to Sonos

  1. Open the Sonos app on your mac.
  2. Choose Manage > Music Library Settings
  3. Choose the + for your music folders.
  4. Instead of ‘another folder or drive’, choose Networked Device
  5. Type the network path name when prompted, and press Next. The format will be \\MacName\ShareName
    • Remember the ShareName and MacName you captured earlier? This is where you’ll use them. Make sure the \ are the right ones (not /, but \).
  6. Enter the Mac username and password. The password is the same as when you login opening your laptop.
    • If you’re not sure about the username, you can find it this way:
      • Open an app called ‘Terminal’ on your macbook. (Go into Launchpad and type ‘term’ and it’ll show up)
      • Type whoami and press enter. 
      • The result that shows is your username. (e.g. Perhaps my computer shows my login name as Salami Slices but my username technically is different (salamislices)). Copy and paste that into the username that Sonos is asking for.
  1. If that doesn’t work, someone had mentioned trying the following:
    • From System Settings, on left side, choose ‘users and groups’
    • Click on the ‘i’ next to Guest User
    • Enable “Allow guest users to connect to shared folders” and choose OK.
    • Now, from Sonos app, when get prompted for username and password, leave them blank and just choose enter.
      • The idea is it would treat it as a guest and since gave access to guests, will work.

 

Brilliant, thank you so much for working this out and sharing it.

If only Sonos alleged support could have told us this two weeks ago!

Thank you for your share on how to fix this I may try on the weekend. I am very disappointed that the update was sent out into the world in a way that wouldn’t play music from an iTunes library on a mac. My system has worked perfectly for years, and this updated has bricked it in relation to my own music library.
At the moment I can only play spotify cast from my phone to the speakers, not ideal.
In my library I have 10000 or so tracks, in spotify two play lists, doesn't really compare,

Thanks. Worked for me.

Userlevel 1

This was brilliant.  I wasted so much on time on hold for Sonos, which never came through, that I was able troll the net a find out the mysterious solution to the 913 Error Code. One thing you might emphasize in Step 7 is “Add a shared folder by choosing the folder where your music is stored and selecting Open”. This is the name you need to add with the backslash and your computer’s name in the “Manage Music Library” of Sonos, under NAS.  I realize you do say this, but you provide many other details as well as the process is somewhat intimidating. (I did not need to an “Everyone” as you suggested.) Yet the You tube video showed me the error of my ways.

 

Thanks again. I’ve said it before and and I’ll say it again: Sonos is great until it stops working, and then basically you are on your own.

william

thank you SO much for taking the time to write these instructions. Very clear and very helpful.  thank you again!

THANK YOU SO MUCH!  This was beyond helpful!

Userlevel 1
Badge

I have followed these instructions step by step multiple times and it still does not work. I routinely remotely login to my iMac so I know what I am doing. My iTunes library is on an external hard drive and I am running Mojave. The only thing I can think off is I have a space  in ,y iTunes folder name IE ITunes New could that be causing this. 

Hi, a big thank you to salami slices for the sterling work. However, the solution isn’t working for me - after everything seemingly going smoothly and my music library indexing the process cuts out and I keep getting the following message:

‘//MacBook-Air-3.local/Music’ is no longer available. The device where the music files are stored may not be powered on, or the path may have changed. Go to Settings > System > Music Library > Music Library Setup to check the path

Of course there is nothing showing in Music Library Setup as the indexing process didn’t complete…

I’ve tried choosing another folder e.g. iTunes and get the same result

I was wondering if anyone else had received this message after following the instructions and if there is anything I’m doing wrong/anything else I can do?

 

 

 

 

Reply to ed18002…. it doesn't work for Catalina os either... 

FYI, I failed to get it to work on my MBP w Sonoma 14.5 so I bit the bullet and waited 62 min for Sonos.

The dude was very nice, spent about 40 min w me and basically followed what you had suggested multiple times and still got 913 and 1002 errors, check user name/PW, etc.

I can’t believe Sonos hasn’t jumped on a fix for this.

This has to be a move to get us all on their music sources; sad.

Userlevel 3
Badge +1

Since I have Amazon Prime, I was able to create a Playlist and can play from SONOS.  Of course the queue is empty and you can’t shuffle or anything- totally ridiculous.

 

Eventually got this to work - desktop only so far - thank you! 

What helped was deleting the prior app completely before doing an update. This prompted the system ID and password screen, thankfully explained. I was able to run the script to get that. 

Now I just have to get the updated apps to recognize the library. My phone keeps saying “Something went wrong” in between the constantly animating headers, and on my iPad it’s not showing any icons after 2 hours of trying to load. 

The reliability of Sonos is nothing short of appalling. By far the worst of any product in my entire life - and I’ve owned two Ducatis!

They’re selling functionality that simply doesn’t exist for many of us. I bought my system precisely to play my library throughout my house. That’s not a bug, that’s fraud. 

 

 

Userlevel 1
Badge

I followed the steps and after some tinkering finally got my library back a few days ago. This AM it is no longer showing up on my app?!? 

There is a reported bug fix coming mid-June 2024. If you can’t wait until then…

(I did this running Sonoma 14.4.1) And thanks to folks in a separate thread on the details - just tried to put them all in one place.

I made a video of the process if you prefer that way: https://youtu.be/kjhKhDuvgDY


Part 1 - Set up the share (System Settings/Preferences)

  1. Open System Settings (in earlier MacOS it’s called System Preferences).
    • Click on the apple in top left of your screen to find that option.
  2. Choose General
  3. Select **Sharing**.
  4. Enable **File Sharing**
  5. Click the "i" symbol
  6. Click the "+" symbol.
  7. Add a shared folder by choosing the folder where your music is stored and selecting Open
    • The name of the folder here will be the ShareName that you’ll use in Part 3.
  8. Under ‘users’, confirm that the list includes an ‘everyone’ option, and that you set ‘everyone’ to *Read Only* at a minimum (or “Read & Write”)
  9. Ensure the customer's account is set to **Read & Write**
    • I’m not 100% sure ‘customer’s account’, but I took it to mean the account I login with on the computer.
  10. Click the Options button
  11. Ensure that both SMB and the customer's account below are checked and choose Done. 

Part 2 - Find your computer’s name

  1. At the bottom (or sometimes top in earlier versions of macOS) of the Sharing page, you’ll see Local hostname. Everything before the .local is the hostname. Copy that down - that will be your MacName that you’ll need in Part 3.

 

Part 3 - Add the share to Sonos

  1. Open the Sonos app on your mac.
  2. Choose Manage > Music Library Settings
  3. Choose the + for your music folders.
  4. Instead of ‘another folder or drive’, choose Networked Device
  5. Type the network path name when prompted, and press Next. The format will be \\MacName\ShareName
    • Remember the ShareName and MacName you captured earlier? This is where you’ll use them. Make sure the \ are the right ones (not /, but \).
  6. Enter the Mac username and password. The password is the same as when you login opening your laptop.
    • If you’re not sure about the username, you can find it this way:
      • Open an app called ‘Terminal’ on your macbook. (Go into Launchpad and type ‘term’ and it’ll show up)
      • Type whoami and press enter. 
      • The result that shows is your username. (e.g. Perhaps my computer shows my login name as Salami Slices but my username technically is different (salamislices)). Copy and paste that into the username that Sonos is asking for.
  1. If that doesn’t work, someone had mentioned trying the following:
    • From System Settings, on left side, choose ‘users and groups’
    • Click on the ‘i’ next to Guest User
    • Enable “Allow guest users to connect to shared folders” and choose OK.
    • Now, from Sonos app, when get prompted for username and password, leave them blank and just choose enter.
      • The idea is it would treat it as a guest and since gave access to guests, will work.

 

Brilliant, thank you so much for working this out and sharing it.

If only Sonos alleged support could have told us this two weeks ago!

It worked so far as to connect the folder. However, the SONOS app does not sync the albums and titles, the library stays empty.

Truly annoying that such an error is not mended asap by SONOS.

All hail Salami Slices!

I have Big Sur 11.7 and managed to figure out the differences from your instructions for Catalina. It worked. Can’t thank you enough.

I just can’t believe Sonos just threw all of us under the bus and forced us to use such a thoughtless update.  Absolutely no consideration or thought given to its customers.

Userlevel 3
Badge +1

Joew19- and to boot, not a word from SONOS.  Not even an email as to when they plan on fixing this mess.

Many, many thanks to Salami Slices and the SkyWillBeBlue for their posts!  I tried a couple of times and failed, but then realized I had to select NAS for the computer folder that had my music.  Then presto!  It worked.

 

Of course, I still can’t get my dedicated music library server to connect (through NAS), so I’ve got to keep my computer on (or at least a Sleep) so Sonos will continue to play the music.  And yes, our apps (on iphone) both now pick up the new ‘music library’ - and my playlists are available again!

 

But I can’t wait until Sonos gets the app fixed so I can use my dedicated NAS drive with this.

 

(BTW:  on a MacBook Pro - 2017 - with Ventura 13.6.7).

 

Thanks again!

 

Tim 

Not working for me. I’m running the latest iOs, Sonoma 14.5. I wonder if that could be an issue.

Userlevel 1
Badge +1

UPDATE: While I was able to get it working, I am now missing all my playlists. (Another huge pain point using Sonos with a local iTunes)

I got this off of Reddit - https://www.reddit.com/r/sonos/comments/1cuasf1/comment/l4qucju/?context=3

  1. Open ITunes (Music), click on Home in the upper left, then go to File -> Library -> Eport Library

  2. This will create a "Library.xml" file. Save it to your Desktop

  3. Make a Folder and name it "iTunes" on your Desktop

  4. Rename the "Library.xml" file to "ITunes Music Library.xml" and put it in the folder you just created.

  5. Move this Folder to where your music is. And I mean that literally. Like where you have all the artists listed in your iTunes Musics files.. Put it there.

  6. Remove and Re-import via Sonos and you "should' be all set. You should be able to just "Update Music Library" instead of removing/re-adding, but I'm not 100% sure.

The above steps will need to be repeated whenever a playlist is changed.

Userlevel 1
Badge +1

Not working for me. I’m running the latest iOs, Sonoma 14.5. I wonder if that could be an issue.

Try the steps in the link I posted below. https://www.reddit.com/r/sonos/comments/1cuasf1/comment/l4qucju/?context=3 That actually worked for me - also on Sonoma.

That’s what didn’t work.

 

This worked great for me. Thank you so much for such a well written and step by step solution. Now, I hope that Sonos comes through with that fix.

Thanks Salami Slices.  I can now see my Music Library on my iMac/Sonos.  Next...How do I get my Android phone Sonos app to access this music library?

Thanks so much Salami Slices.
This worked for me after a little bit of trial and error in specifying the Music folder location for the”NAS”.
I was trying to use an overly long file path that showed the exact location on my Mac. But all I needed to state was “\\mycomputername\music” and then enter my user name and logon password.

 

Thanks Salami Slices.  I can now see my Music Library on my iMac/Sonos.  Next...How do I get my Android phone Sonos app to access this music library?

Hi. I’m on iOS app but I started playing a Library track from Sonos Controller on the Mac and the app picked up the Library as a source. 
But Library now right at bottom of page in the lousy new interface, so not easy to find even when connected 😫

Reply