Answered

Delay between Sonos app to Sonos 3 (pair)

  • 9 January 2024
  • 3 replies
  • 137 views

I have several Sonos products around the house (bedroom, study (play 1’s as a stereo pair), lounge (sound bar, sub and play 1’s as surround pair) and kitchen (play 3’s as a stereo pair).

All work fabulously apart from the stereo pair of Play 3’s in the kitchen. There is a distinct delay between the functionality from the app, to the speakers actually playing music, the same delay occurs when the volume is adjusted (the delay can be upto 5 seconds). The delay occurs across all streaming platforms (Spotify, Apple, Radio etc). This does not happen for any of the other rooms.

 

Some help to fix this would be really great please.

icon

Best answer by Ken_Griffiths 9 January 2024, 15:33

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Assuming you’re running all on your WiFi and not a SonosNet (wired) connection to any Sonos product, perhaps just try a different WiFi channel. I suggest using a non-overlapping ‘fixed’ channel 1, 6, or 11 .and to help reduce interference, set the channel-width on that band to 20Mhz only (if the router allows). I suggest rebooting the router and all speakers after making these changes.

Ensure your speakers are set well away (at least one metre) from any other wireless devices or WiFi access point and not near a microwave oven in the Kitchen (as microwaves can interfere with the connection signal).

Also ensure there are no other Apps running on the controller device, particularly security Apps and software , like VPN client, MAC spoofing, Firewall, WiFi calling and disable ‘mobile data’ access for the Sonos App too.

However, if you are using a wired SonosNet link, then ensure the SonosNet channel in the Sonos App is not the same as the non-overlapping channel on the router, as mentioned above …and ensure that any wired device is connected to the router (or an adjacent switch) only and not to any other network access point. Also ensure the wired product is set at least one metre away from the router, or wireless access point.

See if those things improve the connection. 

Hi

Thanks for the reply. I am afraid I have no idea what a a non-overlapping ‘fixed’ channel 1, 6, or 11 is, or how to set the channel-width on that band to 20Mhz only??

But, would that address the problem since all other products/rooms work fine?

Hi

Thanks for the reply. I am afraid I have no idea what a a non-overlapping ‘fixed’ channel 1, 6, or 11 is, or how to set the channel-width on that band to 20Mhz only??

But, would that address the problem since all other products/rooms work fine?

Yes it certainly could make a difference - the settings mentioned are contained in your router configuration pages, so perhaps check the user manual for your router.

You might also find these Sonos Support links helpful too…