Cant access music on my NAS

  • 10 January 2024
  • 1 reply

Hi, after some help please.  Been using Sonos for several years, S1.  Not used it for a few weeks and changed my phone, thought nothing of it, until I tried to access the music on my library on the NAS.  Can see all of the titles but on selecting it states “access denied”  Thought it was an issue with the phone, so deleted app and reinstalled, found the library on the NAS, It then updates the library and shows all of the albums etc again, select a track and again, access denied.  Tried on two phones, PC, same result each time.  Any idea what I'm doing wrong please?


Best answer by Stanley_4 11 January 2024, 04:15

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +22

The phone(s) are just a remote control for the Sonos devices and aren’t likely the issue.

Really sounds like a NAS permission issue so I’d check that first. Also check your NAS didn’t update and make any changes to the SMB v1 access.

If that fails try a re-index and playing a track and submit a diagnostic to Sonos within about 10 minutes. Contact Sonos support with he diagnostic number and they can give you the internal error information we users can’t see.