Apple Music - can't connect

  • 3 October 2020
  • 26 replies

Hi there, for the past couple of weeks I’ve been unable to connect to Apple Music. “We’ve run into a problem. Please try again.”


Tried signing out of Apple Music, reinstalling sonos app etc. No luck.



Best answer by Annazel S 8 October 2020, 21:04

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

26 replies

Userlevel 5
Badge +16

Hi @User262360.

Thanks for reaching out and I appreciate the troubleshooting you did, let me help and try to figure this out.

Is this the only music service you’re experiencing the issue?

Was there any change made on the network recently or a power outage?

Have you tried to remove and add back Apple music service in the Sonos app?


Kindly submit a diagnostic report through the Sonos app when the issue occurs, and reply with the confirmation number.

I'd start by reviewing your system as well as the status of the devices, it will also help in identifying what's possibly causing the issue.


I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out,  we are always here to help.

Hi there,

I am also having the same problem. I can load other streaming services with no problem.

wvery time I try to load the Apple Music service I either get “make sure your Music app is updated to the latest version” which it is, followed by “we’ve run into a problem, please try again”.

I submitted a diagnostic report, number 396044011

this is very frustrating.




I can confirm I have this same problem.

I discovered it because I noticed that updates I was making in Apple Music were not appearing on Sonos. For example, I added two playlists, and they did not appear in the Sonos app.

Therefore, my plan was to remove the service and re-add it, forcing an update, but now I cannot reconnect to Apple Music at all, as I get a “We’ve run into a problem, please try again” error.

Please let us know when a fix is coming!


Is anyone here running a beta version of iOS by chance? I’m running 14.2 beta, so maybe it’s connected to that???

Sonos rarely plays well with Apple beta OS’s. I suspect it’s something in the beta code or server back end, as as soon as they go gold master, it suddenly starts working, with no updates from Sonos involved. 

Is anyone here running a beta version of iOS by chance? I’m running 14.2 beta, so maybe it’s connected to that???

On one of our phones yes, on the other no, so that doesn’t seem to make a difference,

I’m having the same problem, just started today. Running iOS 14.01. Is there a fix?

I’m having the same issue. Started about a week ago before updating iOS to 14.01. Also looking for a fix, anyone have one yet? 

No further responses from the folks at Sonos, one would have hoped they would have a fix by now.

Userlevel 5
Badge +16

Hi everyone. Thank you for your patience in this.

It will be helpful to submit a diagnostic report on the Sonos app when the issue happens and reach out to 

Sonos Support as we can take a closer look and discuss it with all of you individually in real-time. 

I recommend our phone team, for they have more resources available for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the computer/controller to see what's going on.


If you have any other questions or concerns, feel free to reach out, we’re always here to help.


unfortunately it’s still occurring! S1 and S2

Phone support is a pain - can Sonos please start offering email support again?

Userlevel 1
Badge +1

I'm having the same issue with my Apple music account. I have a family plan and my partner can log into her Apple music account on the Sonos app, but I can't. 

I'd updated my Apple ID password yesterday and I believe this is why it won't work. The Sonos app doesn't seem to recognise that I've updated my password.

same issue here, diagnostic code 44988101


error logs say a series of “unable to browse music - there was a problem connecting to apple music” messages and then a series of “we’ve run into a problem, try again”


i have removed and added the apple music service, reauthenticated. happens on my home network and when on VPN for work, has been consistent since iOS14 update, perhaps earlier.

The VPN should be blocking the ability of the speakers to reach out to the Apple servers. 

You also may want to try a reboot of your router, but that won’t change the VPN issue. 

to clarify, my computer where i was running the sonos controller is sometimes on VPN. the speakers have their own network connection and are never on VPN. regardless of the VPN status, the issue is the same

Ah, that wasn’t clear. Still, you should at least try a reboot of your router, followed by a reboot of the speakers. In the meantime, I’ll wait to see what the diagnostic suggests. 

Any update? Also having the same issue (diagnostic info to be sent).

Same issue. It’s wearing real thin I must say. Ive had this issue on and off over the years. I’ve submitted diagnostic reports -  Offered up 2 tread questions - never got a conclusive answer. It’s time to switch to a Bluetooth speaker system.  Sonos - I have given you hours of my time trying to sort out this BS -  out of a sense of loyalty to your vision and suggested ethos. It’s not worth it any more. Over and out.       2 x play 5s on route to the charity shop. 


Same problem. I phoned customer support again as advised on here by a Sonos advisor. Not helpful. Just said it’s a known Apple problem for which there is no fix as yet. 🤷🏼‍♂️


I get an error with number ‘1002’ very often when trying to play Apple Music on Sonos.  I’m getting extremely frustrated with this and Sonos.  There are NO issues with my network as Apple Music works everywhere else and I can use Sonos for other players with NO issues.  Can you please just sort it out.  I’ve invested a lot of money in your products and don’t expect to have this sort of issue.

Userlevel 7
Badge +18

Hi All.

If you’re having trouble playing from Apple Music (or another service, for that matter) please try the following steps:

  1. Check our status page first - if the service is having issues, nothing you can do is going to fix it so it’s best to check before wasting a lot of time and effort. Most services utilise a different portal for Sonos playback, so even if your iPhone can play Apple Music (or whatever other service), that doesn’t mean that they’re not having issues with their Sonos portal.
  2. If you haven’t done so before, please check for and remove WiFi interference. A general rule is to keep WiFi devices 1m apart from each other (especially the router). We have a reducing WiFi interference help page that’s worth a look. If other (similar sound quality) services don’t have a problem, this probably isn’t needed.
  3. Reboot your WiFi router, and anything that extends it’s range (mesh systems or wired APs - extenders and boosters are unsupported). Removing power for at least 30 seconds is the best way to do this. It may help to also reboot Sonos at the same time, but turn on Sonos again after WiFi is back.
  4. Remove your music account from Sonos and add it again - when software is updated (this could be Sonos updates, or Apple or Sonos server updates) accounts sometimes need reauthorised and removing and adding the account is sometimes more effective than choosing the Reauthorise option. Go to Settings » Services & Voice » Apple Music » Remove account.

If these steps don’t help. I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system, network and situation.


None of these steps work.  Maybe before calling Technical Support, what is “error 1002, adding tracks to the queue”?

Userlevel 7
Badge +18

Error 1002 in reference to playback is due to a timeout - the speaker has 20 seconds to load the entire queue and if it fails to do so, you’ll get that error. It typically happens when larger (over 500 tracks) playlists are loaded.

It shouldn’t happen, however, so we would very much like you to get in touch with technical support so we can document some details and investigate this, or address local network issues if they are the cause.


Thank you for providing some details on the error message.

After connecting technical support I was given some things to check on my router (Linksys MR8300) which I’ve added my notes next to each:

  • The 2.4 GHz Band needs to be enabled. Split 2.4GHz and 5GHz (separate SSID for each band). [This was already done before the call, so no impact]
  • Make sure Mode is set to 802.11 b/g/n. [No options to select on my router, but does by default including ac mode]
  • Client isolation should be off to ensure WiFi devices can communicate with each other [Don’t know what this is so couldn’t do anything, support couldn’t explain well]
  • Select a manual WiFi channel, do not set to auto. Preferably channel 1/6/11. []
  • Security type should be WPA2 with AES Encryption. [WPA2 set, assume with AES encryption as this is not something I can select on my router]
  • Enable UPNP. Change DNS to - Primary - Secondary [I made this change]
  • Enable multicast. [I made this change]
  • Disable smart setup or any other setup assistant. [I don’t think I have this on, can’t see anything that might relate]
  • Enable IGMP snooping [not an option on my router from what I can see]

None of the changes here have resolved the issue.  Technical Support not open until Monday so will have to wait to find out next steps.