Answered

App is slow, takes minutes to find speakers

  • 27 August 2023
  • 10 replies
  • 13206 views

Userlevel 2
Badge
  • Trending Lyricist I
  • 13 replies

Since early this year the app has become slow, the last few weeks I usually have to wait for more than a minute for it to load the speakers, and in many cases it simply does not list them, or only one or two. Nothing has changed speakers-wise, not even WIFI-wise. If I use Spotify it finds the speakers almost instantly. I didn’t change app settings or system settings that would have an impact on the Sonos controller. Sigh. 

I also notice that while it’s finally playing, loading a different track often does not happen. The speakers don’t respond and Sonos just plays the ‘wait’ cursor, or tells me it cannot connect. Again: if I switch to Spotify it plays things immediately.

I just don’t understand how things are sliding downhill so fast.

Ever since February/March the cross-fading won’t work which is a big deal. And the app has been growing increasingly slow. This is so frustrating. If I had not invested in this system years ago I would currently drop it. The speakers and more are fabulous, the sound is so good. But it all depends on this buggy app for an interface and I don’t know what happened but Sonos: what the heck is going on with the app???

icon

Best answer by ratty 27 August 2023, 17:53

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 7

Have you tried deleting and reinstalling the Sonos app or rebooting your router? Are any speakers wired directly to the router?

Classic symptoms of wireless interference and/or IP conflict.

For the former, see https://support.sonos.com/en-gb/article/reduce-wireless-interference. Also see 

For the latter, reserve IP addresses in the router’s DHCP server. Consult the router documentation for instructions. 

Userlevel 7
Badge +22

Fussed with my system and did the WiFi interference stuff and things were still slow. Sent Sonos a diagnostic and contacted them about it. They decided I had two different locations where I had speakers too close together and they were messing up the networking. One was obvious as they were sitting together, the other was a surprise as they were in different rooms, but back to back against the same wall.

Gaining separation on the problem ones fixed that issue.

Same on an earlier issue, a speaker sitting too close to an RF noisy device, it had no radio, just poor design. Again a couple feet of distance helped.

 

So do what you can yourself, particularly getting distance for m other RF sources. Then send in a diagnostic right after you see the issue and contact Sonos with the number if you think there is still an issue.

Userlevel 2
Badge

Thanks.

I didn’t reinstall the app or change anything about the set-up or location of any speakers, but I did regroup the speakers in a different way. The app, at the moment, is finding the speakers and doesn’t take as long anymore. This may change and may be a coincidence but I thought I would reply to show I am still here, and reading answers.

I didn’t think to mention the fact that since about 6 weeks, the app is incredibly slow to show the music that is playing. It will show the speakers at some point, but not what’s playing. I have to close the app, then retry. It usually takes at least a minute to actually see the music which also means I can’t control the volume. This is a pain, of course, as well as the fact that I can’t skip a track. It’s weird.

On the bright side!

For some reason suddenly cross-fading works and does not skip to the next song after 10 seconds. This is improvement. Maybe the situation will stabilise. I have been using Sonos for about 9 years now and would really be unhappy to see it go.

Unlikely that your local network issues, which would be causing this ‘slowness’, would just resolve themselves. There’s a lot of useful posts above that should help you fix the issues you’re experiencing. 

Same issue here, but only with the official Sonos app on my iPhone. It can take up to a minute before all speakers are found and can be controlled. All thrid party apps are working from the first second I open them.

I changed my network setting in the Unifi controller and every speaker has a static IP address. But still the Sonos app is slow. So it’s only related to the official Sonos app on my iPhone. My wifi is experiencing the same. It’s all up to date, Sonos app, iPhone etc
 

Any other suggestions

Same issue here, but only with the official Sonos app on my iPhone. It can take up to a minute before all speakers are found and can be controlled. All thrid party apps are working from the first second I open them.

I changed my network setting in the Unifi controller and every speaker has a static IP address. But still the Sonos app is slow. So it’s only related to the official Sonos app on my iPhone. My wifi is experiencing the same. It’s all up to date, Sonos app, iPhone etc
 

Any other suggestions

Yes, checkout the following…

  1. Log into the UniFi controller
  2. Click the Settings tab on the left sidebar
  3. Click WiFi under the Settings page
  4. Click on the network SSID. Note: if there are multiple SSIDs that the players and controllers connect to, the same will need to be done for each SSID.
  5. Scroll down to Advanced Configuration and set it to Manual
  6. Verify and confirm that WiFi Type is set to Standard
  7. Click on the Apply Changes button at the bottom of the page.
  8. Click on Settings > Networks and select the network that Sonos is being set on.
  9. Scroll down to Advanced Configuration and set it to Manual
  10. Verify and confirm that Network Type is set to Standard and IGMP Snooping is enabled.
  11. Disable the following options by unchecking the Enable option:
  12. Multicast and Broadcast Control (blocks all multicast and broadcast for non-listed devices).
  13. Multicast Enhancement (converts multicast to unicast when possible).
  14. Client Device Isolation (prevents wireless client on the same AP from communicating with each other).
  15. Proxy ARP (converts broadcast to unicast when possible).
  16. Once completed, allow up to a minute for the AP to apply the new settings and restore the online connection, then proceed to the connection or setup of the Sonos system.

Thnx @Ken_Griffiths 

This solved it!!

 

But still kind of strange that it only occurred in official Sonos app, not in the third party apps.

 

I got really tired of having Sonos tell me that this is my problem and that I need to reboot the system. This is clearly a Sonos issue. They need to fix it. I’m considering getting rid of my Sonos speakers and trying something else instead. But before doing that, I’m trying an app called Orto for Sonos. It’s $9.99 per month, which does not seem very expensive. But, then again, why should we need to pay for another app to make our Sonos systems work appropriately?

So far, so good, with respect to Orto. It seems to find my speakers all the time. I’ll be playing with it during the one-week free trial. Interface takes some getting used to.

Userlevel 1

I had similar issues with generally slow app on S2, really sluggish to search/play/pause/change tracks etc…

I checked all the things like ip reservations and wifi interference but for me at least the culprit was the tunein app.

There are two versions on sonos app list with one version being old and unsupported. I never use it and it was installed way back when the kit arrived as default I think. I had the old version and the second I uninstalled it my problems went away.

not sure if installing the new version would have caused an issue or not as it’s not something I use so easier just to remove it entirely.

Hope this helps someone in a similar situation.