15.2 Update notes


Userlevel 7
Badge +14

There will be an interesting addition to our Apps soon via this latest update - 

We’re rolling out a new WiFi signal strength feature over the coming weeks.

  • When connected to a WiFi network, your Sonos products will now show their WiFi signal strength in the Settings tab of the app.
  • Additionally, you can now find detailed networking information for a Sonos product connected to your WiFi network.

Wonder what the SonosNet products will show? Nothing?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

19 replies

Userlevel 7
Badge +12

Nothing new showing on my app

On moves or roams

Userlevel 7
Badge +14

Nothing new showing on my app

On moves or roams

They are rolling that bit out in stages it says - probably like the new search feature which I still don’t have 

Userlevel 7
Badge +12

@SarahN ahhhh 😜

Userlevel 4
Badge +1

Alexa on Beam v1 is broken after the 15.2 update.  Fed up. Every update destroys my system.

Userlevel 7
Badge +20

Alexa on Beam v1 is broken after the 15.2 update.  Fed up. Every update destroys my system.

@mhutchz Can I suggest that you open a new thread, as this is completely off topic.  There is a very obvious cause when updates cause system instability. Suffice to say that the update has not caused any issues with my Beam v1.

Userlevel 7
Badge +14

Thanks @UKMedia 😊 - I did want to keep this thread about the new WiFi signal strength feature which will be rolled out on our apps, and how that will work 

Userlevel 7
Badge +14

@Corry P - when this new feature lands on our devices, if we have SonosNet for some items will this new WiFi signal app feature only show on our WiFi devices?

In my case, it’s only my portable speaks that are not connected via my Boost.

Userlevel 7
Badge +18

Hi @SarahN 

Yes - signal strength will only be displayed for devices which connect to a router (or Access Point) and not for those configured as Home Theatre Surrounds, Home Theatre Sub or those on SonosNet.

Hi @SarahN 

Yes - signal strength will only be displayed for devices which connect to a router (or Access Point) and not for those configured as Home Theatre Surrounds, Home Theatre Sub or those on SonosNet.

 

Although, I use sonosnet for every device I can currently, looking forward to this feature.  I have an Eero mesh system and was wondering if I’d be just fine without sonosnet, so this will be good for testing.  I can move some speakers (or all of them) to WiFi and be confident in a strong connection without having to do random sound tests.

Every update kills my entire system. I have been attempting to update to 15.2 for the last 6 hours without success. Tech support is absolutely no help. Feel like a hampster in the proverbial wheel. System is advertised as seamless installation - it is not. When a system forces an update and there is a constant “Update Problem” and the only solution is to “Try Again” there should be a way to rollback. For all the haters and/or Sonos shills I have a very robust Ubiquiti home network and I have reset the router. The system was working fine for months before this update.

Solution is to go and factory reset all 40 of my Sonos products? What kind of system update is this?

Sonos needs to get their act together and not release software that requires an update which you have to reset everything and hope it works????

I can’t tell you how many hours/days I have spent getting a crap system to work. Regret ever making the investment!

Anyone that is thinking of purchasing a wireless system (which isn’t true) should avoid Sonos. Purchase another system. Sonos is very expensive junk. 

Userlevel 4
Badge +1

Every update kills my entire system. I have been attempting to update to 15.2 for the last 6 hours without success. Tech support is absolutely no help. Feel like a hampster in the proverbial wheel. System is advertised as seamless installation - it is not. When a system forces an update and there is a constant “Update Problem” and the only solution is to “Try Again” there should be a way to rollback. For all the haters and/or Sonos shills I have a very robust Ubiquiti home network and I have reset the router. The system was working fine for months before this update.

Solution is to go and factory reset all 40 of my Sonos products? What kind of system update is this?

Sonos needs to get their act together and not release software that requires an update which you have to reset everything and hope it works????

I can’t tell you how many hours/days I have spent getting a crap system to work. Regret ever making the investment!

Anyone that is thinking of purchasing a wireless system (which isn’t true) should avoid Sonos. Purchase another system. Sonos is very expensive junk. 

My system (Beam + 2 Play:1’s) broke after the 15.1 update and now again after the 15.2 update. I have already done all the usual troubleshooting steps but nothing has activated any of the voice or music services linked to the Sonos app. I regret buying Sonos and will never recommend it to anyone. Sonos has made all my smart devices dumb because Alexa is broken.

Have you set your Ubiquiti switches for “STP’. Also, you should be “reserving” IP addresses (I believe Ubiquiti refers to this as a “fixed” address) for your network clients.

Are your players wired or wireless? If your players are using WiFi it is best to disable “AUTO” WiFi channels. Also, some versions of Ubiquiti allow you to fix the access point association to be used by a client. Obviously this is a bad idea for portable players or players that are moved often, but I recommend fixing the access point for stationary units.

Are you initiating the update using a desktop controller or a phone/pad?

I don’t recommend Factory Reset without some consult. While a Factory Reset might accidentally, temporarily work around something, it rarely cures fundamental issues.

You must have multiple SONOS systems because a system will only support 32 units and 32 simultaneous controllers.

Userlevel 5
Badge +8

My system auto updated today to 15.2, both app and hardware 

The signal strength feature is not present...

Userlevel 7
Badge +14

@GC3  - see point below from Sonos (and stated in my original post) 😁:

 

We’re rolling out a new WiFi signal strength feature over the coming weeks.

It won’t be on your app just yet.

After the 15.2 Update, some of my Sonos Favorites for Sirius XM stopped working with an error message of something like “Unable to Play” .  Some worked fine.  It seemed random.  However, I could go search the Sirius XM Music Source and play the exact same station from there.

 

I solved it by deleting the favorites, and then reinstalling the exact same favorites. 

Userlevel 5
Badge +8

@GC3  - see point below from Sonos (and stated in my original post) 😁:

 

We’re rolling out a new WiFi signal strength feature over the coming weeks.

It won’t be on your app just yet.

Then why even announce in the first place, with reference to 15.2? One thing that you can count on Sonos doing reliably, however, is put out info prematurely...

Then why even announce in the first place, with reference to 15.2? One thing that you can count on Sonos doing reliably, however, is put out info prematurely...

 

Funny, one of the biggest complaints about Sonos over the last 15+ years is they never announce new features until day of release.  Damned if you do and damned if you don’t, I guess.

Feb 28th was doomsday. From that update on my system has been headache after headache. It worked flawlessly prior to that date. I have removed speakers that previously worked to try and bring the count down. I exceeded the 32 count max. Reset routers, mesh points, turned off Band steering on/off, router steering on/off, Hard wired Sonos, removed hardwire from Sonos. Ran Sonos of 5g, 2.4, 5gwifi6, 2.4wifi 6. It says its playing and it isn’t. Beyond annoyed.  I have easily have dropped 15k on these speakers and up until a month ago, I was very happy. Now all I get is aggravation. I am very tech Savy and I even broke down to call tech, and they were closed when they said they were open. 

ughhh, my SL surrounds and Sub keep dropping off the app, sometimes the disappear altogether...very annoying