The latest info on fixing your completely gone system (you might have to take a look at your wifi router settings)

  • 11 July 2024
  • 5 replies
  • 170 views

Userlevel 6
Badge +4

Hey folks,

 

More than 2 months now have gone by and I am still happily on my old S2 app, all updates disabled.

Why? Because the new app with all its updates is sooooo useless, slow, laggy etc.

 

Here are some (very technical) explanations as to why it is so (not by me):

https://www.linkedin.com/pulse/what-happened-sonos-app-technical-analysis-andy-pennell-wigwc

 

And here some suggestions on how to fix it (not by me):

https://www.reddit.com/r/sonos/comments/1dy8srm/common_fixes_on_a_home_network_for_mdns_new_sonos/

https://www.reddit.com/r/sonos/comments/1dyxx6o/the_latest_info_on_fixing_your_completely_gone/

 

Now the bad news: the fixes do not work … at least not for me.

I have an Asus AIMesh for years with some powerful routers interconnected. 

Same Network/Subnet? Check.  Check Wi-Fi Isolation? Check. Multicast/IGMP Settings. Check

Never touched these, they were always enabled. But the whole system is still laggy (with the new app only). The first article mentions the chatty communnication via cloud in order to get your album infos etc. I have a very stable 1GB glasfiber connection ….

But maybe theses fixes can help some of you.

Can´t promote thes links enough, spread the word that there might be a fix.

 

PS: see also 

 


5 replies

Userlevel 2
Badge +1

I’m one of those Reddit users trying to spread the word on potential network related issues and fixes. Thanks for the cross post!

You mention you have interconnected routers. You are talkng about a straight up mesh wifi network or something else?

The chattines of TLS is very much an issue, and for what its worth, the speed of your fiber connection sadly has no big effect on those issues. It will be the traffic loads on the router(s) firmware and hardware, and the capacity of those routers to deal with all the incoming and outgoing message packets. A router has a pretty limited memory, which is normally never an issue given the simplicity of its tasks, directing packets to their correct destinations. It can become a big problem if there is a LOT of packet traffic coming in that doesn’t allow the router enough wiggle room to handle it quickly enough, causing a backlog, then those same packets are repeated because they didn’t get successfully routed, making an even bigger traffic jam. This is like a boss interrupting your phone calls every 30 seconds asking why you haven’t finished the phone call yet. It just slows everything down.

Sorry to hear about the volume lagginess. If you have network isolation turned off, I guess you are in the wait and see boat for updates.

 

Userlevel 6
Badge +4

Thanks for your valuable comments ranash1995!

I have a mesh network which worked very well and without lag with the old S2 app.

It is true that the main router is the most performant, while the satellites are less.

This means that in order to use the new Sonos app one should buy more performant routers. It makes sense when looking at your findings.

My plan for this weekend is the following:

  • setup a separate WIFI network, e.g. guest
  • install the older S2 app via APK on an unused Android 
  • setup a new sonos account 
  • install 1 old Ikea speaker from scratch

After testing this config, I will update to the new Sonos app. I`m afraid it will also update the FW of the speaker so I will not be able to use it anymore with the old app. Sacrifices for the science….

I will compare the throughput, lagginess etc. as far as this is possible with just one speaker.

 

 The linkedin article talked about older speakers struggling to keep up, especially grouped volume. which contributes to lagging and app issues. Something to think about before replacing your router. 
 

The old S2 app is still working with latest firmware apparently so if you should be good, but I would turn off auto updates as it may change. 
 

Looking forward to your updates. 

Userlevel 6
Badge +4

It did not work as expected …

I installed the old S2 on a  new phone on a separate network. Made an account from scratch. Then I wanted to add an IKEA symfonisk to the new (still empty) system . Didn´t let me, had to update to the new app.

Did that. And before I could react, all my loudspeakers in the house were infected with a new update. 

This app is very intrusive and aggressive!

And it created an Sonos WIFI network! How do I get rid of that?

Anyway, setting up a new system with a new user on a separte network did not succeed: the new app recognized the speaker, played a sound, but did not add it. I tried 5 times and after an hour and several resets I abandonned.

After numerous updates and resets I now have an old S2 and a new S2 app on different phones, both managing the same system. All loudspeakers are up to date. And everything seems still to work with the old S2 app. I was even able to add the Symfonisk with the new S2 app to my existing system.

 

In comparison, the new S2 app takes a bit longer to load graphics. But the incredible sluggish lagginess from the beginning seems to be gone. When it comes to control volume of grouped speakers you see/hear the difference: in the old S2 app the volume modification with the slider is in real-time, with the new S2 app you have a slight delay (~1 sec)

 

I´ll continue to compare both apps in the coming weeks...

 

PS: did not touch any of my network settings. So the new S2 app seems to have improved.

Userlevel 7

Hey folks,

 

More than 2 months now have gone by and I am still happily on my old S2 app, all updates disabled.

Why? Because the new app with all its updates is sooooo useless, slow, laggy etc.

 

Here are some (very technical) explanations as to why it is so (not by me):

https://www.linkedin.com/pulse/what-happened-sonos-app-technical-analysis-andy-pennell-wigwc

 

And here some suggestions on how to fix it (not by me):

https://www.reddit.com/r/sonos/comments/1dy8srm/common_fixes_on_a_home_network_for_mdns_new_sonos/

https://www.reddit.com/r/sonos/comments/1dyxx6o/the_latest_info_on_fixing_your_completely_gone/

 

Now the bad news: the fixes do not work … at least not for me.

I have an Asus AIMesh for years with some powerful routers interconnected. 

Same Network/Subnet? Check.  Check Wi-Fi Isolation? Check. Multicast/IGMP Settings. Check

Never touched these, they were always enabled. But the whole system is still laggy (with the new app only). The first article mentions the chatty communnication via cloud in order to get your album infos etc. I have a very stable 1GB glasfiber connection ….

But maybe theses fixes can help some of you.

Can´t promote thes links enough, spread the word that there might be a fix.

 

PS: see also 

 

I have an ASUS AI Mesh using three (3) ZenPro WiFi ET12’s with Ethernet backhaul and the Sonos app has not affected it. In fact the Sonos app itself is working for me. I’m 800 miles from my home and accessing my security system, garage openers, cameras, appliances and Alexa smart devices with no problem. You are correct that Sonos is very chatty across one’s network. I wish others realized that as well and stopped saying things like…”my cell phone connects to my WiFi…so why not Sonos? However, I realize most aren’t that network savvy and frankly why should they be. IMO, though the new app is exposing network issues that previously ran under the radar without issue. Hopefully, Sonos can accelerate the fixes.

Reply