Stop The Popup Ads

  • 31 October 2021
  • 1 reply
  • 208 views

This is really frustrating for the investment.  Sonos needs to cease with these popup ads in the controller immediately!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

There’s two places you should double check. 

The first is your account settings on the Sonos website. Sign in, the go to My account, and select profile. Scroll down to Contact Options, and make sure both selections are unchecked. I’m somewhat paranoid, if they’re already unchecked, check them, wait a minute, then uncheck them.

Second, open your controller, and go to settings. Then app preferences, and scroll down to Allow pop up messages. Make sure that is off. Again, paranoia suggests if it’s already off, turn it on, wait a minute, then turn it back off. 

If you’re still getting pop up messages after that, take a screenshot of them, and post them in this forum, so Sonos knows exactly what messages you’re seeing.