Mac OSX Sonos Controller

  • 13 April 2017
  • 3 replies
  • 1350 views

My main user account that I use to log into my Mac does not have administrative privileges. So every time I start the controller I have to enter my admin user name and password for network access.

This is annoying. Is there a way to fix this?

PS This problem is at least 5 years old (persisted thru a number of Controller updates and OSX updates/installations). Happens on my my MacPro and MacBook Pro.

Thanks for your help
Olaf

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Olaf,

Do you have an admin account on those machines? If so, I'd recommend deleting the current install of the Controller, then log in using the admin account, and redownload and install the controller, and reconnect to your Sonos system. Once you've done that, you can log back out of the admin account, and log into your normal account, and (I think) you won't have to enter the admin password again.

Conversely, (and I'm hazier about this solution, I keep admin on my main account and almost never do this) you could do a "get info" on the controller app from the finder, and scroll to the bottom where there's a "Sharing & Permissions" pane. You may have to unlock that with the admin account and password by clicking on that "lock" icon at the bottom right. But once it's unlocked, you could modify user permissions for the app using the plus sign and give it appropriate permissions.

Hope this leads you in at least a correct direction. I expect there are more expert users who will hop on this thread today and point out where I'm wrong, or where I've not fully explained things. And I thank them for doing that, too. Never hurts to learn something new.
Thanks much for your reply.

Deleted the Controller. Downloaded the controller from Sonos via Opera VPN (needed Opera because their web site annoyingly insists on redirecting me to the German Sonos site). Copied the installer to the admin account and logged into the admin account. Temporarily changed the security settings to "Mac App Store and identified developers" to start the Controller once. Logged back into my regular (non admin) account. Temporarily had to turned off the firewall so the Controller could find my Sonos components. Now it works.

Olaf
Delighted to hear that there's one less annoyance 🙂