Answered

iOS Dark Mode disappeared

  • 7 December 2021
  • 36 replies
  • 468 views

Userlevel 5
Badge +13
  • Prodigy III
  • 338 replies

I have had Dark Mode working on my iPhone 13 Pro Max, but yesterday everything just turned light.

 

The option to enable it in the App Settings menu has disappeared. I have restarted the app, deleted and re downloaded but it is still missing.

 

It is still working fine on my M1 iPad Pro.

 

Grrrrr it’s just reappeared when I was going to get a diagnostics report.

 

once again …… grrrrrrrrr 

icon

Best answer by James L. 7 December 2021, 09:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

Badge +17

Hey @BMF,

 

This can happen if your iPhone is unable to connect to one of our servers in time. A diagnostic would let us confirm that, but I’m glad that darkness has returned to your device :slight_smile:

Please do let us know and attempt to grab a diagnostic if this happens again.

Userlevel 5
Badge +13

Hi @James L. 

 

ahh, ok. Thanks, 

 

If I see it again, I will grab a diagnostics report

Userlevel 5
Badge +13

Just happened again….

 

diagnostics 678727555

Badge +17

Just happened again….

 

diagnostics 678727555

Thanks for that.

Looking at the diagnostic, I’m not seeing any specific errors in connecting to the server, but there are some network timeouts when launching the controller.

I’m not quite sure why these are happening, but I did happen to notice you’re running iOS 15.2, which I believe is still in beta. Since we can’t officially support beta software on controllers, it’s entirely possible that there’s something in this version causing this issue.

Do you have any iOS devices running 15.1.1 (current at the time of writing) that are experiencing this problem?

Userlevel 5
Badge +13

Hi @James L. 

 

will check on my wife’s phone as she will be running the latest “official” iOS.

 

Odd thing is, my iPad is on the same version as my iPhone and does not show the same behaviour. 

 

will report back 

Userlevel 5
Badge +13

Hi,

 

now running the latest general release 15.2 (released today)

 

still no sign of Dark Mode on iPhone 13 Pro Max

 

latest diagnostic 395029413

Userlevel 5
Badge +13

Hi @James L. 

 

still getting this issue, on S2 14 and iOS 15.3 (latest)

 

diagnostics 478372309

 

 

Huh. Just opened up my S2 14.0 on both my iPhone 13 running iOS 15.2.1, as well as my iPad Pro (11 inch), which is running iPad OS 15.2.1 , and both are operating in dark mode.

Let me download and install 15.3 and see if I can reproduce this :) 

Which iOS device are you using? 

 

Edit: Is it just the Pro Max that you’re having issues on, or all iOS devices?

Still working on both my devices, after the iOS upgrade, which suggests to me it’s either an issue with Sonos’ identification/programming for the screen size of the Pro Max, or possibly a local setting. I’ll leave you to discuss with the Sonos moderators, and shut up now. 

Userlevel 7

Still working on both my devices, after the iOS upgrade, which suggests to me it’s either an issue with Sonos’ identification/programming for the screen size of the Pro Max, or possibly a local setting. I’ll leave you to discuss with the Sonos moderators, and shut up now. 

I have a 13 Pro Max and dark mode has always been fine within Sonos app since it first launched, even with 15.3 update today.

Works under both system default appearance mode and Dark Mode options in the Sonos app, but that’s no use if the OP doesn’t have the Appearance option visible in the app.

Hi @James L. 

 

still getting this issue, on S2 14 and iOS 15.3 (latest)

 

diagnostics 478372309

 

In an earlier reply, Staff mention the need for the App to be able to connect to one of the Sonos servers. Are there any security Apps on your mobile(s) or firewall on the router etc; blocking connections perhaps? If so maybe see what happens when you switch off those features temporarily and try closing/opening the App fully (once or twice) to see if the feature shows up in the App under ‘Settings/App Preferences’. 

Userlevel 5
Badge +13

It’s really odd, I don’t have a firewall or parental control as such.

 

I do have nextdns that filters trackers… BUT I have tried using Google DNS and cloudfare which do not do any filtering.

 

I could not see anything obvious in the nextdns logs that record the requests that are made…. Which is why I tried Google DNS and cloudfare, but is the same no matter what dns I use.

 

I have tried force closing the app many, many times, reinstalling etc.

 

 

Userlevel 5
Badge +13

Huh. Just opened up my S2 14.0 on both my iPhone 13 running iOS 15.2.1, as well as my iPad Pro (11 inch), which is running iPad OS 15.2.1 , and both are operating in dark mode.

Let me download and install 15.3 and see if I can reproduce this :) 

Which iOS device are you using? 

 

Edit: Is it just the Pro Max that you’re having issues on, or all iOS devices?

iPhone 13 Pro Max and now my iPad Pro 11 inch M1

 

 

Userlevel 7

Well, it looks like I jinxed myself.

An hour ago, the Sonos app on my iPad Pro 2020 (4th gen) just turned light, with no Appearance option available!

My iPhone 13 Pro Max and an iPad Pro 2018 still have Dark Mode enabled on Sonos.

Rebooted router, deleted and reinstalled Sonos app, but unable to return to Dark Mode on iPad Pro 2020.

Not yet got around to rebooting all sonos devices, will try that next.

Diagnostic from affected controller: 720272632

Userlevel 7

Now gone Light on iPhone 13 Pro Max… 😭

Hi, happened to me too. Was working with no issues till today. I am on Android 10. 

Browsing this issue and found this post. Glad i am not the only one. Must be Sonos side.

 

Please SONOS help us out. Ty.

 

Userlevel 5
Badge +13

Anyone using google WiFi?

Userlevel 5
Badge +13

Just checked my wife’s iPhone 11 which is on the same WiFi network and Sonos setup.

 

Userlevel 7
Badge +12

OK on my ipad pro but option for dark mode on my iPhone 13 pro has gone 

Both running 15.3 diagnostic number 912037269

 

Userlevel 4
Badge +1

OK on my ipad pro but option for dark mode on my iPhone 13 pro has gone 

Both running 15.3 diagnostic number 912037269

 

Same here. iPad still has dark mode but both my iPhones have lost Dark mode in the past hour. The option in the app settings has also disappeared on the phones. All running iOS 15.3 and the latest Sonos S2 v14.0

Userlevel 7
Badge +12

Also I am getting a pop up warning about a certificate not trusted from sni.dreamhost.com don't know if it is related 

Userlevel 7
Badge +12

And just as I posted it's back dark mode that is

UPDATE: Dark Mode is now working on my device. Not sure if restarting my phone did the trick, cause i did that earlier, but it is now active and running.

 

Userlevel 7

Anyone using google WiFi?


No, not using google WiFi.

Dark Mode has now returned on my devices.

I restarted an iPhone and iPad for it to reappear, then just force closed the app twice on another iPad, as first time was unsuccessful (although these same attempts were unsuccessful a few hours beforehand)

Hope you have some joy @BMF getting it to work again 🤞🏼

Userlevel 5
Badge +13

still not working here.
 

I reconfigured the entire network as there was a DNS service that blocks some tracking, NextDNS, which I wanted to rule out of the equation, even though it works properly on my wife’s phone.

 

I changed everything to use Cloudfare then Google DNS. Rebooted the entire system in between and still the issue remains.

 

I am just going on give up on it, I lived without Dark Mode in Sonos before and will have to live without it again.

 

just hoped I could get to the bottom of it and see what needed to be fixed for me and others with the same issue

 

only thing I can think of is I have an Enterprise profile for work email installed, that has to stay…. But has not caused any issues with other apps