Question

I have installed Kaspersky Internet Security 2014 on my PC and my Sonos Controller will not find my network any more :-)

  • 7 January 2014
  • 11 replies
  • 2601 views

I have installed Kaspersky Internet Security 2014 on my PC and my Sonos Controller will not find my network any more :-)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Badge +18
We have a guide up here for the Kaspersky 2013 version, the instructions should be more or less similar.
They are not even close.  Kaspersky has changed its UI.  Please update your instructions!!  My problem is my controller wont find my library.  SiriusXM works just fine.
Un-install the Kaspersky and Sonos components completely.  Re-boot, then install the Sonos controller s/w and then install Kaspersky.  That resolved the problem for me on a Windows 7 UI.
I finally figured it out!  I tried uninstalling/reinstalling, tried the TCP and UDP settings in the guide... nothing worked excepts turning off Kaspersky.  Finally I ran across another post here that said to make sure your windows network profile is set to home or local and that it is a trusted network.  Did that... still nothing.  As a last resort, I took a look at the homegroup settings for my network (you can access this by typing in Homegroup into the start menu search box).  I noticed that the Stream Media With Device was not checked so I checked it and then went into the Choose Media Streaming Options.  JACKPOT!!!  All of my Sonos gear was blocked!!!  Changed the setting for each piece of Sonos and away I went.  Black Sabbath came out loud and clear from my PC's music library!!  

On a side note: My system resources were being completely used up after I checked that Stream Media w/ Device option.  Apparently it starts a process linked to WMP11 and is a complete HOG. Just leave this option unchecked but still change the Choose Media Streaming Options to allow each piece of Sonos gear to access the library.  If that does work, go to the Resource Monitor and take note of the process eating 30% or more.  It will be the only one above 5% so you cant miss it.  Do a google search on how to disable this to get your resources back.  Sonos still works perfect!

Stupid Windows, stupid Kaspersky, and stupid Sonos for not updating your guide to the 2014 version of Kaspersky.

GAME ON!!
And now stupid Sonos website...  The above reply was written by me, Brad, the original person with the question.  Why I got a new username of User944101 I'll never know.  Thats cute.
And now stupid Sonos website...  The above reply was written by me, Brad Wenzel.  Why I got a new username of User944101 I'll never know.  Thats cute.
And now stupid Sonos website...  The above reply was written by me.  Why I got a new username of User944101 I'll never know.  Thats cute.
Hi, I have the same problem, but could not yet solve it. I cannot check the Stream Media. It is just gray. I just can't get my Sonos system running with my PC (no problem with my phone). If I shut down KIS it works.

What's to do?
Userlevel 1
For KASPERSKY 2015 users.
Go to Settings - Protection - Firewall - Configure Packet Rules. If Local Services (TCP) is blocked, edit it and change it to allow and apply it. Check if sonos now works. If not, change all the blocked rules into allow, and use logic to find out which of these rules are preventing the functions. If all of these don't work, just disable the firewall option entirely. Hope this helps, worked for me. Try out other versions to confirm.
For KASPERSKY 2015 users.
Go to Settings - Protection - Firewall - Configure Packet Rules. If Local Services (TCP) is blocked, edit it and change it to allow and apply it. Check if sonos now works. If not, change all the blocked rules into allow, and use logic to find out which of these rules are preventing the functions. If all of these don't work, just disable the firewall option entirely. Hope this helps, worked for me. Try out other versions to confirm.


Yes! - the real solution!