I cannot add Rayo to my services

  • 14 December 2023
  • 30 replies
  • 626 views

I’ve tried adding Rayo to my services on Sonos, to replace Planet Radio. I just get the message saying Check your network connection - if that’s ok try later (paraphrased). My network connection is fine and I can add other services.

I have checked my location is Uk in my account. Also did the thing where you choose another country check for updates, change back, check for updates again, restarted, everything.


30 replies

Might be best to call Sonos Support at this time. 

There’s another thread on here where someone suggested changing your profile country in the online Sonos website then changing it back.

I tried it and it worked.

You have to set up an address the Sonos profile will recognise, I had one I could use but if you delete any existing address information, then select a country and star typing in the first address field it will offer a few suggestions. Select one then save the update.

Close and reopen the Sonos app.

Back to your account profile and set it back to your own address.

Restart the app and it should now allow you to add the Rayo service.

I found I had to leave at least 30 seconds between changing my address and restarting the app to pick up the address change.

Badge +20

There’s another thread on here where someone suggested changing your profile country in the online Sonos website then changing it back.

I tried it and it worked.

You have to set up an address the Sonos profile will recognise, I had one I could use but if you delete any existing address information, then select a country and star typing in the first address field it will offer a few suggestions. Select one then save the update.

Close and reopen the Sonos app.

Back to your account profile and set it back to your own address.

Restart the app and it should now allow you to add the Rayo service.

I found I had to leave at least 30 seconds between changing my address and restarting the app to pick up the address change.

Also in the Sonos App…Settings…System…System Updates…Check for Updates.

this step refreshes the services available list.

Done all that - carefully and given plenty of time between steps - still does not work. Rayo dissappears from the services list when I have a US address set, reappears when I have my home address back in.

Badge +20

Done all that - carefully and given plenty of time between steps - still does not work. Rayo dissappears from the services list when I have a US address set, reappears when I have my home address back in.

Thought Rayo was a UK / European service?

Thought Rayo was a UK / European service?

I am in the UK - just set a US address as part of the process described above and demonstrating that Sonos ‘knew’ I was located there, and then that I was back in the UK!

Surely this is exactly the sort of tech jiggery-pokery that the Sonos ecosystem is meant to keep us well clear of?

Badge +20

Any

Thought Rayo was a UK / European service?

I am in the UK - just set a US address as part of the process described above and demonstrating that Sonos ‘knew’ I was located there, and then that I was back in the UK!

Surely this is exactly the sort of tech jiggery-pokery that the Sonos ecosystem is meant to keep us well clear of?

ah! Sorry…anything odd / advanced Router wise such as VPNs or DNS servers set outside the UK?

Badge +20

I decide to remove Rayo and add it again but created a new account using  a trash mail account, both existing and “new” account worked without issue.

Hi - no,no weird settings at all and i can add other services without any problem, including BBC Sounds which I can listen to live.

Badge +20

You will have to ring Sonos as I am out of ideas.

Same issue here. Anyone found a solution yet?

Userlevel 1
Badge

Total frustration setting in here.  Thanks for all the advice above.

Now spent at least 2 hours on Sonos and Greatest Hits Radio support calls. Both blaming the other for the problem.

CANNOT add the Rayo service - misleading message to check my internet connection (which is perfect, thanks).  Massive time-wasting rebooting everything multiple times, uninstalling etc.

All I qwant to do is listen to the bloody radio station that I pay a premoum service for (Greatest Hits Radio) on my cost-a-fortune sonos system. Why is this to difficult?????

JUST SORT IT. SONOS before I scrap the entire system.

If it were a Sonos issue, wouldn’t it be affecting all services, not just Rayo?

Userlevel 1
Badge

You might think that,

Airgetlam
 

 

But Rayo are saying they have discussed with Sonos and that the problem is at their (sonos) end. To be honest, as an end user, we shouldn’t have to worry about whose problem it is...

Interesting. I’d assume that you’ve submitted a diagnostic, and called Sonos, so they have your hard data to look at?

I’m afraid I’ve seen previous cases where a CS group pointed a finger incorrectly, but we’ll have to see.
 

Hopefully, it will be resolved soon, no matter whose engineers have to fix it. 

still same issue here!

Userlevel 1
Badge

Yes indeed.  I spent an hour on the phone with the Sonos team - to be fair, they were very helpful, although tbh went through all the usual tedium of having to power everyhting off / reboot etc - all to no avail. Submitted diagnostics too. Interestingly, the girl I spoke to also tried to add the service on their helpdesk system and it failed with the same error - so they are able to reproduce the problem - which should mean they can trace it???

Finally they said that the problem must be at the provider’s end. So I then went through all of the same talking to their helpdesk. At the end of that, they gave me a voucher for loss of a month of the premium servivce, which I pay monthly to avoid the ad’s. Then said the problem must be with Sonos….

So round & round it goes! 

Userlevel 4
Badge +4

Just a thought… you are located on the Isle of Man according to your profile right? Isle of Man is not listed under Availability here: https://support.sonos.com/en-us/services/rayo while it is specifically listed for TuneIn for example. Could it be geoblocking? If I set my account to UK and want to add Rayo I get the same error message, but I’m not located in the UK so hence my suspicion it might be geoblocking. 

Userlevel 1
Badge

Hi Outburst. I did think of that. But it wasn’t a problem when I was using Planet Radio to access Greatest Hits Radio, - i.e. before they switched to Rayo.

This reply from GHR seems to confirm that the problem is at Sonos’ end:

>>>>

“ Hi Graham,
 
I'm so sorry about this, I can understand your frustration and this isn't ideal. 
 
The Sonos team have been informed that this is an issue on their end and should be able to provide you with further support.
 
I've applied an extra free month due to this inconvenience.
 
Again, I'm sorry for not being able to support you further with this.
 
All the best,
<<«

Also - I see from this thread (and googl-ing) that “normal” UK-resident Sonos users are having the same problem.

 

Userlevel 4
Badge +4

So I noticed my VPN provider that I use every now and then has an endpoint on the Isle of Man and I did a quick test. I am based in the Netherlands, so adding Rayo without any VPN will fail with the exact same error message. Adding Rayo with a VPN in the UK works fine and adding Rayo with a VPN set to Isle of Man will again fail with the very same error message. I really think this is a geo blocking issue. If you have access to a VPN, I would suggest trying to add Rayo with a UK endpoint.

Userlevel 1
Badge

Thanks, Outburst. If I can get my head around setting up VPN, I will give this a try. However, there are still plenty of UK residents complaining of the same issue, so I really think that, between them, Sonos & Rayo need to get themselves sorted, rather than expecting paying customers to jump through hoops to access it! Especially when this affects pre-existing subscribers.  Anyway, I have passed your suggestion onto Rayo support and await with interest.

This is definitely a Sonos AND Rayo/Bauer problem, not the customer’s!

Userlevel 4
Badge +4

Yeah not saying it is (or should be) a customer’s problem but I also don’t see where it is a Sonos issue. Rayo seems to have messed up their geo blocking and need to fix it and also provide a better error message. 

Userlevel 1
Badge

Hi Outburst…. Following your advice, I remembered that my McAfee Total Protection package offers a built-in VPN, so i had a play with it one morning - and selected the UK option for my location. And Lo… Suddenly I was able to add the Rayo service and select the radio stations from it.

So - thank you for the tip and, for now, I am once again able to enjoy my subscription.

However, as pointed out by myself and others on this forum, it really needs to be sorted by Rayo.  So I will pen a note to Krisha on the GHR support team, who was trying to help me, in the hope that this evidence will cause them to get it fixed.

I still cannot use Rayo on Sonos. I don't understand VPN so not sure what to do?

 

 

Reply