Answered

Can't login to app even though I know password is correct and have reset multiple times



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

46 replies

Any solution to this yet? Same problem here. (Logging in desktop app works though, only the mobile controler do not work)

Any solution to this yet? Same problem here. (Logging in desktop app works though, only the mobile controler do not work)

Yes it’s fixed, I’ve just tried it a few moments ago and it logged in first time - no issues.

I’ve tried both iOS and Android devices and each are working okay.

If it’s still not working for you, then I suggest perhaps contacting Sonos Support via this LINK.

Hey everyone, I just figured this issue out. When you log into your app account, it's gonna have some weird email like s******@gmail.com or whatever. If you see this, you need to transfer your system to your email. There is an option to do it under the settings. After you do that, it should allow you to use your email account t to login regardless of using the correct password and getting the "incorrect password" issue. 

Update, after getting the system ownership transferred to your email, I closed the app, and opened it back up. I was able to connect up to the point where it asks me for my wifi, it detected every wifi in my neighborhood except for mine..............................................................…

Patience is a virtue

Okay, final update. Got it working!!!! After I did the above things I mentioned, and it still doesn't work for you, go ahead and do a factory reset and the rest should be good to go. If it does not work, I guess you can throw the product out the window because this has taken me about 3 hours to figure out. 

Hey everyone, I just figured this issue out. When you log into your app account, it's gonna have some weird email like s******@gmail.com or whatever. If you see this, you need to transfer your system to your email. There is an option to do it under the settings. After you do that, it should allow you to use your email account t to login regardless of using the correct password and getting the "incorrect password" issue. 


This absolutely works. Thank you for figuring it out. That was a ridiculous situation we were in. I updated my password a dozen times before I came across your post. 

@BeeO 

I have the same problem, I cannot log in, and it's not possible to send a reset password to my mail. 

How am I supposed to get to the settings to transfer the system to my email when I cant do anything in the app?

/Emma

 

@BeeO

I have the same problem, I cannot log in, and it's not possible to send a reset password to my mail. 

How am I supposed to get to the settings to transfer the system to my email when I cant do anything in the app?

/Emma

 


If your system and the app are all connected to the same Wi-Fi you don’t need to be logged in to transfer it. Open the  app, go to system - scroll to the bottom to Transfer System Ownership and begin the process. Since you’re logged into write your question it should be the same log information that you transfer it to. Good luck!

So when you reinstalled the app, and selected ‘connect to existing system’, does it do so?  If not, what error message do you get?  Only certain Settings are ‘behind’ a login so what happens if you tap Settings?

What version of Android are you running?

I have always had this issue with Sonos. Never able to login to the app over a 5 year period but can online. Sonos is garbage. 

So i have just got a sonos SL speaker for Christmas today and i am having the same issue i can login through the browser site but not through the app, the speaker is usless with out the app working. I have read the comments on this thread and the comments are from a year ago, and this issue clearly has not been solved a year later, whats the point of selling sonos speakers if the app is usless. 

So i am also unable to login to the App. It used to work just perfectly fine and somehow i am logged off, can't login with the credentials I use here and on the login page it suggests an email i have no idea of. Reinstalled and nothing happens. When i start the app it briefly shows im logged in with my mail and then shows sign in straight away. It is so confusing, because it is not working on my phone, tablet and laptop….. chat support is nowhere to be found….

I suggest that you contact support.

I suggest that you contact support.

I suggest  you read my message. There are never agents online to chat and the bot does not give any solution.

I suggest that you contact support.

I suggest  you read my message. There are never agents online to chat and the bot does not give any solution.

Maybe try transferring your system over to the Sonos account/credentials that you know are correct - see this support link:

https://support.sonos.com/en-us/article/transfer-your-sonos-system-to-a-new-account

There isn’t one as i can’t login to the app. But when I try to login I use the same email as the web version i’m currently logged in to…

 

I have the exact same problem , sent diagnostics to CS and they told me it would be resolved in 30 mins and it is not 

Any solution to this yet? Same problem here. (Logging in desktop app works though, only the mobile controler do not work)

I have the same issue 

Userlevel 7
Badge +17

Who is CS?

Generally short for “Customer Service”, aka Sonos support, I’d think. But I’ve never heard of support saying anything would be “fixed in 30 minutes”, either. 

Userlevel 2
Badge +1

Any solutions?

 

Same error here, cannot add new device, login in app fails, password is correct, tried different android versions.

 

Edit: Was able to login this way:

 

App → Settings → System → Transfer System Ownership → I can’t access this account

 

After that, login worked and I can manage/add devices.

 

Strange Software Path to add a new device 🙃 

Any solutions?

 

Same error here, cannot add new device, login in app fails, password is correct, tried different android versions.

 

Edit: Was able to login this way:

 

App → Settings → System → Transfer System Ownership → I can’t access this account

 

After that, login worked and I can manage/add devices.

 

Strange Software Path to add a new device 🙃 

It sounds like you simply transferred the system over to the account credentials that you were of, that’s all.
You should not need to do that the next time you add a new, or reset, Sonos product to your system. 

Userlevel 2
Badge +1

No, it was the same Account. 

 

Just the login Procedure is different, email and password in steps.

 

Think they are working on new Version anyway.