Answered

Turntable to pre-amp to Sonos Amp Help

  • 22 January 2023
  • 7 replies
  • 54 views

Hello! 
I’m trying to connect Pro-ject Essential 3 turntable to a Pro-ject Phono Box S2 pre-amp to the Sonos Amp. I get the vinyl to play for about 5-10 seconds (sound is great) and then the sound cuts out and no sound continues. 
 

Any recommendations or suggestions?

icon

Best answer by buzz 22 January 2023, 05:53

View original

7 replies

Describe your SONOS system for us. What is wired? Wireless?

What do you do to get the sound back? Are you Grouping speakers or playing only through the AMP where the turntable is connected? Are any error messages displayed?

So far I was just trying to use the Sonos Amp to connect to wired, unpowered speakers. I’d like to be able to use the turntable and play vinyl through out my house but also use the speakers with streaming music through Sonos. 
 

Currently, I can play streaming music thru the Amp to the unpowered speakers and it works just fine. 

Userlevel 7

Under the Line-In settings for the Amp, try setting the Audio Delay setting to High or Max. You can also try setting the Audio Compression setting in the Sonos app to Compressed.

How do you get the turntable to play again after it mutes?

To get the turntable to play again I turn the turntable and pre-amp off and back on again. 
 

I also tried the line-in settings in the Sonos app. Tried all 1-10 levels. Not sure it made a huge difference but level 10 is usually what I use. 
 

I haven’t tried the compressed audio setting but I figured with the turntable and speakers being wired, the compressed settings wouldn’t make a difference. 

I haven’t tried the compressed audio setting but I figured with the turntable and speakers being wired, the compressed settings wouldn’t make a difference. 

This is correct if you are playing on the unit where the turntable is attached. If you are playing on another unit(s) there could be a communication issue and compression might help.

Are you using “Autoplay”? If so, as a test, disable Autoplay for the turntable.

Hey! Turning off Autoplay worked! Or at least I think that was the final reason. Was able to play an entire side of an album with no issues. 
 

thanks everyone!!

Reply