Sonos connect streaming to HIFI from phone

  • 11 November 2022
  • 11 replies
  • 90 views

I have a Sonos connect wired to my purely analog amplifier (connected to 2 floorstanding speakers through cable).

I’m trying to stream Spotify music to the amplifier from my iPhone XS (so that I use the Sonos DAC) but the sound is chopping up (1-2 sec drops every minute or 2). So, no wireless speakers or anything,

Sonos connect is on channel 6, router is on 11. I can stream perfectly from the iPhone to wireless homepod speakers so the wifi is not the problem probably. Not sure what is.


11 replies

I need to add that if I stream to Sonos via the Spotify app on the phone I get the results above. If I use the Sonos S1 app that has Spotify integrated the results are 10 times worse (drops every few seconds) but the sound is clearer (for some reason although there is no EQ on either app enabled).

Do you have any other Sonos devices?  Which Sonos device is wired to your router?

Are there any extenders, mesh.systems etc?

Do you have any other Sonos devices?  Which Sonos device is wired to your router?

Are there any extenders, mesh.systems etc?

No nothing. Very simple setup. No other Sonos devices/ no mesh/ no extenders. Only Connect which is not wired to the router, but connected through wifi. So the house set up is like this:

ISP router (wifi shut down) → Apple airport extreme (handles the wifi) (2,4GHz, 20Mhz, channel 11 & 5Ghz channel 100)

Sonos connect (wifi channel 6) → A.V. In Stereo amp→ 2 Speakers.
Turntable, CD player → Stereo Amp

1 Apple homepod in the kitchen (unrelated to the Sonos).

I am puzzled by what you meant when you said that the Connect is on channel 6?  If nothing is wired then SonosNet is not operating  and the Connect is on the same channel as everything else on your WiFi. It would be worth trying different channels on your router (1,6).

Do you have any other wireless systems like Hue lighting or baby monitors?

Are you playing from the Spotify app or through the Sonos app?

Is the Connect near any possible sources of interference, such as large electrical items?

Which device is acting as DHCP server?  The router or AE?

But as I say, the thing that most puzzles me is how the Connect can be on channel 6 when the router wifi is turned off and the AE is on channel 11.

I can stream perfectly from the iPhone to wireless homepod speakers so the wifi is not the problem probably. Not sure what is.

But are you using Airplay for that?

Sorry John I forgot to mention that the channel on the Sonos Connect was greyed out in my current setup and was locked at 1. I put an ethernet cable momentarily to change it to 6 and now its greyed out again at 6. I realize this pays no role since I don’t have Sonos speakers on a Sonos network. So its irrelevant. Makes sense now. I jus saw that on another thread as a possible problem and tried it out.

The airport extreme is on DHCP NAT mode. The ISP router has disable most of the features (wifi, DHCP etc.)

I can stream to the Sonos connect by either the Spotify app or the Sonos S1 app. Directly from the Spotify app I have drop outs every 2-3 minutes. From the Sonos app every 10-20 secs.

No other networks in the house. Just some smart devices that connect to the internet (AC unit, robot vacuum cleaner).

 

Thanks for the help.

Could you put that Ethernet connection back in (to the AE) please, give it a couple of minutes then check in About My System that the Connect has WM=0 not WM=1.

Then see if the dropouts still occur.  This is just an experiment.

I will try it! Now its WM1. I will need to find a long enough ethernet cable since the connect is close to the receiver but the AE is 6-7 meters away (same room). Before I just unplugged it from the receiver to take it close to the AE and change the channel. 

Something else i noticed is that when I’m in the S1 app every time my phone wakes up there’s a drop and whenever I choose a menu (e.g. settings etc) and play around there’re drops also.

So, an update that probably complicates things:

I realized that whenever there are drops, the sound doesn’t cut out completely. So, if I stick my ear to the speaker every time I invoke the app (spotify or S1 e.g. wake up phone, change an option, the volume etc), the sounds drops but the song continues to play and can be heard at 1/100 volume. You can only hear it if you really stick your ear to the speakers.

So its probably a software or hardware problem on the Sonos side. It’s not about the internet, the network or the cable. Why would it drop the volume almost entirely every now and then? That’s the questions. Volume is dropped typically in the beginning of each song (at least two times, then every now and then, and every time the app in used in some way.

If that’s the case, then I’d highly recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

If there’s an issue inside the electronics of the device, there’s not much we on this community board can do to help.

I understand. Thanks for the tip. I just submitted a diagnostic. It’s number 1079766602.

I thought it could be hardware related (some capacitor dying) but, as we speak, Spotify streaming to Sonos causes drops every 10 sec but streaming from the Sonos S1 app causes drops every 1 minute or so. Also when I was submitting the diagnostic, the drop lasted as long as the process lasted.

So it must be software related.

Reply