Question

S2 intermittently drops speakers (wired and wireless)

  • 9 November 2020
  • 1 reply
  • 127 views

There are many topics here on S2 intermittently having issues but many of them are specific to issues like Spotify.  I am noticing that after upgrading to S2 successfully (including getting rid of incompatible Sonos devices and purchasing a new one to ensure compatibility!), that several of my speakers will drop out of the network frequently -- often daily.   I use the main controller app on iOS, OS X, and I do use Spotify and IDagio to drive the speakers.  

My internal Wifi network is comprised of enterprise-grade networking gear -- current generation Ubiquiti UniFi gear.  As with several other commenters in the forums, I’m a network engineer by background and this is NOT an issue with the stability of the underlying network.  

But, to eliminate that possibility, I put one of the speakers on wired ethernet.  The problem persists.  I have a group consisting of a Play:3 and Play:1 in my office, and a Play:3 in the bedroom next door -- and a separate group consisting of a Play:5, Playbar, and a Move downstairs, again within 10 feet of the wifi AP in an open plan room with no walls to obstruct signal.  

The office/bedroom set drops off the network nearly daily.  Sometimes the whole group will simply be missing from my controller apps.  Sometimes one or two of the speakers will be gone, but the third will still show.  The suggestions in the forums -- to reboot APs, reassociate speakers with the controller, are not helpful.  That’s acceptable as a solution for a rare networking failure -- and should not be a DAILY task to use your product.
 

I have owned Sonos products for many years, and they have generally been trouble-free.  The S2 upgrade has been a step down in stability.  So far in the forums I see no acknowledgment by Sonos that there is an issue -- but just look at how many people are reporting issues.  Please let your loyal customers know that you hear that there is a stability issue with your controller maintaining a connection to speakers, and. that you will issue a fix.  Please!

I just submitted diagnostics as well.  Thanks!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @mmadsensji, thank you for reaching out to us, and welcome to the Sonos community. I appreciate your detailed post describing the issue as well as the steps that you did. I’d be happy to help you out here and it would be best if you can submit a diagnostic report of your system for better understanding and see what would be best for the setup. Reply to us with the confirmation number. We and the community are always here to help.