Answered

New Asus RT-AX82U/AX5400 Router Sonos System Not Showing Any Recommendations?

  • 5 December 2020
  • 72 replies
  • 5805 views


Show first post

72 replies

hi all, thank you all who contributed constructively here. I too have a Asus router AX88U and had dropped connections with my beam + sub + 2 SL Ones. it happens whenever i turn on my guest network. Even after i deactivate the guest network, the sonos will go missing. Never understood why. I tried all the solutions suggested here excluding rolling back the firmware. Nothing has really worked. But i tried to update my firmware to 

Version 3.0.0.4.386.42819

2021/04/29 

after the firmware update, i did a factory restore of my router.

I also deleted all my sonos speakers and re add them. 

So far so good. I have not tried turning on the guest network as i am tired of all these troubleshooting and my family have been complaining that i keep bringing down the internet/speakers to troubleshoot. haha. FINGERS crossed!

I have a RT-AX82U and just got a Beam. Have the same problem with  the current latest Firmware Version:3.0.0.4.386_41700. Anyone find an Asus support post about this? Does someone at Sonos know what these routers could be blocking or at least confirm there is a ticket open with them? 

BTW Sonos team, https://support.sonos.com/s/article/41?language=en_US needs an update to reflect this clear incompatibility. 

p.s. holding onto the Beam and have it connected to my ISP’s cheap DLS ZTE wifi router for now… but for security reasons, not all the family gets access.

Userlevel 7
Badge +18

Hi @belgiumcookieman 

BTW Sonos team, https://support.sonos.com/s/article/41?language=en_US needs an update to reflect this clear incompatibility. 

 

Thanks for pointing that out - I’ll ask for the page to be updated.

thanks everyone for your awesome help in this thread. . couple of months ago I got the RT - AX58U and updated the firmware to the latest available one. I had the same issues with my Sonos soundbar. . I rolled back to the firmware provided in this thread and they were working again.

 

Yesterday I tried the latest firmware 3.0.0.4.386_42095 and did a complete reset after update (administration - > Restore / Save / Upload Setting ->Factory Reset ) . so far all my Sonos products are working and I don't have any connection issues.

 

Hope this information helps.

Hi @belgiumcookieman 

BTW Sonos team, https://support.sonos.com/s/article/41?language=en_US needs an update to reflect this clear incompatibility. 

 

Thanks for pointing that out - I’ll ask for the page to be updated.

To clarify, are you updating the doc because Sonos will not be able to work with Asus to fix the problem or is it a temporary placeholder? I would really appreciate it if Sonos were seeking a solution with ASUS and I would be also pleased to know that ASUS are making progress. Is there interest and resources to fix this issue?

Userlevel 7
Badge +18

Hi @belgiumcookieman 

Hi @belgiumcookieman 

BTW Sonos team, https://support.sonos.com/s/article/41?language=en_US needs an update to reflect this clear incompatibility. 

 

Thanks for pointing that out - I’ll ask for the page to be updated.

To clarify, are you updating the doc because Sonos will not be able to work with Asus to fix the problem or is it a temporary placeholder? I would really appreciate it if Sonos were seeking a solution with ASUS and I would be also pleased to know that ASUS are making progress. Is there interest and resources to fix this issue?

Lower down on that same page is a page specific to Asus RT series routers - I don’t know if you saw it. It still needs updating to include the factory reset. https://support.sonos.com/s/article/3668

Although that page doesn’t refer to the factory reset needed after a firmware update, I have seen internal documentation referring to it. I assume we’ve already been in touch with Asus regarding the issue, but I don’t have anything further to share. As there’s a reasonably simple workaround, it isn’t a priority for us (and there’s nothing we could do about it if it was). The only thing likely to hurry Asus (much like any other company) up on the matter would be increased contact volume from their customers.

Hi @belgiumcookieman 

Hi @belgiumcookieman 

BTW Sonos team, https://support.sonos.com/s/article/41?language=en_US needs an update to reflect this clear incompatibility. 

 

Thanks for pointing that out - I’ll ask for the page to be updated.

To clarify, are you updating the doc because Sonos will not be able to work with Asus to fix the problem or is it a temporary placeholder? I would really appreciate it if Sonos were seeking a solution with ASUS and I would be also pleased to know that ASUS are making progress. Is there interest and resources to fix this issue?

Lower down on that same page is a page specific to Asus RT series routers - I don’t know if you saw it. It still needs updating to include the factory reset. https://support.sonos.com/s/article/3668

Although that page doesn’t refer to the factory reset needed after a firmware update, I have seen internal documentation referring to it. I assume we’ve already been in touch with Asus regarding the issue, but I don’t have anything further to share. As there’s a reasonably simple workaround, it isn’t a priority for us (and there’s nothing we could do about it if it was). The only thing likely to hurry Asus (much like any other company) up on the matter would be increased contact volume from their customers.

Not sure what the workaround it. If you are referring to ‘Disable Airtime Fairness for both 2.4 and 5GHz bands’? As mentioned above and on other posts, this workaround is not working. Right now the only workaround which others report as successful is to rollback the ASUS firmware to Version 3.0.0.4.384.9948. That is not a simple of good workaround as not keeping a router firmware up to date increases security risks.

Userlevel 7
Badge +18

Hi @belgiumcookieman 

Not sure what the workaround it. If you are referring to ‘Disable Airtime Fairness for both 2.4 and 5GHz bands’? As mentioned above and on other posts, this workaround is not working. Right now the only workaround which others report as successful is to rollback the ASUS firmware to Version 3.0.0.4.384.9948. That is not a simple of good workaround as not keeping a router firmware up to date increases security risks.

 

We tend to keep known issues very specific, so the Airtime Fairness issue is considered separate from the issue where Asus RT series routers need reset after updating their firmware, and they have different workarounds. They do both belong on that page you referenced, however.

I wasn’t aware (other than in this thread) of any need to downgrade the router’s firmware - only to reset the router after an update. This is similar to when you clear CMOS/BIOS settings on a PC motherboard after updating it’s firmware to avoid any conflicting settings across versions.

According to the details we’ve gathered, “customers were able to resolve [the issue] by Factory Resetting the respective router after updating the firmware [to] 3.0.0.4.386_41700”.

I hope this helps.

Hi @belgiumcookieman 

Not sure what the workaround it. If you are referring to ‘Disable Airtime Fairness for both 2.4 and 5GHz bands’? As mentioned above and on other posts, this workaround is not working. Right now the only workaround which others report as successful is to rollback the ASUS firmware to Version 3.0.0.4.384.9948. That is not a simple of good workaround as not keeping a router firmware up to date increases security risks.

 

We tend to keep known issues very specific, so the Airtime Fairness issue is considered separate from the issue where Asus RT series routers need reset after updating their firmware, and they have different workarounds. They do both belong on that page you referenced, however.

I wasn’t aware (other than in this thread) of any need to downgrade the router’s firmware - only to reset the router after an update. This is similar to when you clear CMOS/BIOS settings on a PC motherboard after updating it’s firmware to avoid any conflicting settings across versions.

According to the details we’ve gathered, “customers were able to resolve [the issue] by Factory Resetting the respective router after updating the firmware [to] 3.0.0.4.386_41700”.

I hope this helps.

That page isn’t correct though, not fully anyway. Because it says there is an issue with RT series ASUS routers that is fixed by switching off Airtime Fairness, which this thread is evidence of not being correct. Maybe changing the wording to it being a “potential” fix would be accurate, I’m sure it fixes some issues on some RT routers. Outside of that, the only fix in here that works for everyone so far is downgrading to older firmware. I received my router with the newest update on and it still didn’t work. Hopefully this can be fixed somehow.

No update yet on my RT-AX82U, last one was Feb and still has the issue! Downgrading to November update fixes the issue.

I have contacted ASUS support as of today, will see what they say.

Userlevel 7
Badge +18

Hi @Habylab 

Thanks for sharing your experience - that’s very interesting.

Just wanted to say that I updated via the router interface ‘button’ to BIOS Version 3.0.0.4.386.43129 (2021/05/14), then performed a factory reset, re-entered the same SSID and password details and so far (an hour in) everything is running smoothly. For those that were holding back on the November release this might be a chance to patch up and see if it works for you too.

I think the latest Sonos update fixed the issue. I upgraded my firmware on my router and didn't realise it went to a Feb update, not the latest, and Sonos still worked for a day. Now on latest RR-AX82U update and all okay.

Firmware updated on my Asus AX5400 to the May update (few days ago) and I was still having same issues.  Even after a factory reset.

I managed to get the Sonos to update to the latest version and everything is working ok now!

It was nice while it lasted.  Back to the 701 errors :dizzy_face:

Userlevel 1

So I tried the new firmware version and did a factory reset after the firmware update but still have the same old connection issues.

Rolled back from new Version 3.0.0.4.386.43129 - 2021/05/14

to the old

Version 3.0.0.4.384.9948 - 2020/11/03 

and all is well again.  I sure wish Asus and SONOS could get on the same page.

All the suggestions didnt work for me using the latest Asus firmware 386.2_6 .

What did work, as soon as I set the setting, was to change the Wireless Mode in 2.4Ghz to “Legacy”

 

 

Chiming in here as I bought my RT-AX82U yesterday and immediately had connectivity issues with my Sonos system (Beam, 2xPlay:1 and Sonos One) on latest firmware. Rolled back to the 3.0.0.4.384.9948 after finding this thread and looking good now so far.

So is the firmware rollback the general ‘fix’ so far or is factory resetting (and assuming restoring settings from backup) the way to go with keeping up to date? There does seem to be a number of security vulnerabilities patched between Nov 20 and May 21 so I’d really prefer not to be set adrift firmware wise.

Thanks.

Steve

Badge +17

Chiming in here as I bought my RT-AX82U yesterday and immediately had connectivity issues with my Sonos system (Beam, 2xPlay:1 and Sonos One) on latest firmware. Rolled back to the 3.0.0.4.384.9948 after finding this thread and looking good now so far.

So is the firmware rollback the general ‘fix’ so far or is factory resetting (and assuming restoring settings from backup) the way to go with keeping up to date? There does seem to be a number of security vulnerabilities patched between Nov 20 and May 21 so I’d really prefer not to be set adrift firmware wise.

Thanks.

Steve

Asus recommend updating to the latest version, and then performing a factory reset. This should let you stay up to date with security patches as well as avoiding any connection issues documented here :slight_smile:

Thanks James. I did this today - updated to latest version and then forced a factory reset (twice actually!). Afterwards my Sonos system was reachable briefly and then speakers started dropping out from the Sonos app - particularly the Play:1s.  Also noticing a 10-12 second delay when starting a song from Spotify.

Rolled back to 3.0.0.4.384.9948 (even without a factory reset after) and everything is fine.

I spent a couple hours with some birthday Ikea Symfonisks and an Asus XT mesh getting nowhere. Airtime fairness is disabled by default so that wasn’t an option. I wasn’t keen on doing a factory reset as the rest of the family was obviously awake and not keen to have the network down for an hour while I rebuilt the mesh.

In the end I found the best bet was to make one of the bookshelf speakers plug in via ethernet to a satellite Asus XT8 unit and become the master. It then sets up it’s own Sonos wifi network. After that all the other speakers join that special wifi network (and then connect to the internet via the master speakers ethernet). The downside is that all your speakers have to be within range of that speaker’s wifi to do the join. Good enough for a single room setup - I have Ikea 2 bookshelfs and a Ika lamp from the Symonfisk range hooked up - they can be airplayed from the main wifi network eg reachable from Apple TV, iphones etc.

I’ll try the factory reset maybe another time.

No joy with upgrades+factory reset. On the latest firmware my Sonos system is all over the place.  As soon as I roll back everything is fine.

Is this even going to be looked at by Sonos and/or Asus?

Userlevel 7
Badge +22

No joy with upgrades+factory reset. On the latest firmware my Sonos system is all over the place.  As soon as I roll back everything is fine.

Is this even going to be looked at by Sonos and/or Asus?


It is clear that ASUS don’t care at all (and it is 100% their problem to fix). Get a different router, I personally recommend AmpliFi.

Just to add regarding sugestions of turning off QoS and Wifi fairness.

Wifi fairness was disabled for both 2.4Ghz and 5Ghz by default.

I initially logged into my RT-AX82U (latest firmware: 3.0.0.4.386_43588) using the (iOS) mobile app. When I searched for Qos it showed a setting and I marked both bands as disabled. Still couldn’t use / register my Sonos Play 1’s.

I’ve since logged into the router from my PC and when you go to router.asus.com there is an menu items for Adaptive QoS as below. This was still turned on. I have now turned it off as below & have successfully added my first speaker back to a new system (having reset the iOS Sonos app). Worth checking both settings or, ultimately, don’t trust the Asus mobile app! 

 

 

In update to my comments a few months ago, Firmware Version:3.0.0.4.386_43129 is working fine for me on my RT-AX82U even with QoS enabled and without having to split the 2.4 & 5 Gh networks

I see that there is a new firmware version 3.0.0.4.386.43588 available.  Has anybody had any joy with this one or are we still stuck in November 2020?

 

Reply