Question

Netgear GS724Tv4 - Data Storms

  • 17 October 2020
  • 21 replies
  • 444 views

Badge

My home network uses a Netgear GS724Tv4 managed switch.

My Sonos gear comprises:

  1. Connect: Bedroom, Series ID: C100, WM: 0. OTP: 1.1.1(1-17-5-zp90-2.1)
  2. Play:3: Kitchen, Series ID: A100, WM: 0, OTP: 
  3. Beam: Sitting Room, Series ID: A100, Audio In: , WM: 0
  4. Play:1: Sitting Room (RS), Series ID: A200, WM: 0
  5. Play:1: Sitting Room (LS), Series ID: A101, WM: 0, OTP: 
  6. Sub: Sitting Room, Series ID: A101, WM: 0, OTP: 

This all works beautifully. But in my garden shed (connected via a 50m ethernet cable to the managed switch) I also have 2 Sonos 5’s (wired daisy chain).

I seem to be suffering data storms as the 5’s keep disappearing. 

My key Managed Switch settings are:

  • Spanning Tree State: Enable
  • STP Operation Mode; STP
  • Forward BPDU while STP disable: Enable
  • Bridge Priority: 0
  • Bridge Max Age (secs): 20
  • Bridge Hello Time (secs): 2
  • Bridge Forward Delay (secs): 15
  • Spanning Tree Maximum Hops: 20
  • CST Port Configuration (All ports) : STP Status : Enable, Fast Link: Disable, BPDU Forwarding: Enable, Path Cost :10,  External Port Path Cost: 10

 

Any help HUGELY appreciated please. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

21 replies

What other Sonos units are wired to the switch? 

You talk of “2 Sonos 5’s (wired daisy chain)”. The only 5/Five which has dual ports is the old Play:5/gen1. Is this what you mean?

Badge

Hi Ratty,  yes 2 gen 1 Sonos 5’s

What Sonos devices are wired to the switch in the house?

Badge

Ok so I’m the house the Three , Beam and Connect are wired.  Only the Ones are not..

With multiple devices already wired through the switch I doubt you have a conventional broadcast storm. I assume it’s a plain Ethernet cable straight between the switch and the first P:5. Hopefully you’ve checked that the cable itself isn’t faulty?

Badge

Indeed it’s a brand new cable and in fact I actually laid no less than 4 cables and I get the same issue with them all.  The fives work perfectly when In the house.   The way they keep disappearing from the controller app on both phone and Mac is so odd, and that only

occurs when actually playing music.

 

I have also connected a TP-link wire less access point daisy chained off the last Five in the shed which is providing a good WIFI service according to my phone (and of course allows the Sonos phone app to work. 

It’s possible that one of the Play:5s is connecting to the house wirelessly and the cable is being ignored.

Go to http://x.x.x.x:1400/support/review, substituting the IP of one of the wired house players, e.g. the Beam.

Click on Network Matrix and locate the rows representing each of the shed Play:5s. They should contain grey cells, except for the left column. If not, we’ll have to do some more digging.

Badge

Annoyingly the 2nd Five (called “Gym”) is not always visible.  The other one called “Defect” is showing as grey although on saying that I notice one of  the columns calls itself ‘undefined’?

Looks to me (from my router’s device table) like the Fives are:

“Defect”: 00:0E:58:59:C6:CE 192.168.8.167

“Gym”: B8:E9:37:2F:FE:02 1192.168.8.163

 

The “undefined” columns are (a) “Gym”, which has gone AWOL, and (b) the 5GHz radio of “Sitting Room”, which is quite normal.

You said the 5s were daisy-chained. Which way around? “Defect” is showing as (a) wired and (b) tertiary, which suggests it’s not connected directly to the switch.

If “Gym” is the one connected to the switch it would suggest it’s malfunctioning at the Sonos application level, but still able to switch an Ethernet signal. In that case try a factory reset.

 

Badge

I was trying to disable wifi on both Fives today.  I was able to do that for GYM but not DEFECT.  They are both eBay purchases so it is quite possible one of them is not perfect. This arvo I switched the order so that the long ethernet cable connects from managed switch to DEFECT, then DEFECT to GYM then GYM to the TP-L WAP.  Right now my Mac SONOS App shows all devices except the one called DEFECT (which is the one which I can't disable WIFI for):

Associated Product: 192.168.8.168

---------------------------------

Connect: Angus Bedroom

Serial Number: B8-E9-37-98-C8-62:C

Sonos OS: S1

Version: 11.2.3 (build 57381090)

Hardware Version: 1.17.5.5-2.0

Series ID: C100

IP Address: 192.168.8.164

WM: 0

OTP: 1.1.1(1-17-5-zp90-2.1)

---------------------------------

Play:5: Gym

Serial Number: B8-E9-37-2F-FE-02:1

Sonos OS: S1

Version: 11.2.3 (build 57381090)

Hardware Version: 1.17.4.1-2.0

Series ID: B100

IP Address: 192.168.8.163

WM: 0

OTP: 1.1.1(1-17-4-zp5s-2.1)

---------------------------------

Play:3: Kitchen

Serial Number: B8-E9-37-DB-38-D2:D

Sonos OS: S1

Version: 11.2.3 (build 57381090)

Hardware Version: 1.8.1.3-2.0

Series ID: A100

IP Address: 192.168.8.168

WM: 0

OTP:

---------------------------------

Beam: Sitting Room

Serial Number: 94-9F-3E-D3-27-31:4

Sonos OS: S1

Version: 11.2.3 (build 57381090)

Hardware Version: 1.23.1.10-2.2

Series ID: A100

IP Address: 192.168.8.161

Audio In:

WM: 0

---------------------------------

Play:1: Sitting Room (RS)

Serial Number: 94-9F-3E-86-A1-58:3

Sonos OS: S1

Version: 11.2.3 (build 57381090)

Hardware Version: 1.20.1.6-2.2

Series ID: A200

IP Address: 192.168.8.157

WM: 0

---------------------------------

Play:1: Sitting Room (LS)

Serial Number: 5C-AA-FD-2D-65-36:B

Sonos OS: S1

Version: 11.2.3 (build 57381090)

Hardware Version: 1.8.3.7-2.0

Series ID: A101

IP Address: 192.168.8.170

WM: 0

OTP:

---------------------------------

Sub: Sitting Room

Serial Number: 94-9F-3E-A2-93-96:B

Sonos OS: S1

Version: 11.2.3 (build 57381090)

Hardware Version: 1.8.6.6-2.2

Series ID: A101

IP Address: 192.168.8.169

WM: 0

OTP:

 

I will try to factory reset both FIVES tomorrow.  Thank you so much for your help.

Disabling the radio (‘WiFi’) usually requires that the device be directly connected to the network, i.e. not daisy-chained.

Badge

Your daisy chain observation is interesting as the device that I can't disable WIFI on is the first one in the chain.  This morning I did a factory reset as you suggested on both fives and as ever I can't get DEFECT to disable WIFI (it tries but cycles back to enabled) so perhaps you are right that it’s got some kind of ethernet connection issue?

I have come across a SONOS article which describes how to use the http://:1400/wifictrl?wifi=persist-off command to permanently disable WIFI (which I could use on DEFECT) but if it can't then connect via wire I fear I may inadvertently turn it in to a brick?

Here’s the latest Matrix view from the Beam:

 

The matrix shows both speakers connecting by Ethernet: switch → GYM → DEFECT. Neither has its radio disabled.

If you were trying to disable the radio in DEFECT whilst in this arrangement it would usually refuse. DEFECT would need to be wired directly.

The /wifictrl URL no longer works. The procedure was made user-accessible by including the option in the controller, wrapped up in checks and balances to stop a user from accidentally marooning a player.

Badge

So doesn't that make it odd that if both FIVES are successfully connected via wire then WIFI should be ignored and not cause issues?  

 

Pursuing the “unintentional (weak) connection to SONOS NET from the house” theory for moment. I luckily have 4 ethernet cables running to my shed.  So I will use lines 1 and 2 for the FIVEs, and line 3 for the TP-LINK WAP.. Then I will try and disable WIFI on both the FIVES, do you think that’s work a try?  

The speakers should certainly favour wired over wireless, as they’re doing at present. It’s still unclear why one or both should be disappearing, unless as I say for some reason the wired connection is flaky. That’s assuming neither has a higher level internal fault which is causing the Sonos process to hang/crash.

If you have spare lines to the shed it would certainly be work splitting them onto separate feeds in an attempt to isolate the problem(s).

Badge

Ok, so after a bit of experimenting it seems to suggest that 2 of my 4 LAN cables in to my shed are problematic.  Eventually I found 2 lines that seem good and voila not only was I able to Disable WiFi on DEFECT but I was then able to set up a completely stable stereo pair with GYM and DEFECT using the line in function from my phone, this is the first time I have ever got this to work properly in 2 years of trying :).

Interesting as the SONOS telephone help line have repeatedly told me “you can't really do stereo pair with mark 1 FIVES” and that “you definitely can not do line in with and stereo pair together”.  So I'm very pleased.

Does seem odd that you can't daisy chain a stereo pair, I will experiment more with that as it’s going to mean making yet more long ethernet cables.  Evidently you can daisy chain a WAP off a FIVE though..

Huge thanks for your help.

Well, some light at least. If you wired the terminations on the Ethernet lines yourself I would check them carefully. It’s easy to use an incorrect pinout.

The comments you had from Sonos phone support are wholly incorrect. Play:5/gen1s can of course be paired, and each of the two Line-Ins can be independently selected.

You can also daisy-chain a stereo pair, so if you were told otherwise it’s yet more nonsense.

Badge

“You can also daisy-chain a stereo pair, so if you were told otherwise it’s yet more nonsense.”  OK so do you think it’s worth me trying that now that I've managed to Disable WiFi on both FIVES..

If you want to daisy-chain, based off a known-good feed to the shed, it should work fine.

Do you actually need to wire the second Play:5 though? Now that you have a working arrangement I would (a) re-enable the radios on both Play:5s and (b) wire just one of them, ideally the left unit. The wireless one should simply connect to the wired one. 

Badge

Ok but isn't that going total back to where we started, ie if I enable WIFI on DEFECT it will somehow try to connect wirelessly to the BEAM in the house and thus all the dropping out starts again?

No, because you now -- hopefully -- have a solid Ethernet connection from the house. The evidence suggests that your original problems stemmed from a flaky wired connection.