echo from Playbar

  • 28 November 2020
  • 1 reply
  • 1133 views

My playbar sound is echoing. Watching the sports and when the presenters talk over music or other sounds it really echos. When the background noise on tv is silent the speech is perfect and no echo from playbar. Tried tuning and play 1s which are in surround mode. Tv speakers are off


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

 Hi @RIvieralad, thank you for reaching out to us, and welcome to the Sonos community. I appreciate you for bringing this concern to us as well as the steps you have performed. Let me help you out.

Let me suggest the following steps to see if this would work for you.

1. Unplug the optical cable from the Sonos Playbar and the TV. 
2. Unplug the power cable from your TV, the Sonos Playbar, and any connected audio source (such as a cable box or video game console). Wait 30 seconds before you plug them back in.
3. Reconnect the optical cable to your TV and the Sonos Playbar. Inspect the optical cable to ensure it’s not bent or kinked and check to see that it’s fully inserted into both devices.
4. Update the TV’s software (if available)
5. Adjust the group audio delay - Settings > System > Tap your Sonos Beam > Group Audio Delay and then choose a delay option.
6. Check for Sonos update - Settings > System > Check for updates.
7. Remove and re-add surround speakers from your Playbar.

After performing the steps above and you're still experiencing the same, please submit a diagnostic report and post here the confirmation number to check your system functionality and to further assist you with this.

Let us know how you get on with the advice above. We'll wait for your reply.