Answered

Audio skips every 3rd track like clockwork!

  • 18 August 2022
  • 13 replies
  • 123 views

Badge

I own a yoga studio and have 6 Play 3’s, a Connect, and a Boost. The issue I have is very specific and I am not sure how to resolve it. Inernet speeds are in excess of 350MB consistently.

 

What happens is that when you play a song, the next song in the queue will play just fine, but the following or 3rd song will not play, and I will get a message that says “connection to Spotify was lost” then switches tracks to the 4th song. In a studio where the next song being in sync is very important this is a big issue that comes and goes. Anyone heard of this?

I have tried deleting everything then reassigning it all back, this works for a short period then back we are back to this.

 

I have tried resetting both the router and modem to no avail. For a studio this is a difficult problem but one that is so specific that there must be a solution to this, any ideas?

 

Best!

icon

Best answer by Airgetlam 18 August 2022, 07:59

View original

13 replies

Userlevel 7

Do you experience this issue with any other music service or is it just when you use Spotify? Have you tried unplugging all of your Sonos devices for a couple of minutes?

Just as discussed in your other thread, there are essentially three potential reasons. 

First is an issue with Spotify’s servers. It is important to recognize that the servers that Spotify has told the Sonos system to point to is a different server than Spotify uses for other streams, such as their own app, or even web access.

Second could be some sort of wifi interference .  Oth regular WiFi connection, as well as SonosNet could be affected by this, for the purposes of interference, they’re the same, both radio signal.

Third, albeit less likely, could be a duplicate IP address issue in your network, where some device is fighting to get access to the same IP address as one of your speakers. The quick and easy, although more temporary fix for this is a simple network refresh, completed by unplugging all Sonos devices from power, then rebooting your router. Once the router comes back up, plug back in all Sonos devices to power. If that indeed resolves the issue, I would encourage figuring out how to set up reserved IP addresses in your router’s software. 

However, anything posted by the community is going to be an educated guess at best, you’re more likely to get detailed information by submitting a system diagnostic within 10 minutes of experiencing this problem, and calling Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution. Only Sonos employees can access this file, it is not available to we users on the forum.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Userlevel 7
Badge +21

It would be interesting to see if this issue happens when using a local Music Library, Setting one up is usually fairly simple and as a test will let you see if it is a local or remote service issue.

https://support.sonos.com/s/article/257?language=en_US

More help:

https://support.sonos.com/s/global-search/music%20library?language=en_US

Badge

Thanks for the tips guys! I tried changing Sonos Net to a different channel then shut everything down, powered off all speakers and systems. After I rebooted, we are back in business and the audio for now is working.

 

Agreed I should submit a diagnostic report when this happens again. Truly appreciate all the support!

Based on that, I do suspect some sort of wifi interference , potentially from outside your network, although it’s hard to tell what the source is from anecdotal data, which is all we have.

i’d also go the extra step of setting up reserved IP addresses in your router’s table, just to be on the safe side. Has nothing to do whatsoever with interference, but it does avoid potential duplicate IP address, if the router gets into a “bad” state. Sonos tends to expose that more often, merely because the software update process forces a reboot of the speakers, at which time they ask the router for a new IP address. Most other devices don’t do that kind of thing, or at least not as frequently as Sonos tends to. 

Badge

@Airgetlam great suggestion, I will setup reserved IP as this problem happens often and this is maybe why it's happening. Not sure how to setup reserved IPs but I will take a dive in

Should be explained in the manual for your router. 

Badge

Well, that lasted about a month! The Audio Skip, is back to every third song! And I am back to being a DJ for the class. 

 

This problem is so specific, there must be some kind of explanation, any other thoughts out there? I have done a hard reset on the Router, and the modem to no avail.

 

Thanks for any help

This is highly speculative, but as it seems to be related to server connections you might try changing DNS servers in your router. The following link explains how to change to Google Public DNS

https://support-en.wd.com/app/answers/detailweb/a_id/47533

This is a very early speculation on my part: In a system that I’m familiar with, playing Internet radio has become problematic. I’m beginning to wonder if a player is experiencing an intermittent hardware fault. If this player is a Group member, the hardware fault could result in various issues for the Group. Again, this is pure speculation, prompted by a comment from SONOS Support, and involves older players. I’m also entertaining the idea of an intermittent network switch.

As a diagnostic, systematically power down one of your players and operate your system for a while. Keep a good written log of events or you’ll probably go crazy trying to remember what happened.

Please report back because I’m interested in your results.

Badge

I managed to resolve the issue by unplugging all 6 of the Play3s, 2 symfonisks, Connect, and Boost. Upon restart of the devices the 3rd track skip is gone, and we are back to normal! 

 

After this, it would seem that something is happening at the product level and not the router/modem level. Now I need to figure out which product is causing it. I would say it is not the Boost or the Connect because I noticed the issue before I added those, in fact I added the Boost to resolve the issue, which it clearly did not. At best I can narrow it down to one of the 6 play3’s and just one of the Symfonisk (I added the 2nd one recently).

 

Best thing to do is next time this happens, start unplugging each device one at a time then plug it back in and see if the issue resolves.

I’d suggest to the contrary, that it’s still a duplicate IP address issue, which becomes obfuscated when you reboot the Sonos devices, and force them to get new IP addresses from a compromised DHCP table on the router. I’d continue to recommend that you set up reserved IP addresses for your Sonos devices at the least, or you’ll probably be dealing with this issue again after the next Sonos update, which exposes this issue in your router. 

Badge

I’d suggest to the contrary, that it’s still a duplicate IP address issue, which becomes obfuscated when you reboot the Sonos devices, and force them to get new IP addresses from a compromised DHCP table on the router. I’d continue to recommend that you set up reserved IP addresses for your Sonos devices at the least, or you’ll probably be dealing with this issue again after the next Sonos update, which exposes this issue in your router. 

Good point, I have noticed the issue typically resurfaces after an update. I will follow your previous instructions on how to create reserved IP addresses. I will see what I can do to isolate to which product is causing it. 

Reply