Turntable connection to Sonos Connect

  • 8 February 2021
  • 5 replies
  • 96 views

  • Contributor I
  • 2 replies

I was able to connect my Denon turntable to my Sonos system using the Sonos Connect when I bought them back in 2015. I had an issue with the wi-fi that would interfere with the Connect. I have since moved and have tried to reconnect the same turntable to the same Sonos Connect without success. The turntable does show as being connected on Line-in but when I play it there is no sound. Have tried turning the TV on, tried turning the streaming service on, tried plugging into other ports but get nothing. Denon turntable has white and red audio cable that I have plugged into in-jack on Connect.

any ideas?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Have you switched on your turntable’s phono preamp?

There is no switch to turn it on or off. I assume it’s always on. I did disconnect the Connect and reconnected it to the system. I was then able to play the album. I played one song on one album and came back a few hours later to play it for my wife. It did not play. I assume the interference from the wi-fi is still the issue.

Userlevel 7

What specific model is your Denon turntable?

Denon DP-300F

Userlevel 7

Have you tried rebooting your router? Can you connect your Connect (or any of your Sonos speakers) to your router or network with an ethernet cable?

If all else fails, you could try resetting your Connect: https://support.sonos.com/s/article/1096?language=en_US