Answered

2 second delay removed?

  • 29 April 2024
  • 8 replies
  • 144 views

The only way I could connect my Connect and Move so that they would be in perfect sync with each other was to have my two devices (turntable and CD player) go through a splitter then to the Connect and THEN to my receiver. The only downside of that was a 2 second delay so on the CD player having music start or stop 2 seconds later wasn't a big deal but it was weird putting the needle down on a record and not hearing anything for two seconds. But today I went to put a record on and…. NO delay?!?! Was something updated without my noticing it??

icon

Best answer by jgatie 3 May 2024, 19:53

View original

8 replies

Userlevel 7
Badge +14

Hello @tinpanalley, welcome to the Sonos Community!

I’m not quite sure I understand what you are experiencing. Could you please clarify?

The Sonos Connect and Sonos Move should play in sync when grouped within the Sonos App.

I don't know how else to clarify it. It's just the way the systems are built that you will have a delay in the audio if you go from the Connect to a receiver like we do. It takes two seconds to hear audio after you drop a needle, or press pause, etc. 

If you have the device go through the Connect (and Move via WiFi) and then from the connect to the receiver your receiver audio and the Move audio are in sync but the sound is delayed by 2 seconds.

If you just have the audio from the receiver (which has the device as an input) go through the Connect then you get the receiver audio instantly and the Connect/Move has the delay and then the Move and wherever the Connect and receiver out of sync.

So we set it up that the device (turntable) goes through the Connect first and also outputs to the receiver. Delay, but no loss of sync between the Move and the Connect and receiver.

What I'm asking is… all of a sudden, that 2 second delay is no longer there and I'd like to know what happened? Was there an update? Was that fixed? Surely someone at Sonos knows what I'm talking about.

(And could you remove the “answer” tag? I didn't select that as an answer. Thanks!)

The delay can be adjusted down to 75 ms by going to Settings > System > (Line-In device name) > Line-In and adjusting the Audio Delay setting.  

The delay can be adjusted down to 75 ms by going to Settings > System > (Line-In device name) > Line-In and adjusting the Audio Delay setting.  

So is that a adjustment a new thing? Because it wasn't there before. But I'm telling you, there is NO delay now. I just want Sonos to tell me why that is.

So is that a adjustment a new thing? Because it wasn't there before. But I'm telling you, there is NO delay now. I just want Sonos to tell me why that is.

 

Not brand new; as I recall, it came out a few years ago.  And there is a delay now.  The minimum delay has always been 75 ms. 

So is that a adjustment a new thing? Because it wasn't there before. But I'm telling you, there is NO delay now. I just want Sonos to tell me why that is.

 

Not brand new; as I recall, it came out a few years ago.  And there is a delay now.  The minimum delay has always been 75 ms. 

So strange… ok, then I guess something was impeding me from having no delay in the past unless, as I a said, I passed everything through the receiver first and then the connect, but then the connect and Move were out of sync. Strange that this seems an unknown thing when so many of us work around it on other audio forums. I wonder if there's a way to talk to tech people at Sonos who might be more aware of the phenomenon.

Userlevel 7
Badge +15

There were reports a little while back where it was said that you could reset a speaker and then setup line-in autoplay etc. and then disconnect the speaker from the network (so the speaker ‘thinks’ there’s no requirement for a delay as nothing to sync to) and the delay was gone.  Doesn’t sound like what you’ve done though?  There was general surprise that it hadn’t been discovered before but don’t think it was 100% confirmed - although I co-incidentally read something recently where someone else said they had followed this and it worked for them.

EDIT: this was the link I mentioned.

I'm the person who asked the question and I just want to make it clear here that I neither chose the best answer as an answer, nor is it an answer to my question. The forum mods just want to ensure I guess that there's an answer to everything. So if you're having the same problem or question, you will find countless people asking about this on unofficial communities like facebook and reddit and the usual tech forums.
Ultimately, it looks like some update finally got rid of this buggy delay that Sonos themeselves weren't aware of. Either way it now seems fixed but I don't know what fixed it nor why the bug was there in the first place or if it was just the way it worked. Either way, you can now go into your receiver and then to the Connect.
Before, going into the receiver with inputs and then out to the Connect caused the shared music to another wireless speaker through the Connect to be delayed by 2 seconds from the music coming from the receiver and the speakers of the receiver. The alternative was to make the audio sources all go into the Connect first and then out to the receiver. But while that corrected the sync issue, it left everything at a 2 seconds delay which was particular weird when dropping a needle and just irritating when controlling a CD player with a remote.

THIS is a proper answer to this question. And Sonos should ask first before deciding for a user what they want the answer to be to a question. Also, sometimes posts are just discussions. 

Reply