Answered

line in drop out blues

  • 11 November 2018
  • 12 replies
  • 320 views

my line in / audio input drops out in the evenings. I run my record player, via its own independent amp, into a ConnectAmp, supported by a Boost. The audio compression is set to compressed. I still get drop-out. It has just started however after an update... any ideas? I may have to go back to cables otherwise, this is no fun.
icon

Best answer by Edward R 12 November 2018, 12:18

Hi there. This is likely due to WiFi interference. This is often the cause of audio playback issues. If those links don't work, not to worry, we can certainly get to the bottom of this for you. Following any occurrence of this issue, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause. Many thanks in advance.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Userlevel 7
Badge +19
Hi there. This is likely due to WiFi interference. This is often the cause of audio playback issues. If those links don't work, not to worry, we can certainly get to the bottom of this for you. Following any occurrence of this issue, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause. Many thanks in advance.
Currently experiencing this same issue. I have a new set of Play 5's with a sub, and a pair of Play 1's with a sub, and experience severe dropouts whenever playing vinyl via line in. I've switch the router to channel 1, disabled the auto channel on the router, and switched to compressed (none of that helped). I submitted a diagnostic just now 1285907953
Currently experiencing this same issue. I have a new set of Play 5's with a sub, and a pair of Play 1's with a sub, and experience severe dropouts whenever playing vinyl via line in. I've switch the router to channel 1, disabled the auto channel on the router, and switched to compressed (none of that helped). I submitted a diagnostic just now 1285907953Maybe try switching to a different wifi channel or maybe try running your system in Wired/Boost/SonosNet mode as mentioned in this link:

Switching a Sonos Household between Standard & BOOST mode & vice versa
This also happens to me but only with line in! Can be quite frustrating sometimes. I am in a small apartment so it's hard to imagine wifi issues are the cause. Same issue persisted even after I upgraded my service and router.
Also worth setting the line in input device to be 'Airplay device' even though it isn't. This increases the buffering available and can sometimes smooth out choppy sound. Are you playing the line-in audio through the 5s and 1s by grouping? Or just through the 1s by setting them as the Autoplay room?
I've got a connect and two play 3 speakers set up and I have autoplay turned on. I've tried with autoplay turned off but still get the same issue. Also to note, I have to really crank the volume to get the line in to be audible. I'm pushing my tv output through a nice pre amp so I also find this frustrating since I put so much effort and cash into setting this up so I could use Sonos as my home theatre. It's weird since normally the Sonos is usually so bloody loud lol. Having said all that, I'll try the AirPlay thing 🆒
Actually John B's is a much better suggestion. It’s certainly worth trying that. See screenshot.

You may have to close and reopen the App after making the line-in change, also note you can actually edit the Line-In Source Name after selecting the AirPlay option. Just over-type and change its name to something more appropriate like 'Turntable' etc.
Regarding volume, have you set the line-in level setting as high as it will go? (You may have to set this again anyway after selecting Airplay device.)

Regarding TV, Sonos never intended line-in to be used for TV audio, although it can be done.
Thanks for the suggestions all. I realize that this issue is not a new one, and has been covered ad infinitum here. That said, it was pretty bad for me, and getting worse. I switched to channel 6, and dedicated more router real estate to Sonos (just upgraded to an Amplifi HD mesh network router), and it seems to have done the trick. For now.....going to spin records for a few hours and see.
Just to clarify, the name had nothing to do with it right? I just switched to "airplay" line in level so I'll see how that goes after a month or so since my issue is intermittent. Thanks for the suggestions folks!
Just to clarify, the name had nothing to do with it right? I just switched to "airplay" line in level so I'll see how that goes after a month or so since my issue is intermittent. Thanks for the suggestions folks!No, the other way around. Select 'Airplay Device' as the Line-in source name from the dropdown. This will automatically set the Linein source level to 4, but you should change that to whatever level works best for you. The line-in level will have zero effect on the robustness of your line-in performance.