Answered

Spotify won't connect to Alexa

  • 15 November 2018
  • 7 replies
  • 24713 views

I have spent an hour trying to reconnect my Spotify account to both Sonos and Alexa so that I can say, "Alexa, play 'XYZ' on Spotify." It then tells me to connect my Spotify account to starting with my Alexa app but EVERYTHING IS CONNECTED AND I AM LOGGED IN. I have tried uninstalling both apps, I have disconnected the service from the speakers, I have even checked my Spotify account to ensure I am in fact premium, even though I know I am, and sure enough, that's fine too. I literally cannot figure out the problem. That all being said, I can't ask my speakers to play Spotify but I can open the Spotify app on both my laptop and phone and connect to my Sonos speakers from there. THIS IS SO FRUSTRATING. HELP.
icon

Best answer by Skelly.7 15 November 2018, 18:13

You are not alone...



https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-spotify-needs-to-be-linked-but-it-is-already-linked-6815395



Moderator Note: The original issue was caused by an outage which has long since been resolved. This response has been selected as the new Best Answer to this topic, as it's more likely to be helpful. If you suspect you are experiencing an issue as a result of an outage, please click here to view the outage status of all of our services.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

You are not alone...

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-spotify-needs-to-be-linked-but-it-is-already-linked-6815395

Moderator Note: The original issue was caused by an outage which has long since been resolved. This response has been selected as the new Best Answer to this topic, as it's more likely to be helpful. If you suspect you are experiencing an issue as a result of an outage, please click here to view the outage status of all of our services.
Userlevel 7
Badge +20
HI there,

We'll update the thread linked by Skelly.7 when the outage is resolved.
Me too !
Diagnostic ref 1200057472
Userlevel 7
Badge +20
Me too !
Diagnostic ref 1200057472


Hi

Has this only just stopped working or has it never worked? If it's only just stopped please see below my standard Alexa troubleshooting steps:

Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Hi
It’s a new addition.
I have a sound bar and two play 1
The Sonos one is for the kitchen to replace an echo dot and a play 1(now in the living room with the other making a rear pair for the bar.
Before and still the dot will take the command to play from Spotify and happily do it.
The one just asks me to link my Spotify premium account in the Alexa app.
Done that and removed it and put it back but still the one says the same thing.
Also from the Alexa app it shows it a speaker?
Hope that helps
Userlevel 7
Badge +20
If you open the Alexa App>Music, Video & Books>Spotify>Go To Spotify App does it take you to the same Spotify account as you have registered within the Sonos App?
Yep