Answered

Spotify premium not working with Alexa on Sonos One


I just got a Sonos One, linked my Spotify account on Sonos app, linked the same spotify account on Alexa app and made spotify as default. I can confirm that the spotify account is linked correctly on both Sonos and Alexa. When I say Alexa play music from Spotify, Alexa says to play Spotify first link spotify premium account to the alexa app. Can someone please help
icon

Best answer by pradystar 17 November 2018, 09:45

Okay! I was able to get this working. Removed smart device from amazon account, signed out of all amazon apps on my phone, reset sonos one and tried the whole setup again. I think if the setup is right you should at least see the following three listings on your alexa app -> devices section - 1. "your account name" Sonos One (account info) 2. "Your room name" (room info) 3. "Your speaker name"

View original

3 replies

Same problem as you pradystar. I first noticed it last night, still the same this morning. I have tried relinking the account but no joy.
Okay! I was able to get this working. Removed smart device from amazon account, signed out of all amazon apps on my phone, reset sonos one and tried the whole setup again. I think if the setup is right you should at least see the following three listings on your alexa app -> devices section - 1. "your account name" Sonos One (account info) 2. "Your room name" (room info) 3. "Your speaker name"
Thanks, I'll give it a try when I get home.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings