Answered

Spotify playback via Alexa is always 'shuffled'


Badge
I recently shuffled a Spotify Playlist via Alexa, with the command 'shuffle release radar playlist on office'. This worked OK, but now whenever I attempt to play back any Spotify Album via Alexa, it is always shuffled too. The shuffle setting is turned off in my app.
icon

Best answer by AndyF66 13 March 2018, 16:31

Some progress...

Alexa seems to have the concept of a 'shuffle mode' state per room. If you play a playlist via

Alexa shuffle Discover Weekly Playlist in Office

This seems to implicitly turn shuffle mode on for that room. You can turn it on and off with

Alexa turn on shuffle mode (in room) / turn off shuffle mode (in room)

So, If I issue the commands

- Alexa shuffle Discover Weekly Playlist in Office
[Playlist plays shuffled]
- Alexa play Discover Weekly playlist in Office
[Playback happens in SHUFFLED ORDER]
- Alexa turn off shuffle mode in bedroom
- Alexa play Discover Weekly playlist in Office
[Playback happens in proper order, not shuffled]

I've not found a command to report the current shuffle mode state.

This should all be documented somewhere!

View original

6 replies

Userlevel 4
Badge +3
Hi, AndyF66. I've noticed this behaviour myself, it's not common but it can occur. For me, rebooting the speaker resolved it. Can you give that a try and report back if there's no difference?
Badge
I've never managed to fix this. Playlists played in my bedroom via Alexa are *still* always shuffled. This is after may updates of client and firmware, and multiple reboots... All because I once shuffled a playlist with Alexa, a very long time
Badge
Is there an Alexa keyword to force it be specifically NOT shuffled? I've noticed it's the same playlist that is 'stuck' in shuffle mode .
Userlevel 4
Badge +3
Interesting... Which playlist is it? I'd like to test that myself.
Badge
I'm testing with my "Discover Weekly" playlist, curated each week by Spotify. I just tested it again in a room that a I'd not shuffled in previously...

Alexa play Discover Weekly Playlist in Office
- Correctly starts at first track

Alexa play Discover Weekly Playlist in Office
- Correctly starts at first track

Alexa shuffle Discover Weekly Playlist in Office
- Starts at random track as expected

Alexa shuffle Discover Weekly Playlist in Office
- Starts at different random track as expected

Alexa play Discover Weekly Playlist in Office
- NOW STARTS AT RANDOM TRACK

Alexa play Discover Weekly Playlist in Office
- NOW STARTS AT RANDOM TRACK

There is now no apparent way to get it to play that playlist via Alexa and it not be shuffled. Playlist playback is however still OK via the Sonos App. Could it be a setting on the Spotify App itself? Im not sure how they interact?
Badge
Some progress...

Alexa seems to have the concept of a 'shuffle mode' state per room. If you play a playlist via

Alexa shuffle Discover Weekly Playlist in Office

This seems to implicitly turn shuffle mode on for that room. You can turn it on and off with

Alexa turn on shuffle mode (in room) / turn off shuffle mode (in room)

So, If I issue the commands

- Alexa shuffle Discover Weekly Playlist in Office
[Playlist plays shuffled]
- Alexa play Discover Weekly playlist in Office
[Playback happens in SHUFFLED ORDER]
- Alexa turn off shuffle mode in bedroom
- Alexa play Discover Weekly playlist in Office
[Playback happens in proper order, not shuffled]

I've not found a command to report the current shuffle mode state.

This should all be documented somewhere!

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings