Answered

Spotify not playing through Alexa

  • 10 February 2021
  • 2 replies
  • 9732 views

Hi Needs some advice here...!

I have 2 Sonos One’s separated, one called kitchen for obvious reasons the other dinning room.

 

Both play trough the Sonos app, BBC Sound s App and intune app. However if I’m in the kitchen and I ask Alexa to play a song. She says playing song by UB40 on Spotify. However it plays on the Dinning room not the kitchen

 

Therefore I did a Factory reset on each speaker naming each one Kitchen and Dinning Room. The problem I have now, is that neither speaker will no longer play Spotify through alexa. My Sonos app say it playing but there is no sound.

 

My router is on Sky UK if this makes a difference any help greatly appreciated 

icon

Best answer by GuitarSuperstar 10 February 2021, 23:01

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

See if any of these changes will fix your problem:

  • Remove Spotify from your music services in the Sonos app and re-add it.
  • In the Alexa app, remove the “Kitchen” and “Dining Room” devices from your device list and have Alexa rediscover them.
  • Disable the Sonos skill in the Alexa app and re-enable it.
  • Reboot your router.
Userlevel 7
Badge +20

In addition to the steps from @GuitarSuperstar please don't factory reset your devices unless recommended by Sonos or someone experienced within this forum, as it removes all diagnostic information.

You appear to have two issues:

1/ playing Spotify via voice:

Please check that Spotify is set up as the default music service within the Alexa App/settings. Normally Disabling then Enabling the Sonos skill in the Sonos App will resolve this issue;

2/ outputting music to the correct speaker:

When initiating music via Alexa, the control on what speakers output that audio is controlled by the set-up of Alexa Groups/speakers and Alexa device. Can you open your Kitchen group and ensure that your Sonos One is selected as the Alexa device and is also identified in the Speaker section. (If you would like audio to be output in the Dinning Room as well, then select both in the Speakers section). You'll need to do the same for the Dinning Room group with the respective devices as well.