Answered

Sonos Skill asking me to link speakers to my account (but already linked)

  • 26 January 2019
  • 12 replies
  • 2164 views

I have a playbar, three play 3's, a sub, and a play 5. I previously had alexa and sonos working well together until my play 5 failed (stopped communicating wirelessly). Sonos replaced the defective play 5, and when I added it to my system Alexa would not discover the new device (the rest worked fine).

After I followed instructions from several different threads trying to check all of the basic things (no duplicate names, all user profile info is filled out accurately, etc) the next step was to disable and re-enable the sonos skill which is where I've hit a wall. Now Alexa and my sonos system no longer integrate. Sonos is otherwise fully functional and works fine with my other music services and TV.

The sonos skill will not enable and tells me "You need to link speakers to myaddress@email.com before you can add this skill". Of course my speakers are already linked to the account because it's fully functional, but I still logged into my sonos account and confirmed the email address, password, home address, etc., and I went into the sonos app and "forgot" any sonos devices, powered them all down, powered up the wired one first (playbar), and then powered up the rest. I even tried transferring my sonos account to the same email address just to try it, but I still get the same frustrating message (asking me to link my already linked speakers). Not sure where to go from here (fyi, I am desperately trying to avoid "forgetting all devices" in my alexa app, or deleting the alexa app because I use it to control a bunch of other devices in my house and I'm not looking to throw a grenade into this already opened can of worms). Any direction would be greatly appreciated.
icon

Best answer by sean-a-thon 22 May 2019, 20:00

Update. I got it to work, I had to go in and delete all my Sonos devices from the "Devices" tab in the Alexa app. After that I was able to enable the skill.
Same issue for me as well. "Register your speakers" "You need to link speakers to your account before you can add this skill" . Speakers are already linked.
View original

12 replies

Userlevel 7
Badge +19
Hello there, mikedep. If you are still having trouble getting Alexa up and running on Sonos, I would recommend giving our support technicians a call to have someone take a closer look in real time. They may be able to see what is going on when Sonos and Alexa are trying to connect.
I'm facing this exact issue at the moment.
Did you find a solution to the problem ?
Userlevel 7
Hi nikolaSsvedndsen

The thread you posted in is two months old. I suggest you start your own post and provide more information about your specific issue with Sonos and Alexa. We'd love to help :)

Cheers!
Userlevel 2
Badge +1
I have the same issue. same problems, same checks.
What is going on here? i can't add any voice services.
Same problem here! Has anyone figured this out?
I have the same issue. Adding the Sonos skill to Alexa causes an error to be displayed:

Register your speakers

You need to link speakers to your *** Sonos account before you can add this skill



The speakers have already been registered to the right account.
Same issue here... had Alexa hooked up fine; switched to google after the release came out yesterday and it worked fine. Today out of no where the 1 of my 2 beams wouldn’t turn off the tv it’s connected too. I deleted the Sonos Skill from google assistant app and now trying to re-add the skill and it’s telling me to register my speakers but they have been for over a year... deleted the Sonos app, deleted the google assistant app, and reset my router. Nothing is fixing this. Now none of my Sonos products are hooked up via google assistant. Very frustrating. How do we fix this?!?!?

i also have made sure all apps and products are up to date.
It appears to be a system outage with Alexa, Google Assistant and Spotify. Spent the last hour restarting router, reinstalling Alexa, Sonos and Spotify app until I decided to check the live status..

https://status.sonos.com/
It appears to be a system outage with Alexa, Google Assistant and Spotify. Spent the last hour restarting router, reinstalling Alexa, Sonos and Spotify app until I decided to check the live status..

https://status.sonos.com/

Thanks, I will blame it on this for the time being. I installed two new Ones today and neither will execute any commands via Alexa. They will listen and repeat commands but won’t play any music. I.e. “Alexa, play music”. She will say “Playing your playlist on Apple Music” but then silence.

I tried disabling and reenabling the Sonos skill and also forgot Alexa in the Sonos app. My speakers are all linked to my account on the Sonos app but Alexa won’t let me add the skill as it is saying that they are not.

@Sonos team, is the outage the cause of this issue for all of us?
Same issue for me as well. "Register your speakers" "You need to link speakers to your account before you can add this skill" . Speakers are already linked.
Update. I got it to work, I had to go in and delete all my Sonos devices from the "Devices" tab in the Alexa app. After that I was able to enable the skill.
Same issue for me as well. "Register your speakers" "You need to link speakers to your account before you can add this skill" . Speakers are already linked.

Reply