Answered

Sonos Shows as offline in Amazon Alexa App and wont play to Sonos Play 3

  • 6 October 2017
  • 16 replies
  • 13935 views

Hello,

Needing some help, My sonos play 3 is all connected upto Alexa and Sonos however, I cant control it via Alexa as it keeps saying my Sonos is Offline.

Sonos is working fine via the Sonos App and I cant figure out how to get it to show online and work via Alexa - Any ideas?
icon

Best answer by tmellis 9 October 2017, 19:50

This worked for me:
1. Sign in to your Alexa account
2. Display "Your Skills"
3. Disable Sonos skill
4. Enable Sonos skill; sign in to your account again
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

Submit a diagnostic and post the reference number here. Better yet, for direct access to the beta engineers, submit a diagnostic and fill out the beta feedback form here:

https://sonos.custhelp.com/app/beta
I have the same issue. I have checked the names deleted the device rescanned. Nothing seems to work. I have 8 other sonos rooms that work just fine through app but just this one single player that won't seem to connect. And it's listed as a device in the "Smart Home"list but not as a device under "Settings" it's just strange.
Userlevel 1
This worked for me:
1. Sign in to your Alexa account
2. Display "Your Skills"
3. Disable Sonos skill
4. Enable Sonos skill; sign in to your account again
Thanks tmellis, those steps worked for me 🙂 first I tried restarting all devices, no luck, then the Disable Skill method worked [1-play:3 in kitchen, 2-play:5's in living room, 2 echo ]
Still won’t work on my end. Any other suggestions? Divices were “discovered” and shows up on the Amazon app but it still says it’s “offline” when I try to play something.
I have the same issue with both our new Sonos One and our new Echo Dot. All of our 10 original Sonos speakers show up in the Alexa app, but only 5 speakers can be voice controlled by the Dot. As for the other, non-functioning 5 speakers:
- When I ask the Dot to play music in the Play Room, the Dot says, "I couldn't find anything called Play Room. To check your device or group name, go to Settings in the Alexa app." However, the Alexa app shows the Play Room speaker.
- When I ask the Dot to play music in one of the other 4 non-functioning rooms, for example, the Dot says, "Sorry, on Dining Room is offline," despite this speaker clearly being online in the Sonos app and showing up in the Alexa app.
Holly mines doing same thing am a loss what to do next it connected once then somehow has disconnected and now as you say says it’s can’t find anything ; have tried all above but to no avail very frustrating ??
Hi guys. Same issue - new Sonos One shows up as "offline" in the alexa app no matter what I do.
I just had this issue with a new Sonos One. Check and see if your Sonos has the same name as one of your Alexa devices. I added a Sonos One named "Office" (name was set in the Sonos app) to my Alexa setup. I also had an old Echo Dot that had been in my Office, which was also named Office (in the Alexa app). Alexa was showing my Sonos One as "Office Sonos", but the duplicate name was still messing things up. Once I renamed the Dot to "Dot" and the Sonos One to "Office", everything played fine.

TL;DR: check for duplicate names between your Sonos speakers and your Alexa devices!
My fix for Sonos One showing offline in Alexa app. Unplugged Sonos One for about 2 min and did set up again from very beginning to add a speaker. Sonos one now plays and accepts Alexa commands and shows online in Alexa app. Hope this helps. 😃
Badge
bear with it everyone, took me 3 days to sort and after a few reboots it works and works well
Userlevel 7
Badge +20
I suggest you reset the Sonos 1.

Disable the Sonos skill within the Alexa app;
Forget all devices under Smart Home within the Alexa app;
Select the Sonos 1 in the Sonos App and remove voice control;
Reboot your Connect if you have one;
Select Add player and link the Sonos 1 as normal;
Discover all devices under Smart Home within the Alex App;
Enable the Sonos skill within the Alexa App.

That should resolve your issue.
Resolved by disabling and re-enabling the sonos integration through the alexa app... It "just worked" the 2nd time around.
Userlevel 7
Badge +20
Also select Alexa App>Settings>Your Sonos One and you should have the option to toggle On-Line.
This worked for me:
1. Sign in to your Alexa account
2. Display "Your Skills"
3. Disable Sonos skill
4. Enable Sonos skill; sign in to your account again
Badge
Just had the same issue. Disabled the Alexa Sonos skill. Signed out of Alexa app too. Signed back into the Alexa app, enabled Sonos skill, signed back into Sonos via the Skill, seems to work fine now. Let's see if this becomes a repetitive issue. :?