Sonos Roam is with amazon assistant but not playing any music

  • 4 July 2021
  • 5 replies
  • 65 views

I have just bought a Sonos Roam! I have installed Alexa Assistant, first time work correct, then I took  the device to connect  in other Wi-Fi to use Alexa, but didn’t work! I came Back and did not work anymore. I can ask about wheather she aswers, but when i ask to Play a music , she says the name but did play nothing stay quiet.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Try rebooting the Roam by following these steps:

  1. Disconnect Roam from charging cables and remove it from wireless chargers.
  2. Hold the button on the back of Roam for at least five seconds until you hear the power-off tone and the light above the Sonos logo turns off.
  3. Wait 10 seconds.
  4. Press the button on the back of Roam to turn it back on.

Did not work! I asked to play Bon Jovi! Alexa says This is Bon Jovi in the SpotFy and the song never begins, stay quiet!

@MarcosBRA 

Maybe try the following…

  1. In the Sonos S2 App goto ‘Settings/Services and Voice/Amazon Alexa’ and remove the Alexa Assistant from your Roam room.
  2. Goto Amazon Alexa App and navigate to ‘More/Skills & Games/Your Skills’ and disable the Sonos Skill.
  3. After 5 minutes return to the Sonos App, go back to "Settings/Services and Voice” and add Alexa back to your Roam and follow all on screen instructions.

See if that quickly resolves the issue for you.

Userlevel 7

You can also try removing Spotify from your music services in the Sonos app and re-adding it. You might also try rebooting your router.

Here is a link to the another community chat with the same issue. It’s getting attention from Sonos support saying they are working with Amazon Support at the end of July 2021. Not other updates from Sonos support since then to date. 

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-sonos-roam-6857923