Sonos plays only one song at a time


Sonos Beam + 2 Sonos 1 + Sub (TV setup), separate Sonos One.

Re-occuring issue when using Alexa with Amazon Music. Sonos plays only one song from the playlist/radio etc and stops.
Saw many threads before and used a workaround few times:
https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-only-plays-one-song-at-a-time-6817646/index1.html

But currently nothing seems to be resolving this issue.
Steps from other threads no longer work and really seem to be outdated as Alexa menu changed.

10 replies

Userlevel 7
Badge +20
Did you try Step 3 in my post?
I have a support ticket open with Sonos support. Based on diagnostic report nothing wierd was seen.

So I have tried your step 3 today. Note in alexa.amazon.com in a browser I could not find option to forget all devices (step 3.2 ) please check but I don't think this option exists any more - I did not see an option to forget devices for some time now.
After power reboot of the speakers, Sonos app controller prompted me to do SW upgrade to v10.1. Not sure if that is just another patch or if one of the speakers was missing a SW component. I followed up with the upgrade. In the first instance it looked to work fine. But then when I checked app around 3min later I was prompted to do upgrade again. Tried that again and a message was displayed - SW upgrade failed, try again later. But when I used selected Done, system reported that all speakers are up to date and there are no new upgrades. Weird. After all that, issue is currently fixed - speakers have successfully played several tracks in a row from Amazon Music.
However, in the past I kept seeing this issue re-occurring every 3-5 days. I will post again when it happens.
Userlevel 7
Badge +20
FYI - Here is an updated set of steps reflecting the recent changes to the Alexa App:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
1.4/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.
1.5/ Here is a link to my naming standards: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app, select ‘Devices>All Devices'. Now select each Sonos Device in turn and click the Trash Can in the top right of the screen;
3.3/ In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to carry out step 3.8 again.
Not a full day gone by and it broke again.
I have updated Sonos support ticket and sent new diagnostics.
This is the story of last 4-5 months. I use workaround one day, 1-5 days later it breaks again.
I try workaround steps 2 or 3 again. And same story again.

It worked fine yesterday, played music all night.
Went to work, on the way home I used Amazon Music in the car.
Got back home, asked Alexa on Sonos to play music for my kids - only one song played and stopped.
Haven't tried a workaround tonight yet. Want to give Sonos support a chance to look at this issue. But this is just ridiculous.
Userlevel 7
Badge +20
I wonder if this is in some way linked to you playing Amazon Music in your car. As a test, can you reset Sonos and not play Amazon Music for a few days. If Sonos is still working after a few days, then play Amazon Music in your car and see if Sonos reverts back to only playing one track.
I fixed the system up again using step 2.3. This is quite painful as most of the speakers are powered from out of reach sockets behind sofa, behind mounted TV etc.
Still this is the only reliable way to fix the issue - worked 3 out of 3 times in last few days.

I confirmed this morning that system worked fine.

Later today I played Amazon Music playlist for kids in the car via my phone and Bluetooth.
After return home everything worked fine still. Amazon Music via Sonos, activated by Alexa - multiple tracks played with no issue.

We watched some telly with kids then. TV is hooked up via HDMI to Beam + Sub + 2xSonos Play 1 as surrounds. This group of speakers is called in my setup as TV.

Then I tried to play some Amazon Music tracks....and issue showed again.
There was also another wierd thing: Alexa is enabled on Beam (so TV) but when I asked: Alexa: Play lullabys radio.
Alexa played Amazon Music lullaby in a different room, did not play it on Beam (TV).
I was expecting Alexa to start music on TV (that was working fine in the morning).

I have fixed the system again using step 2.3
I will see how long Sonos plays well before I turn TV set again.

Note: in your step 3.2 when I tried to do this (it was also suggested by Sonos support - though they also missed that Alexa menu changed and still referred me to old menus that are no longer available) I cannot forget TV set (beam + surrounds + subs). The TV group, when selected, instead of few options + trash icon shows Pawel's Sonos Bem, Online.
When selected, I get several menu items but cannot "forget" it. Only de-register.
Userlevel 7
Badge +20
I fixed the system up again using step 2.3. This is quite painful as most of the speakers are powered from out of reach sockets behind sofa, behind mounted TV etc.
Still this is the only reliable way to fix the issue - worked 3 out of 3 times in last few days.

I confirmed this morning that system worked fine.

Later today I played Amazon Music playlist for kids in the car via my phone and Bluetooth.
After return home everything worked fine still. Amazon Music via Sonos, activated by Alexa - multiple tracks played with no issue.

We watched some telly with kids then. TV is hooked up via HDMI to Beam + Sub + 2xSonos Play 1 as surrounds. This group of speakers is called in my setup as TV.

Then I tried to play some Amazon Music tracks....and issue showed again.
There was also another wierd thing: Alexa is enabled on Beam (so TV) but when I asked: Alexa: Play lullabys radio.
Alexa played Amazon Music lullaby in a different room, did not play it on Beam (TV).
I was expecting Alexa to start music on TV (that was working fine in the morning).

I have fixed the system again using step 2.3
I will see how long Sonos plays well before I turn TV set again.

Note: in your step 3.2 when I tried to do this (it was also suggested by Sonos support - though they also missed that Alexa menu changed and still referred me to old menus that are no longer available) I cannot forget TV set (beam + surrounds + subs). The TV group, when selected, instead of few options + trash icon shows Pawel's Sonos Bem, Online.
When selected, I get several menu items but cannot "forget" it. Only de-register.


Do you have an Amazon App or device connected to the Beam - could this be signed into another Amazon account? What mobile device are you using the Alexa App on? My Android App shows a Trash can against my PlayBar + 2 Surrounds...
I don't have any other account. Though my original Amazon account was created in the UK. I moved to Australia 6 years ago and had my Amazon account changed (I had to delete all association with UK amazon account, credit cards etc). Only after I did that I was able to associate same email address with my new Amazon account for Australia. And only then I was able to create and pay for Amazon Music with Australian subscription and as per regional deal that was going on at that time.

In the browser I could not see Device menu in the Smart Home settings.

Today I did the following:
Asked Alexa: Alexa, what account this is?
Reply was: I am not sure who is speaking but you are in Pawel's account.
So all good.

I did logout from both Alexa app and Alexa account in the browser.
Logged on manually again.

In the browser I now can see Smart Home -> Devices.
All 4 devices are listed: TV, Children, Bedroom and Playroom
And I have options to Forget against each one of them.

in the app though, situation has not changed. I see all 4 devices + Alexa on this phone.
Alexa on the phone shows Online. Children, Playroom and Bedroom - when selected have a trash icon and only a few options.
TV is still different
When selected I get Pawel's Sonos Beam Online
When I select it I get very different menu:
General
- Audio Controls
- Do not disturb
- Communication
- Location
- Time zone
- Follow-up mode
- Measurements units
- Registered to (with option to Deregister)
- About
No trash icon

All other speakers show:
About
- Connected via
- Description
- Type
- Enabled (with option to disable)
And all have trash icon

Today, system has no issue, but - we did not watch TV today. I really think when I switch on TV it will all change again. Will test this tomorrow.
Sonos Beam + 2 Sonos 1 + Sub (TV setup), separate Sonos One.

Re-occuring issue when using Alexa with Amazon Music. Sonos plays only one song from the playlist/radio etc and stops.
Saw many threads before and used a workaround few times:
https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-only-plays-one-song-at-a-time-6817646/index1.html

But currently nothing seems to be resolving this issue.
Steps from other threads no longer work and really seem to be outdated as Alexa menu changed.


Update:
Around 13th April I tried full system reset:
- removed all devices from smart home skills
- disabled Sonos skill in Alexa
- removed Alexa from all devices
- logged off and uninstalled Alexa app as well as all other Amazon apps
- in Sonos I dismantled TV setup pairing (Beam, surrounds, sub)
- I then performed factory resets on all Sonos devices
- I then rebuild the Sonos system from scratch, used brand new room names for all devices
- installed Alexa and tried to activate this on the TV system with Beam
This all failed at this step. I cannot add Alexa to Beam any more. It shows the speaker but has it offline and keeps failing adding Alexa

I contacted Sonos support. Followed all the steps they suggsted (again, remove devices, change room name etc) but nothing helped. I repeated UKMedia steps (full deregistration steps 3) but that also did not help. I cannot now add Alexa to Beam.
Sonos support replied 14th April saying that they are looking into this issue and will contact me if they find resolution.

I have not heard from them since.

I decided to enable Alexa on a Sonos One in adjacent room. That worked fine and I can now control my Sonos system using Alexa from kids room. Also - issue with Amazon Music playing only one track from a playlist has not been seen since.

I would still prefer to have Alexa on Beam as lounge where it is located is where we spend most of the time.
Sadly it looks that Sonos and Alexa on Beam is having quite a few issues. I hope Sonos will be able to work it out eventually.
And the latest update:
Sonos support contacted me couple of days ago and mentioned new software upgrade that contains fix for the issue I had with re-activation of Alexa on the Beam speaker.
I have Auto SW upgrade enabled, so by the time I tried my Sonos App was already upgraded.
With new sw version I had no issues with adding Alexa back to Beam. Hurrah.

Also, so far Alexa seems to always play all the tracks. I was using it a lot over last 2 days, also ensured I use Beam with TV and in various groping between rooms - so far everything works fine.

Ever since I enabled Alexa and started using Amazon Music on Sonos Beam (over 3 months ago) I had nearly daily issues with Alexa. I spent more than 18h in troubleshooting and applying workarounds. During one go with a workaround involving power-down all the speakers the old Play 1 died and I had to pay for its replacement as it was really old and out of warranty.
My day job is testing radio access network software for mobile telecoms - I have bags of experience in system testing and troubleshooting. Glad that after all that ordeal system so far appears to be in good shape. I don't think I would have strength to go through same slow and painful process to get another fix in.

I really hope Sonos can improve their interface with Alexa as well as diagnostics on the issues seen by other users.

regards
sobuc




Sonos Beam + 2 Sonos 1 + Sub (TV setup), separate Sonos One.

Re-occuring issue when using Alexa with Amazon Music. Sonos plays only one song from the playlist/radio etc and stops.
Saw many threads before and used a workaround few times:
https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-only-plays-one-song-at-a-time-6817646/index1.html

But currently nothing seems to be resolving this issue.
Steps from other threads no longer work and really seem to be outdated as Alexa menu changed.


Update:
Around 13th April I tried full system reset:
- removed all devices from smart home skills
- disabled Sonos skill in Alexa
- removed Alexa from all devices
- logged off and uninstalled Alexa app as well as all other Amazon apps
- in Sonos I dismantled TV setup pairing (Beam, surrounds, sub)
- I then performed factory resets on all Sonos devices
- I then rebuild the Sonos system from scratch, used brand new room names for all devices
- installed Alexa and tried to activate this on the TV system with Beam
This all failed at this step. I cannot add Alexa to Beam any more. It shows the speaker but has it offline and keeps failing adding Alexa

I contacted Sonos support. Followed all the steps they suggsted (again, remove devices, change room name etc) but nothing helped. I repeated UKMedia steps (full deregistration steps 3) but that also did not help. I cannot now add Alexa to Beam.
Sonos support replied 14th April saying that they are looking into this issue and will contact me if they find resolution.

I have not heard from them since.

I decided to enable Alexa on a Sonos One in adjacent room. That worked fine and I can now control my Sonos system using Alexa from kids room. Also - issue with Amazon Music playing only one track from a playlist has not been seen since.

I would still prefer to have Alexa on Beam as lounge where it is located is where we spend most of the time.
Sadly it looks that Sonos and Alexa on Beam is having quite a few issues. I hope Sonos will be able to work it out eventually.

Reply